summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Smith <matt@offtopica.uk>2021-10-17 10:25:42 +0100
committerNick Sarnie <sarnex@gentoo.org>2021-10-21 19:50:03 -0400
commit19c4471fabfdb23a8a2ca6a3f7cbf2dfb11bbceb (patch)
treeeb25d8809925a1231d74ca4caa7e7e9053003d16 /dev-libs/tree-sitter-typescript
parentdev-libs/tree-sitter-scala: Init at 0.19.0 (diff)
downloadgentoo-19c4471fabfdb23a8a2ca6a3f7cbf2dfb11bbceb.tar.gz
gentoo-19c4471fabfdb23a8a2ca6a3f7cbf2dfb11bbceb.tar.bz2
gentoo-19c4471fabfdb23a8a2ca6a3f7cbf2dfb11bbceb.zip
dev-libs/tree-sitter-typescript: Init at 0.20.0
Package-Manager: Portage-3.0.26, Repoman-3.0.3 Signed-off-by: Matt Smith <matt@offtopica.uk> Signed-off-by: Nick Sarnie <sarnex@gentoo.org>
Diffstat (limited to 'dev-libs/tree-sitter-typescript')
-rw-r--r--dev-libs/tree-sitter-typescript/Manifest1
-rw-r--r--dev-libs/tree-sitter-typescript/metadata.xml15
-rw-r--r--dev-libs/tree-sitter-typescript/tree-sitter-typescript-0.20.0.ebuild15
3 files changed, 31 insertions, 0 deletions
diff --git a/dev-libs/tree-sitter-typescript/Manifest b/dev-libs/tree-sitter-typescript/Manifest
new file mode 100644
index 000000000000..3074115ad29a
--- /dev/null
+++ b/dev-libs/tree-sitter-typescript/Manifest
@@ -0,0 +1 @@
+DIST tree-sitter-typescript-0.20.0.tar.gz 769336 BLAKE2B 12f5ac1f29963eda7a34d08832ca263cf91fd6a8335c998d9d1795851bd30d4a43ade36d004ffcb287c73b63e691582a79d640e24050df4f778fa308f5b0665e SHA512 99cbcabf58717eb17346b2139320f0d13846f1f335a81ed01fee6e748cd0d867218a9cc8d216162c3b9b9da86487024bedbced67e91adadab207633c25dc7e1a
diff --git a/dev-libs/tree-sitter-typescript/metadata.xml b/dev-libs/tree-sitter-typescript/metadata.xml
new file mode 100644
index 000000000000..f486929bd436
--- /dev/null
+++ b/dev-libs/tree-sitter-typescript/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>matt@offtopica.uk</email>
+ <name>Matthew Smith</name>
+ </maintainer>
+ <maintainer type="person" proxied="proxy">
+ <email>sarnex@gentoo.org</email>
+ <name>Nick Sarnie</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">tree-sitter/tree-sitter-typescript</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-libs/tree-sitter-typescript/tree-sitter-typescript-0.20.0.ebuild b/dev-libs/tree-sitter-typescript/tree-sitter-typescript-0.20.0.ebuild
new file mode 100644
index 000000000000..a504afd74bf7
--- /dev/null
+++ b/dev-libs/tree-sitter-typescript/tree-sitter-typescript-0.20.0.ebuild
@@ -0,0 +1,15 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+TS_PV=rust-0.20.0
+inherit tree-sitter-grammar
+
+DESCRIPTION="TypeScript grammar for Tree-sitter"
+HOMEPAGE="https://github.com/tree-sitter/tree-sitter-typescript"
+S="${WORKDIR}"/${PN}-${TS_PV}/typescript/src
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"