summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2020-03-19 16:24:36 -0400
committerCraig Andrews <candrews@gentoo.org>2020-03-19 16:24:55 -0400
commit0e6efca5ec5d0a4878f228f481ae22e09cf8d507 (patch)
treec5cdf1438825c879955a0cf953f91e60b1ad63ea /dev-libs/spdlog/spdlog-1.3.1.ebuild
parentprofiles: remove USE="cxx" from the base profile (diff)
downloadgentoo-0e6efca5ec5d0a4878f228f481ae22e09cf8d507.tar.gz
gentoo-0e6efca5ec5d0a4878f228f481ae22e09cf8d507.tar.bz2
gentoo-0e6efca5ec5d0a4878f228f481ae22e09cf8d507.zip
dev-libs/spdlog: Cleanup old version
Package-Manager: Portage-2.3.94, Repoman-2.3.21 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'dev-libs/spdlog/spdlog-1.3.1.ebuild')
-rw-r--r--dev-libs/spdlog/spdlog-1.3.1.ebuild41
1 files changed, 0 insertions, 41 deletions
diff --git a/dev-libs/spdlog/spdlog-1.3.1.ebuild b/dev-libs/spdlog/spdlog-1.3.1.ebuild
deleted file mode 100644
index 69ab5a2e653a..000000000000
--- a/dev-libs/spdlog/spdlog-1.3.1.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake
-
-DESCRIPTION="Very fast, header only, C++ logging library"
-HOMEPAGE="https://github.com/gabime/spdlog"
-
-if [[ ${PV} == *9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/gabime/spdlog"
-else
- SRC_URI="https://github.com/gabime/spdlog/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64"
-fi
-
-LICENSE="MIT"
-SLOT="0/1"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
- dev-libs/libfmt:0/5
-"
-RDEPEND="${DEPEND}"
-
-PATCHES=( "${FILESDIR}/${PN}-1.0.0-unbundle-fmt.patch" )
-
-src_configure() {
- rm -r include/spdlog/fmt/bundled || die
-
- local mycmakeargs=(
- -DSPDLOG_BUILD_EXAMPLES=no
- -DSPDLOG_BUILD_BENCH=no
- -DSPDLOG_BUILD_TESTS=$(usex test)
- )
-
- cmake_src_configure
-}