summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2023-03-02 08:50:43 +0000
committerPatrick Lauer <patrick@gentoo.org>2023-03-02 08:53:57 +0000
commitd46ef5409051d8a325ff959f94c10b6981f6ebbb (patch)
tree08a246cb9f9d4391443c89b1b59e8c59d6a4422e /dev-libs/rocr-runtime
parentapp-emacs/ddskk: Don't use ${ED} in src_prepare (diff)
downloadgentoo-d46ef5409051d8a325ff959f94c10b6981f6ebbb.tar.gz
gentoo-d46ef5409051d8a325ff959f94c10b6981f6ebbb.tar.bz2
gentoo-d46ef5409051d8a325ff959f94c10b6981f6ebbb.zip
dev-libs/rocr-runtime: Fix version detection
This breaks rocm_bandwidth_test and others downstream as they compare to an internal version string. This silently breaks if git is not installed, so fix it to always be correct. Closes: https://bugs.gentoo.org/894064 Signed-off-by: Patrick Lauer <patrick@gentoo.org>
Diffstat (limited to 'dev-libs/rocr-runtime')
-rw-r--r--dev-libs/rocr-runtime/rocr-runtime-5.4.3-r1.ebuild (renamed from dev-libs/rocr-runtime/rocr-runtime-5.4.3.ebuild)5
1 files changed, 5 insertions, 0 deletions
diff --git a/dev-libs/rocr-runtime/rocr-runtime-5.4.3.ebuild b/dev-libs/rocr-runtime/rocr-runtime-5.4.3-r1.ebuild
index f408d4213314..f6a8a5598f2a 100644
--- a/dev-libs/rocr-runtime/rocr-runtime-5.4.3.ebuild
+++ b/dev-libs/rocr-runtime/rocr-runtime-5.4.3-r1.ebuild
@@ -44,6 +44,11 @@ src_prepare() {
# Gentoo installs "*.bc" to "/usr/lib" instead of a "[path]/bitcode" directory ...
sed -e "s:-O2:--rocm-path=${EPREFIX}/usr/lib/ -O2:" -i image/blit_src/CMakeLists.txt || die
+ # internal version depends on git being present and random weird magic, otherwise fallback to incoherent default value
+ # fix default value to be more better
+
+ sed -i -e "s:1.7.0:${PV}:" CMakeLists.txt || die
+
cmake_src_prepare
}