summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Kenzelmann <gentoo@k8n.de>2019-12-07 16:23:26 +0100
committerJoonas Niilola <juippis@gentoo.org>2019-12-08 15:35:20 +0200
commitf4768f465acc530c2038bef926b394d45d717231 (patch)
tree74bdff7fd6f40f9d857555ac0584124595499c86 /dev-libs/pigpio
parentmedia-libs/gegl: 0.4.18 fix skipping mipmap tests (diff)
downloadgentoo-f4768f465acc530c2038bef926b394d45d717231.tar.gz
gentoo-f4768f465acc530c2038bef926b394d45d717231.tar.bz2
gentoo-f4768f465acc530c2038bef926b394d45d717231.zip
dev-libs/pigpio: new version 72 new upstream version, revbump, small adjustment to confd file
Signed-off-by: Daniel Kenzelmann <gentoo@k8n.de> Closes: https://github.com/gentoo/gentoo/pull/13905 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-libs/pigpio')
-rw-r--r--dev-libs/pigpio/Manifest1
-rw-r--r--dev-libs/pigpio/files/pigpiod.confd2
-rw-r--r--dev-libs/pigpio/pigpio-72.ebuild39
3 files changed, 41 insertions, 1 deletions
diff --git a/dev-libs/pigpio/Manifest b/dev-libs/pigpio/Manifest
index 9cff9ed247c9..f1e73f8d5cc7 100644
--- a/dev-libs/pigpio/Manifest
+++ b/dev-libs/pigpio/Manifest
@@ -2,3 +2,4 @@ DIST pigpio-67.tar.gz 369268 BLAKE2B a9d59369f5eed4b733e0e5c0e85013a132e55ff63a2
DIST pigpio-68.tar.gz 371251 BLAKE2B c0118854d18ce158a3d5c96380289cc8bc68f35f72ce28f207dfbb827f97f538acd82cec2af11590e59985b77ef08834d55b3ac7578e1f6b6d1a0b5d5d594632 SHA512 125364eab9dd33c39fda148c6018679ac91b099914d7f0c6362f61566a9c957065189ace03ad4668b29f25d4d542b81d42c0befe0712867b48977b755dc03edc
DIST pigpio-70.tar.gz 374569 BLAKE2B a2caadf0e1307c8c3ce936d5fd4d31e18185aa53900f6b2cf8b92a31f423b9a82bf4d2b7212fa8cd5b2d26773598a138ef8331884410f3f418542f43ca1fe2d4 SHA512 00db37b9c0f9751e6179b19e7018583abd9e11d78d01ff9f99b713004cf4e6a224e93644206599378a34dd46fd75c08557021b706015b0bc2bd8b34e363691db
DIST pigpio-71.tar.gz 374952 BLAKE2B a79a408915285674211e50e30d3cafa433a9ee364cacced501e109d6c31a3a03c14f9d25c3c18e3df252801de65c60ca67cd5f1a8e08f05be8098ad591a14fee SHA512 c3bf029bebff9a7ee02b48597f624a5dcdf277c5c1a7ffa2f6cb83885a93cd6713935d9502127d11c4e9c11e7f6f6be49c8af367707eca2fff469728b5248e2f
+DIST pigpio-72.tar.gz 384220 BLAKE2B ff3466df80adb6ee9bb2f6bc8aa9589bb6789746eedfab410d2a23dcd4986c29297f71469c8330c55603d8aabba7a4b2171390a63c21a12464b45cc4e24645d8 SHA512 c090962cb11204774e4a97a3dec37146882d66abef4d3e4de62e116b64650d6c66f95646f6350e3a45d8b2ba261a8d16c74f7648869cd0e94f42a80d88bb6d6e
diff --git a/dev-libs/pigpio/files/pigpiod.confd b/dev-libs/pigpio/files/pigpiod.confd
index dbcf8a4c3efc..02c1442322ca 100644
--- a/dev-libs/pigpio/files/pigpiod.confd
+++ b/dev-libs/pigpio/files/pigpiod.confd
@@ -1,4 +1,4 @@
# Only listen on local interface by default
# use evironment variables PIGPIO_PORT="8888" and PIGPIO_ADDR="::1" for pigs with local interface
# PIGPIOD_OPTS="-l -p 8888"
-PIGPIOD_OPTS="-l"
+PIGPIOD_OPTS="-l -n 127.0.0.1"
diff --git a/dev-libs/pigpio/pigpio-72.ebuild b/dev-libs/pigpio/pigpio-72.ebuild
new file mode 100644
index 000000000000..f4a86cfd1b13
--- /dev/null
+++ b/dev-libs/pigpio/pigpio-72.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
+
+inherit distutils-r1 systemd toolchain-funcs
+
+DESCRIPTION="A library for the Raspberry which allows control of the GPIOs"
+HOMEPAGE="http://abyz.me.uk/rpi/pigpio/index.html"
+SRC_URI="https://github.com/joan2937/pigpio/archive/V${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~arm"
+IUSE="python"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+src_prepare() {
+ eapply "${FILESDIR}/${PN}-70-makefile.patch"
+ eapply_user
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" STRIP=: STRIPLIB=: SIZE=:
+ use python && distutils-r1_src_compile
+}
+
+src_install() {
+ emake DESTDIR="${D}" LDCONFIG=: PYTHON2=: PYTHON3=: \
+ libdir="${EPREFIX}/usr/$(get_libdir)" prefix="${EPREFIX}/usr" \
+ mandir="${EPREFIX}/usr/share/man" install
+ einstalldocs
+ newinitd "${FILESDIR}"/pigpiod.initd pigpiod
+ newconfd "${FILESDIR}"/pigpiod.confd pigpiod
+ systemd_newunit "${FILESDIR}"/pigpiod.systemd pigpiod.service
+ use python && distutils-r1_src_install
+}