summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-12-16 08:37:15 +0000
committerJoonas Niilola <juippis@gentoo.org>2023-12-16 11:53:24 +0200
commit4a8259d53400b26766eec198df9ca9cf9dae9668 (patch)
tree00686351cc65dd26868c6005d9d79f73fcaf2472 /dev-libs/nss
parentdev-libs/nss: fix bitness check for LTO (diff)
downloadgentoo-4a8259d53400b26766eec198df9ca9cf9dae9668.tar.gz
gentoo-4a8259d53400b26766eec198df9ca9cf9dae9668.tar.bz2
gentoo-4a8259d53400b26766eec198df9ca9cf9dae9668.zip
dev-libs/nss: disable seccomp sandbox for file(1) in bitness check
We just built the file that file(1) is being used on, so it's entirely safe. We don't need the sandboxing here which leads to a confusing error if file(1) bails out. Bug: https://bugs.gentoo.org/915890 Signed-off-by: Sam James <sam@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/34308 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-libs/nss')
-rw-r--r--dev-libs/nss/nss-3.96.ebuild2
1 files changed, 1 insertions, 1 deletions
diff --git a/dev-libs/nss/nss-3.96.ebuild b/dev-libs/nss/nss-3.96.ebuild
index 35503a7b5874..68af01795644 100644
--- a/dev-libs/nss/nss-3.96.ebuild
+++ b/dev-libs/nss/nss-3.96.ebuild
@@ -114,7 +114,7 @@ nssbits() {
# TODO: Port this to toolchain-funcs tc-get-ptr-size/tc-get-build-ptr-size
echo > "${T}"/test.c || die
${cc} ${!cppflags} ${!cflags} -fno-lto -c "${T}"/test.c -o "${T}/${1}test.o" || die
- case $(file "${T}/${1}test.o") in
+ case $(file -S "${T}/${1}test.o") in
*32-bit*x86-64*) echo USE_X32=1;;
*64-bit*|*ppc64*|*x86_64*) echo USE_64=1;;
*32-bit*|*ppc*|*i386*) ;;