summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-06-10 09:47:34 +0100
committerSam James <sam@gentoo.org>2023-06-10 09:52:06 +0100
commit0890fb435855f121706704fb56c40053c22dc075 (patch)
treeee92b77770127d19e41d134da456ed2bf0b2e8cf /dev-libs/libtraceevent
parentapp-editors/micro: drop 2.0.9 (diff)
downloadgentoo-0890fb435855f121706704fb56c40053c22dc075.tar.gz
gentoo-0890fb435855f121706704fb56c40053c22dc075.tar.bz2
gentoo-0890fb435855f121706704fb56c40053c22dc075.zip
dev-libs/libtraceevent: fix tests
Depend on cunit for tests and pass the emake args consistently. Closes: https://bugs.gentoo.org/852689 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/libtraceevent')
-rw-r--r--dev-libs/libtraceevent/libtraceevent-1.7.2.ebuild15
1 files changed, 12 insertions, 3 deletions
diff --git a/dev-libs/libtraceevent/libtraceevent-1.7.2.ebuild b/dev-libs/libtraceevent/libtraceevent-1.7.2.ebuild
index a572e944cacb..7e83bab0bd27 100644
--- a/dev-libs/libtraceevent/libtraceevent-1.7.2.ebuild
+++ b/dev-libs/libtraceevent/libtraceevent-1.7.2.ebuild
@@ -18,13 +18,18 @@ fi
LICENSE="LGPL-2.1"
SLOT="0"
-IUSE="doc"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
RDEPEND="
!<dev-util/trace-cmd-3.0
"
BDEPEND="
- doc? ( app-text/xmlto app-text/asciidoc )
+ doc? (
+ app-text/asciidoc
+ app-text/xmlto
+ )
+ test? ( dev-util/cunit )
"
src_configure() {
@@ -39,7 +44,11 @@ src_configure() {
src_compile() {
emake "${EMAKE_FLAGS[@]}"
- use doc && emake doc
+ use doc && emake "${EMAKE_FLAGS[@]}" doc
+}
+
+src_test() {
+ emake "${EMAKE_FLAGS[@]}" test
}
src_install() {