summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authororbea <orbea@riseup.net>2022-06-17 16:10:18 -0700
committerSam James <sam@gentoo.org>2022-06-18 00:44:53 +0100
commit9fa0feab9df77f5fe7014cbf6f4dd9451fd2e42c (patch)
treeb82ca77e8a81f8cf44ec11ec44bcb45a60423a6d /dev-libs/libmaa
parentapp-admin/ansible-modules-hashivault: disable py3.11 (diff)
downloadgentoo-9fa0feab9df77f5fe7014cbf6f4dd9451fd2e42c.tar.gz
gentoo-9fa0feab9df77f5fe7014cbf6f4dd9451fd2e42c.tar.bz2
gentoo-9fa0feab9df77f5fe7014cbf6f4dd9451fd2e42c.zip
dev-libs/libmaa: Fix the build with rlibtool
The configure.in lacks LT_INIT which generates libtool and allows the build to work with rlibtool which depends on this file to determine if it should build shared or static libraries. Closes: https://bugs.gentoo.org/778464 Signed-off-by: orbea <orbea@riseup.net> Closes: https://github.com/gentoo/gentoo/pull/25947 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/libmaa')
-rw-r--r--dev-libs/libmaa/files/libmaa-1.3.2-libtool.patch55
1 files changed, 55 insertions, 0 deletions
diff --git a/dev-libs/libmaa/files/libmaa-1.3.2-libtool.patch b/dev-libs/libmaa/files/libmaa-1.3.2-libtool.patch
new file mode 100644
index 000000000000..bbdecdd89e62
--- /dev/null
+++ b/dev-libs/libmaa/files/libmaa-1.3.2-libtool.patch
@@ -0,0 +1,55 @@
+https://bugs.gentoo.org/778464
+
+From: orbea <orbea@riseup.net>
+Date: Fri, 17 Jun 2022 15:59:49 -0700
+Subject: [PATCH] configure: Add missing LT_INIT
+
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -27,6 +27,7 @@ VERSION=$(MAA_MAJOR).$(MAA_MINOR).$(MAA_TEENY)
+ .SUFFIXES:
+ .SUFFIXES: .c .o
+
++top_builddir= @top_builddir@
+ srcdir= @srcdir@
+ VPATH= @srcdir@
+ prefix= @prefix@
+--- a/configure.in
++++ b/configure.in
+@@ -28,6 +28,8 @@ AC_INIT
+ AC_CONFIG_SRCDIR([maa.h])
+ AC_CONFIG_HEADER(config.h)
+
++LT_INIT
++
+ MAA_MAJOR=1
+ MAA_MINOR=3
+ MAA_TEENY=2
+@@ -38,7 +40,7 @@ echo .
+ AC_CANONICAL_HOST
+ AC_PROG_AWK
+ AC_PROG_CC
+-#AC_PROG_LIBTOOL
++AC_PROG_LIBTOOL
+ AC_ISC_POSIX
+
+ if test "$CC" = gcc; then
+@@ -57,8 +59,6 @@ AC_CHECK_PROGS(DVIPS,dvips)
+ AC_CHECK_PROGS(REFBIBTEX,refbibtex)
+ AC_CHECK_PROGS(BIBTEX,bibtex)
+
+-AC_CHECK_PROG(LIBTOOL,libtool,libtool)
+-
+ echo .
+ echo Checking for header file support
+
+--- a/doc/Makefile.in
++++ b/doc/Makefile.in
+@@ -22,6 +22,7 @@
+
+ .SUFFIXES:
+
++top_builddir= @top_builddir@
+ srcdir= @srcdir@
+ VPATH= @srcdir@
+ prefix= @prefix@