summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-03-30 13:10:12 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-03-30 15:39:39 +0200
commitcab29240303bac0c4a6ccf13ae15fd6ab9abf408 (patch)
tree3b09063f028b2ba9b3facad644a3689f78247b30 /dev-libs/libfastjson
parentnet-irc/rbot: enable ruby30 (diff)
downloadgentoo-cab29240303bac0c4a6ccf13ae15fd6ab9abf408.tar.gz
gentoo-cab29240303bac0c4a6ccf13ae15fd6ab9abf408.tar.bz2
gentoo-cab29240303bac0c4a6ccf13ae15fd6ab9abf408.zip
dev-libs/libfastjson: bump to 0.99.9.1
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-libs/libfastjson')
-rw-r--r--dev-libs/libfastjson/Manifest1
-rw-r--r--dev-libs/libfastjson/libfastjson-0.99.9.1.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-libs/libfastjson/Manifest b/dev-libs/libfastjson/Manifest
index d05dabe0f415..2390c247e4ff 100644
--- a/dev-libs/libfastjson/Manifest
+++ b/dev-libs/libfastjson/Manifest
@@ -1,2 +1,3 @@
DIST libfastjson-0.99.8.tar.gz 433819 BLAKE2B f988c01de8e7becc5a848825c18151fec2b80f81eb5b50e459b1a3bb535f5521fb63e9350eb133eb984f57f42c5f529220a0c9461eb4689e1421ad815c4c4d87 SHA512 1e7eb7eaae2c6ccb78b77ac883808e1d311b03bad083dc72ab7712765a2ed139accd762850d60f54c6fe0ad48c4385714818fd2c8ed76700ce3546e5aff1c823
+DIST libfastjson-0.99.9.1.tar.gz 89468 BLAKE2B 6922c482043499d5c39845c5d8db12a956c7820c15514eed7e4a0ba74f24b68c4cb580ea53f215a965de4b2e6fe70d07e5a14dee09f52725f88328de279dd62a SHA512 32b513fb66ac5a54b0a3d028fabffad5d675fe50475ddd834de45c69eb0a60f83f85a0706071e5d61df25fb09a3de65ac37c295a620a65801782e0f24d033d41
DIST libfastjson-0.99.9.tar.gz 436502 BLAKE2B 5ed542f373dee2e28c85f8b48e9d35c7727d7e565c691f90caed7a9ac1192814c6371e03bce18dd9765b4251e6a78b7e612eeb38872d2833cd72021d41fb889a SHA512 90505fba033179aa92f12ac5dbbb071f69f3491de5bbbbb46d553b08ac325448459c9e33ba22ef4f9db0bae4496cca60046eebf6325d70b045c1a0a9845b0d48
diff --git a/dev-libs/libfastjson/libfastjson-0.99.9.1.ebuild b/dev-libs/libfastjson/libfastjson-0.99.9.1.ebuild
new file mode 100644
index 000000000000..67b402d40b7a
--- /dev/null
+++ b/dev-libs/libfastjson/libfastjson-0.99.9.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Fork of the json-c library, which is optimized for liblognorm processing"
+HOMEPAGE="https://www.rsyslog.com/tag/libfastjson/"
+SRC_URI="https://github.com/rsyslog/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0/4.3.0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc64 ~riscv ~sparc ~x86"
+IUSE="static-libs"
+
+BDEPEND=">=sys-devel/autoconf-archive-2015.02.04"
+
+DOCS=( AUTHORS ChangeLog )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local -a myconf=(
+ $(use_enable static-libs static)
+ --disable-rdrand
+ --enable-compile-warnings=yes
+ )
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+
+ find "${ED}"/usr/lib* -name '*.la' -delete || die
+}