summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-10-28 19:42:23 +0100
committerSam James <sam@gentoo.org>2022-10-28 19:47:45 +0100
commit6ad52b98bb917767184bcb25cce0a7289d2c2832 (patch)
tree792154dcc6e2133257c1d8513e9d8b25830fb47d /dev-libs/libbase58
parentdev-libs/jansson: drop multilib (diff)
downloadgentoo-6ad52b98bb917767184bcb25cce0a7289d2c2832.tar.gz
gentoo-6ad52b98bb917767184bcb25cce0a7289d2c2832.tar.bz2
gentoo-6ad52b98bb917767184bcb25cce0a7289d2c2832.zip
dev-libs/libbase58: drop multilib
No multilib reverse dependencies. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/libbase58')
-rw-r--r--dev-libs/libbase58/libbase58-0.1.4-r2.ebuild (renamed from dev-libs/libbase58/libbase58-0.1.4-r1.ebuild)30
1 files changed, 15 insertions, 15 deletions
diff --git a/dev-libs/libbase58/libbase58-0.1.4-r1.ebuild b/dev-libs/libbase58/libbase58-0.1.4-r2.ebuild
index 80dc047c83be..11e8cf11ea37 100644
--- a/dev-libs/libbase58/libbase58-0.1.4-r1.ebuild
+++ b/dev-libs/libbase58/libbase58-0.1.4-r2.ebuild
@@ -1,15 +1,15 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit autotools multilib-minimal
+inherit autotools
DESCRIPTION="C implementation of Bitcoin's base58 encoding"
HOMEPAGE="https://github.com/luke-jr/libbase58"
-LICENSE="MIT"
-
SRC_URI="https://github.com/luke-jr/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
SLOT="0/0"
KEYWORDS="amd64 ~arm ~mips ~ppc ~ppc64 x86"
IUSE="test tools"
@@ -20,35 +20,35 @@ RDEPEND="tools? ( dev-libs/libgcrypt )"
DEPEND="${RDEPEND}
test? (
app-editors/vim-core
- dev-libs/libgcrypt[${MULTILIB_USEDEP}]
+ dev-libs/libgcrypt
)
"
src_prepare() {
- eapply_user
- eautoreconf
+ default
- # NOTE: Needed because test suite uses srcdir instead of builddir to set PATH and for
- # multilib support.
- multilib_copy_sources
+ eautoreconf
}
-multilib_src_configure() {
+src_configure() {
local myeconf=(
- --disable-static
LIBGCRYPT_CONFIG="${EPREFIX}/usr/bin/${CHOST}-libgcrypt-config"
)
- if multilib_is_native_abi && use tools; then
+
+ if use tools; then
myeconf+=( --enable-tool )
elif use test; then
myeconf+=( --enable-tool --bindir='/TRASH' )
else
myeconf+=( --disable-tool )
fi
+
econf "${myeconf[@]}"
}
-multilib_src_install_all() {
+src_install() {
+ default
+
if use test; then
# It's hard to control this directory with multilib_is_native_abi && use tools, hence -f.
rm -rf "${ED}/TRASH" || die