summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-10-31 09:40:15 +0000
committerSam James <sam@gentoo.org>2021-10-31 09:40:15 +0000
commitecd47ee00dd11dd0a398e14ad53ea5d1e6d3e427 (patch)
tree5e5cd219bb426d10caa415a19a0f15211ce2e648 /dev-libs/hiredis
parentdev-libs/hiredis: fix 1.0.2 subslot (diff)
downloadgentoo-ecd47ee00dd11dd0a398e14ad53ea5d1e6d3e427.tar.gz
gentoo-ecd47ee00dd11dd0a398e14ad53ea5d1e6d3e427.tar.bz2
gentoo-ecd47ee00dd11dd0a398e14ad53ea5d1e6d3e427.zip
dev-libs/hiredis: drop 1.0.1-r1
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/hiredis')
-rw-r--r--dev-libs/hiredis/Manifest1
-rw-r--r--dev-libs/hiredis/hiredis-1.0.1-r1.ebuild87
2 files changed, 0 insertions, 88 deletions
diff --git a/dev-libs/hiredis/Manifest b/dev-libs/hiredis/Manifest
index 51fbe74315c9..017828759b4c 100644
--- a/dev-libs/hiredis/Manifest
+++ b/dev-libs/hiredis/Manifest
@@ -1,4 +1,3 @@
DIST hiredis-0.14.1.tar.gz 64372 BLAKE2B 9846b05e21bfadb876e26ab45bf5c29a3283b602ef725dfbd877815be690bb5579551f0c452e1d8abf9ae985f6b71408a3b86b343ca5d6dce58dd4897640996a SHA512 a7310f2d65075df0c17636a0220e16487759471a3442b1de2595ab747565f6b6262e37131613b13e396b31050bcbe5529c35d420cd43fd7d500d9d563d469c4f
DIST hiredis-1.0.0.tar.gz 97507 BLAKE2B 247852d53be96e36dbdd7d4d8cfbda4406aa66281f26c28c3f80ab4593679122fd59430b2d5f04d20126b4459fc75af0a1fd67f1ee1db691d8db575debad2b61 SHA512 eb56201121eecdbfc8d42e8c2c141ae77bea248eeb36687ac6835c9b2404f5475beb351c4d8539d552db4d88e933bb2bd5b73f165e62b130bb11aeff39928e69
-DIST hiredis-1.0.1.tar.gz 97937 BLAKE2B 476bb3607aabe2147eead61c98de325f4dbd2d7c7439513ea0cd98980fc151a64798647757e46feb61e8914e47b42963bf128c938c94c42c448369065532166f SHA512 87909f78171cf4deeb3d030484b55fbd1a7f7f27f33636f90e169a900ddc5c5ec447d2df34739ada3cf35a50d647cb4fcbe2754f4521d18f770f1cf8ed962909
DIST hiredis-1.0.2.tar.gz 98139 BLAKE2B 86d872cfec3d4e925d5d68e4f4faf1301aa6d706bd0406a8080471e14afc2c25db13b9a0937d29baccd457611af8e46922b5379183c7470c9ae1860aac3af096 SHA512 86497a1c21869bbe535378885eee6dbd594ef96325966511a3513f81e501af0f5ac7fed864f3230372f3ac7a23c05bad477fa5aa90b9747c9fb1408028174f9b
diff --git a/dev-libs/hiredis/hiredis-1.0.1-r1.ebuild b/dev-libs/hiredis/hiredis-1.0.1-r1.ebuild
deleted file mode 100644
index b1397aa2a4d0..000000000000
--- a/dev-libs/hiredis/hiredis-1.0.1-r1.ebuild
+++ /dev/null
@@ -1,87 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit toolchain-funcs
-
-DESCRIPTION="Minimalistic C client library for the Redis database"
-HOMEPAGE="https://github.com/redis/hiredis"
-SRC_URI="https://github.com/redis/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/1.0.1"
-KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ppc ppc64 ~riscv ~s390 sparc x86 ~x64-solaris"
-IUSE="examples ssl static-libs test"
-RESTRICT="!test? ( test )"
-
-DEPEND="ssl? ( dev-libs/openssl:= )"
-RDEPEND="${RDEPEND}"
-BDEPEND="test? ( dev-db/redis )"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.0.0-disable-network-tests.patch
-)
-
-src_prepare() {
- default
-
- # use GNU ld syntax on Solaris
- sed -i -e '/DYLIB_MAKE_CMD=.* -G/d' Makefile || die
-}
-
-_build() {
- emake \
- AR="$(tc-getAR)" \
- CC="$(tc-getCC)" \
- PREFIX="${EPREFIX}/usr" \
- LIBRARY_PATH="$(get_libdir)" \
- USE_SSL=$(usex ssl 1 0) \
- DEBUG_FLAGS= \
- OPTIMIZATION= \
- "$@"
-}
-
-src_compile() {
- # The static lib re-uses the same objects as the shared lib, so
- # overhead is low w/creating it all the time. It's also needed
- # by the tests.
- _build dynamic static hiredis.pc
-}
-
-src_test() {
- local REDIS_PID="${T}"/hiredis.pid
- local REDIS_SOCK="${T}"/hiredis.sock
- local REDIS_PORT=56379
- local REDIS_TEST_CONFIG="
- daemonize yes
- pidfile ${REDIS_PID}
- port ${REDIS_PORT}
- bind 127.0.0.1
- unixsocket //${REDIS_SOCK}
- "
-
- _build hiredis-test
-
- "${EPREFIX}"/usr/sbin/redis-server - <<< "${REDIS_TEST_CONFIG}" || die
- ./hiredis-test -h 127.0.0.1 -p ${REDIS_PID} -s ${REDIS_SOCK}
- local ret=$?
-
- kill "$(<"${REDIS_PID}")" || die
- [[ ${ret} != "0" ]] && die "tests failed"
-}
-
-src_install() {
- _build PREFIX="${ED}/usr" install
-
- if ! use static-libs ; then
- find "${ED}" -name '*.a' -delete || die
- fi
-
- insinto /usr/$(get_libdir)/pkgconfig
- doins ${PN}.pc
-
- local DOCS=( CHANGELOG.md README.md )
- use examples && DOCS+=( examples )
- einstalldocs
-}