summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/gecode
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/gecode')
-rw-r--r--dev-libs/gecode/Manifest1
-rw-r--r--dev-libs/gecode/gecode-3.7.3.ebuild52
-rw-r--r--dev-libs/gecode/metadata.xml13
3 files changed, 66 insertions, 0 deletions
diff --git a/dev-libs/gecode/Manifest b/dev-libs/gecode/Manifest
new file mode 100644
index 000000000000..a9908f77b332
--- /dev/null
+++ b/dev-libs/gecode/Manifest
@@ -0,0 +1 @@
+DIST gecode-3.7.3.tar.gz 1643336 SHA256 e7cc8bcc18b49195fef0544061bdd2e484a1240923e4e85fa39e8d6bb492854c SHA512 292bafeaca3911b8af40d7c0f425cf0263f4408afad47f4f229a821ce89d06dc69ad1feeeef72531a1e711d797d249581b67c2d9cfdc9e544240012c838d2a5b WHIRLPOOL 5aad39285c73e2d918fca98b694b33e00b11fcc21d542a37e23424acc381696f20826d6c28a33a5cde8fbfdfd4254d05791f2db903903306887e4c4fdecb7104
diff --git a/dev-libs/gecode/gecode-3.7.3.ebuild b/dev-libs/gecode/gecode-3.7.3.ebuild
new file mode 100644
index 000000000000..74c441827401
--- /dev/null
+++ b/dev-libs/gecode/gecode-3.7.3.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+DESCRIPTION="Gecode is an environment for developing constraint-based systems and applications"
+SRC_URI="http://www.gecode.org/download/${P}.tar.gz"
+HOMEPAGE="http://www.gecode.org/"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples gist"
+
+DEPEND="gist? (
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ media-libs/freetype
+ media-libs/libpng
+ >=dev-libs/glib-2
+)"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf \
+ --disable-examples \
+ $(use_enable gist qt) \
+ $(use_enable gist)
+}
+
+src_compile() {
+ default
+ use doc && emake doc
+}
+
+src_install() {
+ default
+
+ if use doc; then
+ dohtml -r doc/html/
+ einfo "HTML documentation has been installed into " \
+ "/usr/share/doc/${PF}/html"
+ fi
+
+ if use examples; then
+ docinto examples
+ doins examples/*.cpp
+ einfo "Example C++ programs have been installed into " \
+ "/usr/share/doc/${PF}/examples"
+ fi
+}
diff --git a/dev-libs/gecode/metadata.xml b/dev-libs/gecode/metadata.xml
new file mode 100644
index 000000000000..572f73ec811a
--- /dev/null
+++ b/dev-libs/gecode/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <use>
+ <flag name="gist">
+ Enable Gist, the Gecode Interactive Search Tool
+ </flag>
+ </use>
+</pkgmetadata>
+