summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2018-03-11 11:40:39 +0100
committerDavid Seifert <soap@gentoo.org>2018-03-11 11:40:39 +0100
commit1e3bbc4851a42b8d7f3076bf214152b380fdbfec (patch)
tree21a986a0c346064f11e326e471d07d1b62ce268e /dev-libs/cppcodec
parentdev-cpp/catch: Version bump to 2.2.0 (diff)
downloadgentoo-1e3bbc4851a42b8d7f3076bf214152b380fdbfec.tar.gz
gentoo-1e3bbc4851a42b8d7f3076bf214152b380fdbfec.tar.bz2
gentoo-1e3bbc4851a42b8d7f3076bf214152b380fdbfec.zip
dev-libs/cppcodec: Initial ebuild
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-libs/cppcodec')
-rw-r--r--dev-libs/cppcodec/cppcodec-9999.ebuild38
-rw-r--r--dev-libs/cppcodec/metadata.xml12
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-libs/cppcodec/cppcodec-9999.ebuild b/dev-libs/cppcodec/cppcodec-9999.ebuild
new file mode 100644
index 000000000000..61c267ce9512
--- /dev/null
+++ b/dev-libs/cppcodec/cppcodec-9999.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+: ${CMAKE_MAKEFILE_GENERATOR:=ninja}
+inherit cmake-utils
+
+DESCRIPTION="C++11 library to encode/decode base64, base64url, base32, base32hex and hex"
+HOMEPAGE="https://github.com/tplgy/cppcodec"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/tplgy/cppcodec.git"
+
+ # Disable pulling in catch
+ EGIT_SUBMODULES=()
+else
+ SRC_URI="https://github.com/tplgy/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="test"
+
+DEPEND="
+ test? (
+ virtual/pkgconfig
+ >=dev-cpp/catch-2.2.0
+ )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING=$(usex test)
+ )
+ cmake-utils_src_configure
+}
diff --git a/dev-libs/cppcodec/metadata.xml b/dev-libs/cppcodec/metadata.xml
new file mode 100644
index 000000000000..fc886b24e5c5
--- /dev/null
+++ b/dev-libs/cppcodec/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>soap@gentoo.org</email>
+ <name>David Seifert</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">tplgy/cppcodec</remote-id>
+ <bugs-to>https://github.com/tplgy/cppcodec/issues</bugs-to>
+ </upstream>
+</pkgmetadata>