summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-06-12 21:28:46 +0100
committerSam James <sam@gentoo.org>2023-06-12 21:30:49 +0100
commit375f6a1aaf559c90e9c66592e511d3bceb63048a (patch)
tree3827fa267c79a1019d947248f32b64c3978bab64 /dev-lang
parentmedia-gfx/jhead: drop 3.06.0.1 (diff)
downloadgentoo-375f6a1aaf559c90e9c66592e511d3bceb63048a.tar.gz
gentoo-375f6a1aaf559c90e9c66592e511d3bceb63048a.tar.bz2
gentoo-375f6a1aaf559c90e9c66592e511d3bceb63048a.zip
dev-lang/python: skip test_dtrace for pgo
Had a report on IRC of a sandbox failure: ``` F: open_wr S: deny P: /usr/lib/python3.10/__pycache__/pprint.cpython-310.pyc.140330861931056 A: /usr/lib/python3.10/__pycache__/pprint.cpython-310.pyc.140330861931056 R: /usr/lib/python3.10/__pycache__/pprint.cpython-310.pyc.140330861931056 C: /usr/bin/python3.10 /usr/bin/dtrace -q -s /var/tmp/portage/dev-lang/python-3.11.3/work/Python-3.11.3/Lib/test/dtracedata/assert_usable.d ``` This is still fishy and it sounds like some clock problem at the point of installing 3.10 or similar, but it's not like test_dtrace is useful for us during PGO anyway. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/python/python-3.10.11.ebuild1
-rw-r--r--dev-lang/python/python-3.10.12.ebuild1
-rw-r--r--dev-lang/python/python-3.11.3.ebuild1
-rw-r--r--dev-lang/python/python-3.11.4.ebuild1
-rw-r--r--dev-lang/python/python-3.12.0_beta1.ebuild1
-rw-r--r--dev-lang/python/python-3.12.0_beta1_p1.ebuild1
-rw-r--r--dev-lang/python/python-3.12.0_beta1_p3.ebuild1
-rw-r--r--dev-lang/python/python-3.12.0_beta1_p4.ebuild1
-rw-r--r--dev-lang/python/python-3.12.0_beta2.ebuild1
-rw-r--r--dev-lang/python/python-3.9.16_p3-r1.ebuild1
-rw-r--r--dev-lang/python/python-3.9.17.ebuild1
11 files changed, 11 insertions, 0 deletions
diff --git a/dev-lang/python/python-3.10.11.ebuild b/dev-lang/python/python-3.10.11.ebuild
index b30e6ea4d97f..5b06497f4210 100644
--- a/dev-lang/python/python-3.10.11.ebuild
+++ b/dev-lang/python/python-3.10.11.ebuild
@@ -187,6 +187,7 @@ src_configure() {
--timeout 1200
-x test_gdb
+ -x test_dtrace
# All of these seem to occasionally hang for PGO inconsistently
# They'll even hang here but be fine in src_test sometimes.
diff --git a/dev-lang/python/python-3.10.12.ebuild b/dev-lang/python/python-3.10.12.ebuild
index 3c243581ddc8..de6a7df98888 100644
--- a/dev-lang/python/python-3.10.12.ebuild
+++ b/dev-lang/python/python-3.10.12.ebuild
@@ -187,6 +187,7 @@ src_configure() {
--timeout 1200
-x test_gdb
+ -x test_dtrace
# All of these seem to occasionally hang for PGO inconsistently
# They'll even hang here but be fine in src_test sometimes.
diff --git a/dev-lang/python/python-3.11.3.ebuild b/dev-lang/python/python-3.11.3.ebuild
index 389e56a6a6f4..da75820e95cd 100644
--- a/dev-lang/python/python-3.11.3.ebuild
+++ b/dev-lang/python/python-3.11.3.ebuild
@@ -174,6 +174,7 @@ src_configure() {
--timeout 1200
-x test_gdb
+ -x test_dtrace
# All of these seem to occasionally hang for PGO inconsistently
# They'll even hang here but be fine in src_test sometimes.
diff --git a/dev-lang/python/python-3.11.4.ebuild b/dev-lang/python/python-3.11.4.ebuild
index 4beb23611cfe..8cc87f45c64c 100644
--- a/dev-lang/python/python-3.11.4.ebuild
+++ b/dev-lang/python/python-3.11.4.ebuild
@@ -174,6 +174,7 @@ src_configure() {
--timeout 1200
-x test_gdb
+ -x test_dtrace
# All of these seem to occasionally hang for PGO inconsistently
# They'll even hang here but be fine in src_test sometimes.
diff --git a/dev-lang/python/python-3.12.0_beta1.ebuild b/dev-lang/python/python-3.12.0_beta1.ebuild
index e79715cc645a..2f7f75bf906e 100644
--- a/dev-lang/python/python-3.12.0_beta1.ebuild
+++ b/dev-lang/python/python-3.12.0_beta1.ebuild
@@ -169,6 +169,7 @@ src_configure() {
--timeout 1200
-x test_gdb
+ -x test_dtrace
# All of these seem to occasionally hang for PGO inconsistently
# They'll even hang here but be fine in src_test sometimes.
diff --git a/dev-lang/python/python-3.12.0_beta1_p1.ebuild b/dev-lang/python/python-3.12.0_beta1_p1.ebuild
index e79715cc645a..2f7f75bf906e 100644
--- a/dev-lang/python/python-3.12.0_beta1_p1.ebuild
+++ b/dev-lang/python/python-3.12.0_beta1_p1.ebuild
@@ -169,6 +169,7 @@ src_configure() {
--timeout 1200
-x test_gdb
+ -x test_dtrace
# All of these seem to occasionally hang for PGO inconsistently
# They'll even hang here but be fine in src_test sometimes.
diff --git a/dev-lang/python/python-3.12.0_beta1_p3.ebuild b/dev-lang/python/python-3.12.0_beta1_p3.ebuild
index e79715cc645a..2f7f75bf906e 100644
--- a/dev-lang/python/python-3.12.0_beta1_p3.ebuild
+++ b/dev-lang/python/python-3.12.0_beta1_p3.ebuild
@@ -169,6 +169,7 @@ src_configure() {
--timeout 1200
-x test_gdb
+ -x test_dtrace
# All of these seem to occasionally hang for PGO inconsistently
# They'll even hang here but be fine in src_test sometimes.
diff --git a/dev-lang/python/python-3.12.0_beta1_p4.ebuild b/dev-lang/python/python-3.12.0_beta1_p4.ebuild
index e79715cc645a..2f7f75bf906e 100644
--- a/dev-lang/python/python-3.12.0_beta1_p4.ebuild
+++ b/dev-lang/python/python-3.12.0_beta1_p4.ebuild
@@ -169,6 +169,7 @@ src_configure() {
--timeout 1200
-x test_gdb
+ -x test_dtrace
# All of these seem to occasionally hang for PGO inconsistently
# They'll even hang here but be fine in src_test sometimes.
diff --git a/dev-lang/python/python-3.12.0_beta2.ebuild b/dev-lang/python/python-3.12.0_beta2.ebuild
index e79715cc645a..2f7f75bf906e 100644
--- a/dev-lang/python/python-3.12.0_beta2.ebuild
+++ b/dev-lang/python/python-3.12.0_beta2.ebuild
@@ -169,6 +169,7 @@ src_configure() {
--timeout 1200
-x test_gdb
+ -x test_dtrace
# All of these seem to occasionally hang for PGO inconsistently
# They'll even hang here but be fine in src_test sometimes.
diff --git a/dev-lang/python/python-3.9.16_p3-r1.ebuild b/dev-lang/python/python-3.9.16_p3-r1.ebuild
index e9ff013485fb..592e2685f905 100644
--- a/dev-lang/python/python-3.9.16_p3-r1.ebuild
+++ b/dev-lang/python/python-3.9.16_p3-r1.ebuild
@@ -176,6 +176,7 @@ src_configure() {
"-j$(makeopts_jobs)"
--pgo-extended
-x test_gdb
+ -x test_dtrace
-u-network
# All of these seem to occasionally hang for PGO inconsistently
diff --git a/dev-lang/python/python-3.9.17.ebuild b/dev-lang/python/python-3.9.17.ebuild
index af2e30057ade..449a5f90b94d 100644
--- a/dev-lang/python/python-3.9.17.ebuild
+++ b/dev-lang/python/python-3.9.17.ebuild
@@ -176,6 +176,7 @@ src_configure() {
"-j$(makeopts_jobs)"
--pgo-extended
-x test_gdb
+ -x test_dtrace
-u-network
# All of these seem to occasionally hang for PGO inconsistently