summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-06-17 03:18:07 +0100
committerSam James <sam@gentoo.org>2023-06-17 03:18:07 +0100
commit15253e35bb941ccae9ac5c9f0201599ed1bd9167 (patch)
treee0ed4263b1c5a90facb495a603be699ff99c9e1e /dev-lang
parentdev-python/google-auth: revbump for allowing urllib3 (diff)
downloadgentoo-15253e35bb941ccae9ac5c9f0201599ed1bd9167.tar.gz
gentoo-15253e35bb941ccae9ac5c9f0201599ed1bd9167.tar.bz2
gentoo-15253e35bb941ccae9ac5c9f0201599ed1bd9167.zip
dev-lang/mono: add 6.12.0.182
Bug: https://bugs.gentoo.org/908612 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/mono/Manifest1
-rw-r--r--dev-lang/mono/mono-6.12.0.182.ebuild122
2 files changed, 123 insertions, 0 deletions
diff --git a/dev-lang/mono/Manifest b/dev-lang/mono/Manifest
index 95ccf27564e5..5d2e986526bd 100644
--- a/dev-lang/mono/Manifest
+++ b/dev-lang/mono/Manifest
@@ -1 +1,2 @@
DIST mono-6.12.0.122.tar.xz 292266176 BLAKE2B 07043c5fbca33edf64ebca0392b47af9b9ab502be772efb5afbe5ec9e8683b7f4e96a305ee906dff617842bdba2819c2abc130d7aff23b12779f403bbd88f3bd SHA512 0fbd4147498cc81e384933147eb6aa5c559d17a794a308af7ffa43dce51e0faefde24fc75e987ed804dcb161b52756944bc3611100fc0a4adcc260ca97ddaecd
+DIST mono-6.12.0.182.tar.xz 303230932 BLAKE2B fc959e1d57d91670e8adf8ab64d3c0f16b7291f6a70d191b4401bf42a6bd35a7ac23b1aa5d2ed5cda833f29204bd56d800910320169941283cab52a1cb79ef30 SHA512 5f0f02f2adf89785af8f620c16d69fc97b87c9b39133286e6f1237a397f4842ea8d26802d9f802f8798a86540dc1bc3b5201428f218c78fbcf91f0d575cde512
diff --git a/dev-lang/mono/mono-6.12.0.182.ebuild b/dev-lang/mono/mono-6.12.0.182.ebuild
new file mode 100644
index 000000000000..1abef5af7dd3
--- /dev/null
+++ b/dev-lang/mono/mono-6.12.0.182.ebuild
@@ -0,0 +1,122 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CHECKREQS_DISK_BUILD="4500M"
+inherit autotools check-reqs linux-info mono-env pax-utils multilib-minimal
+
+DESCRIPTION="Mono runtime and class libraries, a C# compiler/interpreter"
+HOMEPAGE="https://mono-project.com"
+SRC_URI="https://download.mono-project.com/sources/mono/${P}.tar.xz"
+
+LICENSE="MIT LGPL-2.1 GPL-2 BSD-4 NPL-1.1 Ms-PL GPL-2-with-linking-exception IDPL"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 -riscv ~x86 ~amd64-linux"
+IUSE="doc minimal nls pax-kernel xen"
+
+# Note: mono works incorrect with older versions of libgdiplus
+# Details on dotnet overlay issue: https://github.com/gentoo/dotnet/issues/429
+DEPEND="
+ app-crypt/mit-krb5[${MULTILIB_USEDEP}]
+ sys-libs/zlib[${MULTILIB_USEDEP}]
+ ia64? ( sys-libs/libunwind )
+ !minimal? ( >=dev-dotnet/libgdiplus-6.0.2 )
+ nls? ( sys-devel/gettext )
+"
+RDEPEND="
+ ${DEPEND}
+ app-misc/ca-certificates
+"
+BDEPEND="
+ sys-devel/bc
+ app-alternatives/yacc
+ pax-kernel? ( sys-apps/elfix )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-5.12-try-catch.patch
+ "${FILESDIR}"/${PN}-6.12.0.122-disable-automagic-ccache.patch
+)
+
+pkg_pretend() {
+ linux-info_pkg_setup
+
+ if use kernel_linux ; then
+ if linux_config_exists ; then
+ linux_chkconfig_builtin SYSVIPC || die "SYSVIPC not enabled in the kernel"
+ else
+ # https://github.com/gentoo/gentoo/blob/f200e625bda8de696a28338318c9005b69e34710/eclass/linux-info.eclass#L686
+ ewarn "kernel config not found"
+ ewarn "If CONFIG_SYSVIPC is not set in your kernel .config, mono will hang while compiling."
+ ewarn "See https://bugs.gentoo.org/261869 for more info."
+ fi
+ fi
+
+ # bug #687892
+ check-reqs_pkg_pretend
+}
+
+pkg_setup() {
+ mono-env_pkg_setup
+ check-reqs_pkg_setup
+}
+
+src_prepare() {
+ # We need to sed in the paxctl-ng -mr in the runtime/mono-wrapper.in so it don't
+ # get killed in the build proces when MPROTECT is enabled, bug #286280
+ # RANDMMAP kills the build process too, bug #347365
+ # We use paxmark.sh to get PT/XT logic, bug #532244
+ if use pax-kernel ; then
+ ewarn "We are disabling MPROTECT on the mono binary."
+
+ # issue 9 : https://github.com/Heather/gentoo-dotnet/issues/9
+ sed '/exec "/ i\paxmark.sh -mr "$r/@mono_runtime@"' -i "${S}"/runtime/mono-wrapper.in || die "Failed to sed mono-wrapper.in"
+ fi
+
+ default
+
+ # PATCHES contains configure.ac patch
+ eautoreconf
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ $(use_with xen xen_opt)
+ --without-ikvm-native
+ --disable-dtrace
+ --enable-system-aot
+ $(multilib_native_use_with doc mcs-docs)
+ $(use_enable nls)
+ )
+
+ # Workaround(?) for bug #779025
+ # May be able to do a real fix by adjusting path used?
+ if multilib_is_native_abi ; then
+ myeconfargs+=( --enable-system-aot )
+ else
+ myeconfargs+=( --disable-system-aot )
+ fi
+
+ econf "${myeconfargs[@]}"
+}
+
+multilib_src_test() {
+ emake -C mcs/tests check
+}
+
+multilib_src_install() {
+ default
+
+ # Remove files not respecting LDFLAGS and that we are not supposed to provide, see Fedora
+ # mono.spec and http://www.mail-archive.com/mono-devel-list@lists.ximian.com/msg24870.html
+ # for reference.
+ rm -f "${ED}"/usr/lib/mono/{2.0,4.5}/mscorlib.dll.so || die
+ rm -f "${ED}"/usr/lib/mono/{2.0,4.5}/mcs.exe.so || die
+}
+
+pkg_postinst() {
+ # bug #762265
+ cert-sync "${EROOT}"/etc/ssl/certs/ca-certificates.crt
+}