summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-15 12:15:54 -0800
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2020-11-15 12:17:05 -0800
commit45d60c2d646a2f1f92a94f2edf24705bcf7b3310 (patch)
tree52db2ce28e79ff3f3308874ab946f584518e587d /dev-lang/rust
parentxfce-extra/tumbler: Lower keywords to match libgepub (diff)
downloadgentoo-45d60c2d646a2f1f92a94f2edf24705bcf7b3310.tar.gz
gentoo-45d60c2d646a2f1f92a94f2edf24705bcf7b3310.tar.bz2
gentoo-45d60c2d646a2f1f92a94f2edf24705bcf7b3310.zip
dev-lang/rust: QA: fix RedundantUriRename
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Michał Górny <mgorny@gentoo.org> Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'dev-lang/rust')
-rw-r--r--dev-lang/rust/rust-1.45.2.ebuild4
-rw-r--r--dev-lang/rust/rust-1.46.0.ebuild4
-rw-r--r--dev-lang/rust/rust-1.47.0-r1.ebuild4
3 files changed, 6 insertions, 6 deletions
diff --git a/dev-lang/rust/rust-1.45.2.ebuild b/dev-lang/rust/rust-1.45.2.ebuild
index 5c87a5c5a60e..767a01b9f91b 100644
--- a/dev-lang/rust/rust-1.45.2.ebuild
+++ b/dev-lang/rust/rust-1.45.2.ebuild
@@ -12,7 +12,7 @@ if [[ ${PV} = *beta* ]]; then
BETA_SNAPSHOT="${betaver:0:4}-${betaver:4:2}-${betaver:6:2}"
MY_P="rustc-beta"
SLOT="beta/${PV}"
- SRC="${BETA_SNAPSHOT}/rustc-beta-src.tar.xz"
+ SRC="${BETA_SNAPSHOT}/rustc-beta-src.tar.xz -> rustc-${PV}-src.tar.xz"
else
ABI_VER="$(ver_cut 1-2)"
SLOT="stable/${ABI_VER}"
@@ -27,7 +27,7 @@ DESCRIPTION="Systems programming language from Mozilla"
HOMEPAGE="https://www.rust-lang.org/"
SRC_URI="
- https://static.rust-lang.org/dist/${SRC} -> rustc-${PV}-src.tar.xz
+ https://static.rust-lang.org/dist/${SRC}
!system-bootstrap? ( $(rust_all_arch_uris rust-${RUST_STAGE0_VERSION}) )
"
diff --git a/dev-lang/rust/rust-1.46.0.ebuild b/dev-lang/rust/rust-1.46.0.ebuild
index ceaa6d45c121..9bb19adc29f4 100644
--- a/dev-lang/rust/rust-1.46.0.ebuild
+++ b/dev-lang/rust/rust-1.46.0.ebuild
@@ -12,7 +12,7 @@ if [[ ${PV} = *beta* ]]; then
BETA_SNAPSHOT="${betaver:0:4}-${betaver:4:2}-${betaver:6:2}"
MY_P="rustc-beta"
SLOT="beta/${PV}"
- SRC="${BETA_SNAPSHOT}/rustc-beta-src.tar.xz"
+ SRC="${BETA_SNAPSHOT}/rustc-beta-src.tar.xz -> rustc-${PV}-src.tar.xz"
else
ABI_VER="$(ver_cut 1-2)"
SLOT="stable/${ABI_VER}"
@@ -27,7 +27,7 @@ DESCRIPTION="Systems programming language from Mozilla"
HOMEPAGE="https://www.rust-lang.org/"
SRC_URI="
- https://static.rust-lang.org/dist/${SRC} -> rustc-${PV}-src.tar.xz
+ https://static.rust-lang.org/dist/${SRC}
!system-bootstrap? ( $(rust_all_arch_uris rust-${RUST_STAGE0_VERSION}) )
"
diff --git a/dev-lang/rust/rust-1.47.0-r1.ebuild b/dev-lang/rust/rust-1.47.0-r1.ebuild
index 371a9cd72b54..eb58cb752e8e 100644
--- a/dev-lang/rust/rust-1.47.0-r1.ebuild
+++ b/dev-lang/rust/rust-1.47.0-r1.ebuild
@@ -12,7 +12,7 @@ if [[ ${PV} = *beta* ]]; then
BETA_SNAPSHOT="${betaver:0:4}-${betaver:4:2}-${betaver:6:2}"
MY_P="rustc-beta"
SLOT="beta/${PV}"
- SRC="${BETA_SNAPSHOT}/rustc-beta-src.tar.xz"
+ SRC="${BETA_SNAPSHOT}/rustc-beta-src.tar.xz -> rustc-${PV}-src.tar.xz"
else
ABI_VER="$(ver_cut 1-2)"
SLOT="stable/${ABI_VER}"
@@ -27,7 +27,7 @@ DESCRIPTION="Systems programming language from Mozilla"
HOMEPAGE="https://www.rust-lang.org/"
SRC_URI="
- https://static.rust-lang.org/dist/${SRC} -> rustc-${PV}-src.tar.xz
+ https://static.rust-lang.org/dist/${SRC}
!system-bootstrap? ( $(rust_all_arch_uris rust-${RUST_STAGE0_VERSION}) )
"