summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-03-15 03:43:11 +0000
committerSam James <sam@gentoo.org>2024-03-15 03:43:43 +0000
commit32bc4082f072809017d39f7adbaf9bb48300e88b (patch)
tree2aa04d9a12c0162405d129c09bef4a0ea4c97ad0 /dev-lang/python
parentapp-shells/nushell: drop 0.88.1, 0.90.1 (diff)
downloadgentoo-32bc4082f072809017d39f7adbaf9bb48300e88b.tar.gz
gentoo-32bc4082f072809017d39f7adbaf9bb48300e88b.tar.bz2
gentoo-32bc4082f072809017d39f7adbaf9bb48300e88b.zip
dev-lang/python: skip another flaky test
Every so often, I get: ``` 0:28:02 load avg: 0.00 running (1): test.test_concurrent_futures.test_deadlock (27 min 33 sec) 0:28:32 load avg: 0.00 running (1): test.test_concurrent_futures.test_deadlock (28 min 3 sec) 0:29:02 load avg: 0.00 running (1): test.test_concurrent_futures.test_deadlock (28 min 33 sec) ``` There's a bunch of upstream reports about this test too. Just skip it. Closes: https://bugs.gentoo.org/788022 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-lang/python')
-rw-r--r--dev-lang/python/python-3.10.13_p3.ebuild2
-rw-r--r--dev-lang/python/python-3.11.8_p1.ebuild2
-rw-r--r--dev-lang/python/python-3.12.2_p1.ebuild2
-rw-r--r--dev-lang/python/python-3.13.0_alpha4.ebuild2
-rw-r--r--dev-lang/python/python-3.13.0_alpha5.ebuild2
-rw-r--r--dev-lang/python/python-3.8.18_p2.ebuild1
-rw-r--r--dev-lang/python/python-3.9.18_p2.ebuild2
7 files changed, 13 insertions, 0 deletions
diff --git a/dev-lang/python/python-3.10.13_p3.ebuild b/dev-lang/python/python-3.10.13_p3.ebuild
index 916bc1290842..c3099177affd 100644
--- a/dev-lang/python/python-3.10.13_p3.ebuild
+++ b/dev-lang/python/python-3.10.13_p3.ebuild
@@ -247,6 +247,7 @@ src_configure() {
# They'll even hang here but be fine in src_test sometimes.
# bug #828535 (and related: bug #788022)
-x test_asyncio
+ -x test_concurrent_futures
-x test_httpservers
-x test_logging
-x test_multiprocessing_fork
@@ -384,6 +385,7 @@ src_test() {
-j "$(makeopts_jobs)"
# fails
+ -x test_concurrent_futures
-x test_gdb
)
diff --git a/dev-lang/python/python-3.11.8_p1.ebuild b/dev-lang/python/python-3.11.8_p1.ebuild
index a86fff509136..0b7d97cc23bc 100644
--- a/dev-lang/python/python-3.11.8_p1.ebuild
+++ b/dev-lang/python/python-3.11.8_p1.ebuild
@@ -237,6 +237,7 @@ src_configure() {
# They'll even hang here but be fine in src_test sometimes.
# bug #828535 (and related: bug #788022)
-x test_asyncio
+ -x test_concurrent_futures
-x test_httpservers
-x test_logging
-x test_multiprocessing_fork
@@ -398,6 +399,7 @@ src_test() {
-j "$(makeopts_jobs)"
# fails
+ -x test_concurrent_futures
-x test_gdb
)
diff --git a/dev-lang/python/python-3.12.2_p1.ebuild b/dev-lang/python/python-3.12.2_p1.ebuild
index e6450baf0c45..7e8fb832f57c 100644
--- a/dev-lang/python/python-3.12.2_p1.ebuild
+++ b/dev-lang/python/python-3.12.2_p1.ebuild
@@ -237,6 +237,7 @@ src_configure() {
# They'll even hang here but be fine in src_test sometimes.
# bug #828535 (and related: bug #788022)
-x test_asyncio
+ -x test_concurrent_futures
-x test_httpservers
-x test_logging
-x test_multiprocessing_fork
@@ -392,6 +393,7 @@ src_test() {
-j "$(makeopts_jobs)"
# fails
+ -x test_concurrent_futures
-x test_gdb
)
diff --git a/dev-lang/python/python-3.13.0_alpha4.ebuild b/dev-lang/python/python-3.13.0_alpha4.ebuild
index b763d4213f47..78f3cecc7a9e 100644
--- a/dev-lang/python/python-3.13.0_alpha4.ebuild
+++ b/dev-lang/python/python-3.13.0_alpha4.ebuild
@@ -247,6 +247,7 @@ src_configure() {
# They'll even hang here but be fine in src_test sometimes.
# bug #828535 (and related: bug #788022)
-x test_asyncio
+ -x test_concurrent_futures
-x test_httpservers
-x test_logging
-x test_multiprocessing_fork
@@ -403,6 +404,7 @@ src_test() {
-j "$(makeopts_jobs)"
# fails
+ -x test_concurrent_futures
-x test_gdb
)
diff --git a/dev-lang/python/python-3.13.0_alpha5.ebuild b/dev-lang/python/python-3.13.0_alpha5.ebuild
index b763d4213f47..78f3cecc7a9e 100644
--- a/dev-lang/python/python-3.13.0_alpha5.ebuild
+++ b/dev-lang/python/python-3.13.0_alpha5.ebuild
@@ -247,6 +247,7 @@ src_configure() {
# They'll even hang here but be fine in src_test sometimes.
# bug #828535 (and related: bug #788022)
-x test_asyncio
+ -x test_concurrent_futures
-x test_httpservers
-x test_logging
-x test_multiprocessing_fork
@@ -403,6 +404,7 @@ src_test() {
-j "$(makeopts_jobs)"
# fails
+ -x test_concurrent_futures
-x test_gdb
)
diff --git a/dev-lang/python/python-3.8.18_p2.ebuild b/dev-lang/python/python-3.8.18_p2.ebuild
index 30365c0caa7c..35dce04267d9 100644
--- a/dev-lang/python/python-3.8.18_p2.ebuild
+++ b/dev-lang/python/python-3.8.18_p2.ebuild
@@ -306,6 +306,7 @@ src_test() {
-j "$(makeopts_jobs)"
# fails
+ -x test_concurrent_futures
-x test_gdb
)
diff --git a/dev-lang/python/python-3.9.18_p2.ebuild b/dev-lang/python/python-3.9.18_p2.ebuild
index 3f0257a31151..2fac75e39220 100644
--- a/dev-lang/python/python-3.9.18_p2.ebuild
+++ b/dev-lang/python/python-3.9.18_p2.ebuild
@@ -171,6 +171,7 @@ src_configure() {
# They'll even hang here but be fine in src_test sometimes.
# bug #828535 (and related: bug #788022)
-x test_asyncio
+ -x test_concurrent_futures
-x test_httpservers
-x test_logging
-x test_multiprocessing_fork
@@ -365,6 +366,7 @@ src_test() {
-j "$(makeopts_jobs)"
# fails
+ -x test_concurrent_futures
-x test_gdb
)