summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-lang/falcon
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-lang/falcon')
-rw-r--r--dev-lang/falcon/Manifest1
-rw-r--r--dev-lang/falcon/falcon-0.9.6.4.ebuild51
-rw-r--r--dev-lang/falcon/metadata.xml5
3 files changed, 57 insertions, 0 deletions
diff --git a/dev-lang/falcon/Manifest b/dev-lang/falcon/Manifest
new file mode 100644
index 000000000000..e76bd45cf2df
--- /dev/null
+++ b/dev-lang/falcon/Manifest
@@ -0,0 +1 @@
+DIST Falcon-0.9.6.4.tar.gz 1782796 SHA256 24f4294f93c192f21d3590795a9fdd864c3f2d376cb0baac9c1e11e893cfaf81 SHA512 244fc0cc6811d9c918a1983d93e380982584016d84752b00d3adc17e46d7a7cbf9d20f09b7562316b1c9ea6eaaa91c1cb931f4469f7d510d9084f1daaca732a5 WHIRLPOOL 2178d6307fcd516f490fada540af649a60ca39f8640215b926f153316ab349ed9b46e47c7849270a20632e9639ca65d635f88ed4d0a2fccf718967ce83106a8b
diff --git a/dev-lang/falcon/falcon-0.9.6.4.ebuild b/dev-lang/falcon/falcon-0.9.6.4.ebuild
new file mode 100644
index 000000000000..89e124c350e9
--- /dev/null
+++ b/dev-lang/falcon/falcon-0.9.6.4.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit cmake-utils multilib
+
+MY_P=${P/f/F}
+
+DESCRIPTION="An open source general purpose untyped language written in C++"
+HOMEPAGE="http://falconpl.org/"
+SRC_URI="http://falconpl.org/project_dl/_official_rel/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug readline"
+
+DEPEND="
+ dev-libs/libpcre
+ sys-libs/zlib
+ readline? ( sys-libs/readline )
+"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS="AUTHORS ChangeLog README RELNOTES"
+
+src_configure() {
+ mycmakeargs=(
+ -DFALCON_DISABLE_RPATH=ON
+ -DFALCON_LIB_DIR=$(get_libdir)
+ -DFALCON_SKIP_BISON=ON
+ -DFALCON_WITH_MANPAGES=ON
+ -DFALCON_WITH_INTERNAL_PCRE=OFF
+ -DFALCON_WITH_INTERNAL_ZLIB=OFF
+ -DFALCON_WITH_GPL_READLINE=ON
+ $(cmake-utils_use readline FALCON_WITH_EDITLINE)
+ )
+ cmake-utils_src_configure
+}
+
+src_test() {
+ FALCON_LOAD_PATH=".;${CMAKE_BUILD_DIR}/core/clt"
+ for testsuite in "${S}/core/tests/testsuite" "${S}/modules/feathers/tests/testsuite"; do
+ "${CMAKE_BUILD_DIR}/core/clt/faltest/faltest" \
+ -d "${testsuite}" || die "faltest in ${testsuite} failed"
+ done
+}
diff --git a/dev-lang/falcon/metadata.xml b/dev-lang/falcon/metadata.xml
new file mode 100644
index 000000000000..6318a491915d
--- /dev/null
+++ b/dev-lang/falcon/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>lang-misc</herd>
+</pkgmetadata>