summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-09-07 13:55:58 +0200
committerDavid Seifert <soap@gentoo.org>2019-09-07 13:55:58 +0200
commit1e69d70fdc5e3588b243fa6701512f61d387daec (patch)
treef7c24764dab5b8c575dbbadc1d10a4f55becf032 /dev-lang/f2c/f2c-20100827-r1.ebuild
parentdev-libs/libf2c: Port to EAPI 7 (diff)
downloadgentoo-1e69d70fdc5e3588b243fa6701512f61d387daec.tar.gz
gentoo-1e69d70fdc5e3588b243fa6701512f61d387daec.tar.bz2
gentoo-1e69d70fdc5e3588b243fa6701512f61d387daec.zip
dev-lang/f2c: Port to EAPI 7
Package-Manager: Portage-2.3.75, Repoman-2.3.17 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-lang/f2c/f2c-20100827-r1.ebuild')
-rw-r--r--dev-lang/f2c/f2c-20100827-r1.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/dev-lang/f2c/f2c-20100827-r1.ebuild b/dev-lang/f2c/f2c-20100827-r1.ebuild
new file mode 100644
index 000000000000..dd624e40d486
--- /dev/null
+++ b/dev-lang/f2c/f2c-20100827-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DEB_PV=20100827
+DEB_PR=1
+DEB_P=${PN}_${DEB_PV}
+
+DESCRIPTION="Fortran to C converter"
+HOMEPAGE="http://www.netlib.org/f2c"
+SRC_URI="
+ mirror://debian/pool/main/${PN:0:1}/${PN}/${DEB_P}.orig.tar.gz
+ mirror://debian/pool/main/${PN:0:1}/${PN}/${DEB_P}-${DEB_PR}.debian.tar.gz"
+
+LICENSE="HPND"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+
+RDEPEND=">=dev-libs/libf2c-20130927-r1"
+
+S="${WORKDIR}/${PN}"
+
+PATCHES=(
+ # selective list of patches from debian
+ "${WORKDIR}"/debian/patches/0000-prequilt-tweaks.patch
+ "${WORKDIR}"/debian/patches/0002-prototype-rmdir.patch
+ "${WORKDIR}"/debian/patches/0003-struct-init-braces.patch
+ "${WORKDIR}"/debian/patches/0004-man-dash-hyphen-slash.patch
+
+ "${FILESDIR}"/${PN}-20100827-fix-buildsystem.patch
+ "${FILESDIR}"/${PN}-20100827-Wimplicit-function-declaration.patch
+)
+
+src_configure() {
+ tc-export CC
+}
+
+src_compile() {
+ emake -C src -f makefile.u f2c
+}
+
+src_install() {
+ dobin src/f2c
+
+ doman f2c.1
+ dodoc src/README src/Notice
+
+ dodoc f2c.pdf
+ newdoc "${WORKDIR}"/debian/changelog debian.changelog
+}