summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHaelwenn (lanodan) Monnier <contact@hacktivis.me>2023-05-23 03:44:29 +0200
committerJoonas Niilola <juippis@gentoo.org>2023-06-03 16:07:32 +0300
commitdc2811a5df983c54aa4a1be09837529f5a2c1512 (patch)
treeee07cda193eca9c1427771310152413e9df400e4 /dev-lang/elixir
parentnet-libs/neon: add upstream patches (diff)
downloadgentoo-dc2811a5df983c54aa4a1be09837529f5a2c1512.tar.gz
gentoo-dc2811a5df983c54aa4a1be09837529f5a2c1512.tar.bz2
gentoo-dc2811a5df983c54aa4a1be09837529f5a2c1512.zip
dev-lang/elixir: add 1.14.5
Signed-off-by: Haelwenn (lanodan) Monnier <contact@hacktivis.me> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-lang/elixir')
-rw-r--r--dev-lang/elixir/Manifest1
-rw-r--r--dev-lang/elixir/elixir-1.14.5.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-lang/elixir/Manifest b/dev-lang/elixir/Manifest
index 71d69ad9c663..b0f3a6741e1c 100644
--- a/dev-lang/elixir/Manifest
+++ b/dev-lang/elixir/Manifest
@@ -3,3 +3,4 @@ DIST elixir-1.13.4.tar.gz 2912984 BLAKE2B 3849e7be7d1ba54ac3f96690f158b60a3b7da7
DIST elixir-1.14.1.tar.gz 3081499 BLAKE2B 1efcf2a2b654634363ae6bc70f677f8a2ea7903452a84c1ad21eb3586a5ded0e4a761ae0de21500daf2f8585ee1d20a8dfa6a7e0bd95a931ce4a4a6e798a0d75 SHA512 8f4c531f36ba1f2f775b1b45075790bfbdcc1c2995cb127809ac9cbb4d6163bf784d9db402119afbcd5f5d75725870cc59968bf751910d29b43f075328265573
DIST elixir-1.14.3.tar.gz 3086297 BLAKE2B b162ea35a762bc1e151c7844237f3167c97da9aae44bca9fe022d09cde6f6909103b383e67b2133b68e76c061c4ed05cdd081070bdbb48be85bbc0ed067fadfd SHA512 eec1e161364f823e26d79596d18b0ff7e6ade1c2c1f6f9ca84eb34d20fd90f434bbd29ef74cd41096e8f25e71d9cd1da0ec6f0a4f24c485124f9525b1ae2c4e0
DIST elixir-1.14.4.tar.gz 3076206 BLAKE2B 77b543c53ee03b1f911e3159c81175281b9e4a8ad714b5e87a438e9f70a36000c4e3c2b0f564165c97fb27b6444d20af70da45d8544a6a8b12d60549a00f1c0c SHA512 c39e91e27485ce52e6d29c64f6d5c7abc50e99b8aac578642a4c085083fed23ccba095a013fee4dd3de97524bf4ec54af31478150818921b2a891f7a5840080a
+DIST elixir-1.14.5.tar.gz 3076366 BLAKE2B cf1487c269b4f09c5a7771339782ddc5f6dc2d5f31bd098486824e1f50040462a55a6135e76a7d635461b8d61ce8ab45be2d1da86d60ecf0bc3c86c98b86531d SHA512 589482fb080eb9f71319b7927312ee255dab0376a8fb781533bc97b6a75dd71ec43cd022bb2eff12eca205cdeaf9a6d629f754c555c17cd6222e05912ff3d960
diff --git a/dev-lang/elixir/elixir-1.14.5.ebuild b/dev-lang/elixir/elixir-1.14.5.ebuild
new file mode 100644
index 000000000000..faea8a68f900
--- /dev/null
+++ b/dev-lang/elixir/elixir-1.14.5.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Elixir programming language"
+HOMEPAGE="https://elixir-lang.org"
+SRC_URI="https://github.com/elixir-lang/elixir/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 ErlPL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~riscv ~sparc ~x86"
+IUSE="test"
+
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ >=dev-lang/erlang-23:0=[ssl]
+"
+# 'mix' tool collides with sci-biology/phylip, bug #537514
+RDEPEND="${DEPEND}
+ !!sci-biology/phylip
+"
+DEPEND+="
+ test? ( dev-vcs/git )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.9.1-disable-network-tests.patch
+ "${FILESDIR}"/${PN}-1.10.3-no-Q.patch
+ "${FILESDIR}"/${PN}-1.10.3-epmd-daemon.patch
+ "${FILESDIR}"/${PN}-1.14.1-make44-parallel-build.patch
+)
+
+src_install() {
+ emake DESTDIR="${D}" LIBDIR="$(get_libdir)" PREFIX="${EPREFIX}/usr" install
+ dodoc README.md CHANGELOG.md CODE_OF_CONDUCT.md
+}