summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHaelwenn (lanodan) Monnier <contact@hacktivis.me>2024-05-21 02:50:20 +0200
committerJoonas Niilola <juippis@gentoo.org>2024-07-03 15:53:31 +0300
commitc33dd683e6f316b91375b2f8b7780bf15fe7e1ed (patch)
tree434b0412788ca1aeba58a542a0946942ad52f5ef /dev-lang/elixir
parentsys-apps/opal-utils: enable py3.12, py3.13, cleanup ebuild (diff)
downloadgentoo-c33dd683e6f316b91375b2f8b7780bf15fe7e1ed.tar.gz
gentoo-c33dd683e6f316b91375b2f8b7780bf15fe7e1ed.tar.bz2
gentoo-c33dd683e6f316b91375b2f8b7780bf15fe7e1ed.zip
dev-lang/elixir: add 1.16.3
Signed-off-by: Haelwenn (lanodan) Monnier <contact@hacktivis.me> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-lang/elixir')
-rw-r--r--dev-lang/elixir/elixir-1.16.3.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-lang/elixir/elixir-1.16.3.ebuild b/dev-lang/elixir/elixir-1.16.3.ebuild
new file mode 100644
index 000000000000..e471f6ed3900
--- /dev/null
+++ b/dev-lang/elixir/elixir-1.16.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Elixir programming language"
+HOMEPAGE="https://elixir-lang.org"
+SRC_URI="https://github.com/elixir-lang/elixir/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 ErlPL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~riscv ~sparc ~x86"
+IUSE="test"
+
+RESTRICT="!test? ( test )"
+
+# https://hexdocs.pm/elixir/compatibility-and-deprecations.html#between-elixir-and-erlang-otp
+DEPEND="
+ >=dev-lang/erlang-24:0=[ssl]
+ <dev-lang/erlang-27
+"
+# 'mix' tool collides with sci-biology/phylip, bug #537514
+RDEPEND="${DEPEND}
+ !!sci-biology/phylip
+"
+DEPEND+="
+ test? ( dev-vcs/git )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.9.1-disable-network-tests.patch
+ "${FILESDIR}"/${PN}-1.10.3-no-Q.patch
+ "${FILESDIR}"/${PN}-1.10.3-epmd-daemon.patch
+)
+
+src_install() {
+ emake DESTDIR="${D}" LIBDIR="$(get_libdir)" PREFIX="${EPREFIX}/usr" install
+ dodoc README.md CHANGELOG.md CODE_OF_CONDUCT.md
+}