summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2023-06-01 20:41:27 +0200
committerJakov Smolić <jsmolic@gentoo.org>2023-06-03 07:23:29 +0200
commitdb268303d2223b17f54899da21574fd6bbdaf4f5 (patch)
tree758c9125db10fbbfe463c57ec2ea788316243c18 /dev-java
parentjava-virtuals/servlet-api: treeclean (diff)
downloadgentoo-db268303d2223b17f54899da21574fd6bbdaf4f5.tar.gz
gentoo-db268303d2223b17f54899da21574fd6bbdaf4f5.tar.bz2
gentoo-db268303d2223b17f54899da21574fd6bbdaf4f5.zip
dev-java/avalon-logkit: treeclean
Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/avalon-logkit/Manifest1
-rw-r--r--dev-java/avalon-logkit/avalon-logkit-2.1-r12.ebuild93
-rw-r--r--dev-java/avalon-logkit/files/avalon-logkit-2.1-java7.patch30
-rw-r--r--dev-java/avalon-logkit/metadata.xml8
4 files changed, 0 insertions, 132 deletions
diff --git a/dev-java/avalon-logkit/Manifest b/dev-java/avalon-logkit/Manifest
deleted file mode 100644
index 10a23e81558a..000000000000
--- a/dev-java/avalon-logkit/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST avalon-logkit-2.1-src.tar.gz 60218 BLAKE2B 1c35b38a22d95cffabb19e099d42697adf7aa6ad471f6cb62e02a30b6612c8405b9f7473ca61ea4f7f9c1f3b1ece6ee68f7ec711b79672330db3ac9e57642e0d SHA512 9977a3a172ca4fb5c3ad1f623ff109214f71900d2e244f175cc5d140f5f9993caca7e5ca3220728f18a1d6242d11a48990f9ce0150c36b7a9bb10a7a6d5a905a
diff --git a/dev-java/avalon-logkit/avalon-logkit-2.1-r12.ebuild b/dev-java/avalon-logkit/avalon-logkit-2.1-r12.ebuild
deleted file mode 100644
index 1bdcb3f071f0..000000000000
--- a/dev-java/avalon-logkit/avalon-logkit-2.1-r12.ebuild
+++ /dev/null
@@ -1,93 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-JAVA_PKG_IUSE="doc source test"
-
-inherit java-pkg-2 java-ant-2
-
-# NB: this project is dead and we should look into removing it from the tree.
-# Take a look at the homepage.
-# As of February 2022, dev-java/commons-logging is the only consumer of this
-# package besides dev-java/avalon-framework. However, commons-logging is still
-# used by many other consumers and does not have an updated version that do not
-# depend on this package.
-DESCRIPTION="Easy-to-use Java logging toolkit"
-HOMEPAGE="https://avalon.apache.org/closed.html"
-SRC_URI="https://archive.apache.org/dist/excalibur/avalon-logkit/source/avalon-logkit-${PV}-src.tar.gz"
-
-KEYWORDS="amd64 ~arm arm64 ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos"
-LICENSE="Apache-2.0"
-SLOT="2.0"
-
-CP_DEPEND="
- dev-java/javax-mail:0
- dev-java/jboss-jms-api:1.1
- dev-java/log4j-12-api:2
- java-virtuals/servlet-api:3.0"
-RDEPEND="${CP_DEPEND}
- >=virtual/jre-1.8:*"
-DEPEND="${CP_DEPEND}
- >=virtual/jdk-1.8:*
- test? (
- dev-java/ant-junit:0
- )"
-
-src_prepare() {
- default
-
- # Unfortunately, LogFactor5 support is no longer provided by the Log4j 1.x
- # bridge in Log4j 2. But it seems that LogFactor5 merely consists of a
- # Swing-based GUI that is neither checked by this package's tests nor used
- # by reverse dependencies in ::gentoo. If virtually nobody would use
- # LogFactor5, components in this package pertaining to it could be simply
- # removed to make the migration to Log4j 2 feasible.
- # http://people.apache.org/~carnold/log4j/docs/x/logging-log4j-1.2.10/docs/lf5/overview.html
- rm -rv src/java/org/apache/log/output/lf5 ||
- die "Failed to remove support for stale LogFactor5 project"
-
- # Doesn't like 1.6 / 1.7 changes to JDBC
- eapply "${FILESDIR}/${P}-java7.patch"
-
- java-ant_ignore-system-classes
-
- java-ant_xml-rewrite \
- -f build.xml \
- -c -e available \
- -a classpathref \
- -v 'build.classpath' || die
-
- java-pkg_filter-compiler jikes
-}
-
-JAVA_ANT_REWRITE_CLASSPATH="yes"
-JAVA_ANT_ENCODING="UTF-8"
-
-src_test() {
- java-pkg-2_src_test
-}
-
-src_install() {
- java-pkg_newjar "target/${P}.jar"
- use doc && java-pkg_dojavadoc dist/docs/api
- use source && java-pkg_dosrc src/java/*
-}
-
-pkg_postinst() {
- # Display a message about LogFactor5 support drop upon first install
- # or upgrade from a version before the drop
- local changed_ver="2.1-r11"
- local should_show_msg replaced_ver
- [[ -z "${REPLACING_VERSIONS}" ]] && should_show_msg=1 # First install
- for replaced_ver in ${REPLACING_VERSIONS}; do
- if ver_test "${replaced_ver}" -lt "${changed_ver}"; then
- should_show_msg=1
- break
- fi
- done
- [[ "${should_show_msg}" ]] || return
- ewarn "Due to migration to Log4j 2, this package has to drop LogFactor5"
- ewarn "support. As a result, the org.apache.log.output.lf5 Java package"
- ewarn "is not available in the JAR installed by this package."
-}
diff --git a/dev-java/avalon-logkit/files/avalon-logkit-2.1-java7.patch b/dev-java/avalon-logkit/files/avalon-logkit-2.1-java7.patch
deleted file mode 100644
index cb2611bf0de4..000000000000
--- a/dev-java/avalon-logkit/files/avalon-logkit-2.1-java7.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-diff -Nur avalon-logkit-2.1/src/java/org/apache/log/output/db/DefaultDataSource.java avalon-logkit-2.1_patched//src/java/org/apache/log/output/db/DefaultDataSource.java
---- avalon-logkit-2.1/src/java/org/apache/log/output/db/DefaultDataSource.java 2005-08-30 05:03:49.000000000 +0300
-+++ avalon-logkit-2.1_patched//src/java/org/apache/log/output/db/DefaultDataSource.java 2011-09-27 08:27:49.313005212 +0300
-@@ -20,7 +20,9 @@
- import java.sql.Connection;
- import java.sql.DriverManager;
- import java.sql.SQLException;
-+import java.sql.SQLFeatureNotSupportedException;
- import javax.sql.DataSource;
-+import java.util.logging.Logger;
-
- /**
- * A basic datasource that doesn't do any pooling but just wraps
-@@ -111,4 +113,16 @@
- {
- m_logWriter = logWriter;
- }
-+
-+ public boolean isWrapperFor(Class cls) {
-+ return false;
-+ }
-+
-+ public Object unwrap(Class cls) throws SQLException {
-+ throw new SQLException("Not a wrapper for " + cls);
-+ }
-+
-+ public Logger getParentLogger() throws SQLFeatureNotSupportedException {
-+ throw new SQLFeatureNotSupportedException("Not a supported feature");
-+ }
- }
diff --git a/dev-java/avalon-logkit/metadata.xml b/dev-java/avalon-logkit/metadata.xml
deleted file mode 100644
index 6ef2d50cf07e..000000000000
--- a/dev-java/avalon-logkit/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>java@gentoo.org</email>
- <name>Java</name>
- </maintainer>
-</pkgmetadata>