summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Jolly <kangie@gentoo.org>2024-11-04 17:24:14 +1000
committerMatt Jolly <kangie@gentoo.org>2024-11-09 16:25:41 +1000
commit01ba4dc61965ef7658a24728841c04c9a1ce4871 (patch)
treea2a6b927779e5990ff87ec4589373d1d89129a63 /dev-java
parentprofiles: mask dev-lang/starlark-rust (diff)
downloadgentoo-01ba4dc61965ef7658a24728841c04c9a1ce4871.tar.gz
gentoo-01ba4dc61965ef7658a24728841c04c9a1ce4871.tar.bz2
gentoo-01ba4dc61965ef7658a24728841c04c9a1ce4871.zip
*/*: update for slotted Rust
Tidyups: - $(cargo_crate_uris) - Rust BDEPENDS come from the eclass except in very rare circumstances (RUST_OPTIONAL=1) - RUST_M{AX,IN}_VER where required. - Suboptimal crate separator (`-` -> `@`) Signed-off-by: Matt Jolly <kangie@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/39218 Signed-off-by: Matt Jolly <kangie@gentoo.org>
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/icedtea-web/icedtea-web-1.8.8-r2.ebuild (renamed from dev-java/icedtea-web/icedtea-web-1.8.8-r1.ebuild)14
1 files changed, 9 insertions, 5 deletions
diff --git a/dev-java/icedtea-web/icedtea-web-1.8.8-r1.ebuild b/dev-java/icedtea-web/icedtea-web-1.8.8-r2.ebuild
index 73754338cb33..ff395edab946 100644
--- a/dev-java/icedtea-web/icedtea-web-1.8.8-r1.ebuild
+++ b/dev-java/icedtea-web/icedtea-web-1.8.8-r2.ebuild
@@ -4,14 +4,16 @@
EAPI=8
README_GENTOO_SUFFIX="-r3"
-CRATES="dunce-0.1.1"
+CRATES="dunce@0.1.1"
inherit autotools bash-completion-r1 cargo java-pkg-2 readme.gentoo-r1 xdg-utils
DESCRIPTION="FOSS Java browser plugin and Web Start implementation"
HOMEPAGE="https://github.com/AdoptOpenJDK/IcedTea-Web"
SRC_URI="https://github.com/AdoptOpenJDK/${PN}/archive/${P}.tar.gz
- $(cargo_crate_uris ${CRATES})"
+ ${CARGO_CRATE_URIS}"
+S="${WORKDIR}/IcedTea-Web-${P}"
+
LICENSE="GPL-2 GPL-2-with-linking-exception LGPL-2"
SLOT="0"
KEYWORDS="amd64 arm64 ppc64"
@@ -25,7 +27,6 @@ BDEPEND="
app-arch/zip
app-alternatives/bc
virtual/pkgconfig
- virtual/rust
doc? ( app-alternatives/bc )
"
@@ -58,10 +59,13 @@ RDEPEND="
>=virtual/jre-1.8:*
"
-S="${WORKDIR}/IcedTea-Web-${P}"
-
QA_FLAGS_IGNORED="usr/bin/.*"
+pkg_setup() {
+ java-pkg-2_pkg_setup
+ rust_pkg_setup
+}
+
src_prepare() {
eapply_user
sed -i 's/JAVADOC_OPTS=/\0-Xdoclint:none /g' Makefile.am || die