summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/rome
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/rome')
-rw-r--r--dev-java/rome/Manifest1
-rw-r--r--dev-java/rome/files/rome-0.9-build.xml-test-upstream.patch17
-rw-r--r--dev-java/rome/metadata.xml8
-rw-r--r--dev-java/rome/rome-0.9.ebuild49
4 files changed, 75 insertions, 0 deletions
diff --git a/dev-java/rome/Manifest b/dev-java/rome/Manifest
new file mode 100644
index 000000000000..8bd7f75a692a
--- /dev/null
+++ b/dev-java/rome/Manifest
@@ -0,0 +1 @@
+DIST rome-0.9-src.zip 248755 SHA256 c8e8674de5b204d02ce8b5e33fa5f848f23ee4e4746c60ebc7ccf52a1ac97a4f SHA512 d4bc9945e2b77bdc38eca609ec353379c279cd700d8d85220a1723d1b019da2c18bd93ff98b062e519e7d87f2d2b6853f373fc7178cec0f83b34af45fce5f3ff WHIRLPOOL 69554087947fec155478d5d8cd820976a878d1055dfbeebcb567893c2e943ae89f247dd578ad94d6c88cba2ee8d3faa7fac05556790157f7e2e95ed1cd752404
diff --git a/dev-java/rome/files/rome-0.9-build.xml-test-upstream.patch b/dev-java/rome/files/rome-0.9-build.xml-test-upstream.patch
new file mode 100644
index 000000000000..95e53f4f7f73
--- /dev/null
+++ b/dev-java/rome/files/rome-0.9-build.xml-test-upstream.patch
@@ -0,0 +1,17 @@
+===================================================================
+RCS file: /opt/sourcecast/data/ccvs/repository/rome/build.xml,v
+retrieving revision 1.14
+retrieving revision 1.15
+diff -u -r1.14 -r1.15
+--- rome/build.xml 2006/12/04 21:47:37 1.14
++++ rome/build.xml 2006/12/26 14:35:46 1.15
+@@ -131,6 +131,9 @@
+ <fileset dir="src/data">
+ <include name="**/*.xml" />
+ </fileset>
++ <fileset dir="src/test">
++ <include name="**/*.properties" />
++ </fileset>
+ </copy>
+ </target>
+
diff --git a/dev-java/rome/metadata.xml b/dev-java/rome/metadata.xml
new file mode 100644
index 000000000000..407583277d87
--- /dev/null
+++ b/dev-java/rome/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>java</herd>
+<maintainer>
+ <email>java@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-java/rome/rome-0.9.ebuild b/dev-java/rome/rome-0.9.ebuild
new file mode 100644
index 000000000000..20a33a6296b7
--- /dev/null
+++ b/dev-java/rome/rome-0.9.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+JAVA_PKG_IUSE="doc source test"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Open source Atom/RSS Java utilities that make it easy to work in Java with most syndication formats"
+HOMEPAGE="https://java.net/projects/rome"
+SRC_URI="https://rome.dev.java.net/source/browse/*checkout*/rome/www/dist/${P}-src.zip"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86 ~x86-fbsd"
+IUSE=""
+
+COMMON_DEPEND=">=dev-java/jdom-1.0"
+DEPEND=">=virtual/jdk-1.4
+ app-arch/unzip
+ test? ( dev-java/ant-junit )
+ ${COMMON_DEPEND}"
+RDEPEND=">=virtual/jre-1.4
+ ${COMMON_DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Patch build.xml so the tests pass
+ epatch "${FILESDIR}/${P}-build.xml-test-upstream.patch"
+
+ # Symlink jars
+ mkdir -p target/lib
+ cd target/lib
+ java-pkg_jar-from jdom-1.0
+}
+
+src_install() {
+ java-pkg_newjar target/${P}.jar
+
+ use doc && java-pkg_dojavadoc dist/docs/api
+ use source && java-pkg_dosrc src/java/*
+}
+
+src_test() {
+ java-pkg_jar-from --into target/lib junit
+ ANT_TASKS="ant-junit" eant test
+}