summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/jupidator
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/jupidator')
-rw-r--r--dev-java/jupidator/Manifest1
-rw-r--r--dev-java/jupidator/jupidator-0.6.0.ebuild46
-rw-r--r--dev-java/jupidator/metadata.xml8
3 files changed, 55 insertions, 0 deletions
diff --git a/dev-java/jupidator/Manifest b/dev-java/jupidator/Manifest
new file mode 100644
index 000000000000..cffaea20f235
--- /dev/null
+++ b/dev-java/jupidator/Manifest
@@ -0,0 +1 @@
+DIST jupidator.0.6.0.tar.bz2 253170 SHA256 00213313f794363cc3b4dd8c335cb35cc8582d0d56d72cb941b3edc8f2b94580 SHA512 5e96831ca41b6871eb5f6c883c21eae17474844a74fc5e103b534d6e225d0a16ef98149da1d52728e737607eb7ece586f05aafa0a0ada29c4c28ff3e078a2415 WHIRLPOOL f8625ac738c610c1b3ed60f05a140b0e7367d97189bc27e70666886879c1da74117df360b938718861a4f8a52fdea7e8ed8355b68b33fb459272145481a3f45a
diff --git a/dev-java/jupidator/jupidator-0.6.0.ebuild b/dev-java/jupidator/jupidator-0.6.0.ebuild
new file mode 100644
index 000000000000..733ce3257c51
--- /dev/null
+++ b/dev-java/jupidator/jupidator-0.6.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+JAVA_PKG_IUSE="doc source"
+WANT_ANT_TASKS="ant-nodeps"
+
+inherit java-pkg-2 java-ant-2 eutils
+
+MY_P="${PN}.${PV}"
+
+DESCRIPTION="Jupidator is a library/tool in Java for automatic updating of applications"
+HOMEPAGE="http://www.sourceforge.net/projects/jupidator"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.5
+ dev-java/ant-core"
+DEPEND=">=virtual/jdk-1.5
+ dev-java/ant-core
+ doc? ( app-text/xmlto )
+ sys-devel/gettext"
+
+S="${WORKDIR}/${PN}"
+
+java_prepare() {
+ rm -v dist/*.jar || die
+ rm -rv src/java/org/apache/tools/bzip2 || die
+ #Bundled ant classes
+ java-ant_rewrite-classpath nbproject/build-impl.xml
+ chmod +x i18n/make.sh || die
+}
+
+src_compile() {
+ ANT_TASKS="ant-nodeps" eant -Dgentoo.classpath="$(java-pkg_getjars ant-core)" compile jar
+}
+
+src_install() {
+ java-pkg_dojar dist/${PN}.jar
+ use doc && java-pkg_dohtml -r dist/doc
+ use source && java-pkg_dosrc src/java/com
+}
diff --git a/dev-java/jupidator/metadata.xml b/dev-java/jupidator/metadata.xml
new file mode 100644
index 000000000000..4e84a8985356
--- /dev/null
+++ b/dev-java/jupidator/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <upstream>
+ <remote-id type="sourceforge">jupidator</remote-id>
+ </upstream>
+</pkgmetadata>