summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/joni
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/joni')
-rw-r--r--dev-java/joni/Manifest2
-rw-r--r--dev-java/joni/joni-1.1.4.ebuild38
-rw-r--r--dev-java/joni/joni-2.1.0.ebuild38
-rw-r--r--dev-java/joni/metadata.xml8
4 files changed, 86 insertions, 0 deletions
diff --git a/dev-java/joni/Manifest b/dev-java/joni/Manifest
new file mode 100644
index 000000000000..d8d7066c424a
--- /dev/null
+++ b/dev-java/joni/Manifest
@@ -0,0 +1,2 @@
+DIST joni-1.1.4.tar.gz 120701 SHA256 644f24378cffa2efe9d59c3a28616c80319693a42eeb0234550f9e1f2e8ba11e SHA512 68ac4559e3b6ac2506126af7c8159a87a7906fe45e71828478051f1a84a10b9b62c966168b260d1e0b0395cbd1792a428b2e1ac458db32b57b7a84c81f9e7804 WHIRLPOOL fce0621bf6302423c31036cb084f92455578321b940ad6b9a91f078fdadd9a94a4e0f52aeb42a9beb7fb6be3b789a54f99becf094c3a7462d3b9246edbb4967f
+DIST joni-2.1.0.tar.gz 125084 SHA256 9c8cb9abd7d8d086b777ade94a7ac68aaf7b9343720f81796d8c1a6c49e4cc39 SHA512 dd40b3a857deb02848d4a87de010ec6b9c96fb962643ea1022833a1bb5ebd76ffac403ff2a54497df288998939ed81910c22c02a2df1f7290112bb2ea506db0e WHIRLPOOL 4f5befc5b9813fb54cf813184fd152bbe3af98c73fda0d9c89dfbc42aa7b2f621b20738c23bad0682954ff8c7566a4053173857f06dac36036d6178c8ae9b89d
diff --git a/dev-java/joni/joni-1.1.4.ebuild b/dev-java/joni/joni-1.1.4.ebuild
new file mode 100644
index 000000000000..536458b1cf67
--- /dev/null
+++ b/dev-java/joni/joni-1.1.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+JAVA_PKG_IUSE="source"
+inherit base java-pkg-2 java-ant-2
+
+DESCRIPTION="Java port of the Oniguruma regular expression engine"
+HOMEPAGE="http://jruby.codehaus.org/"
+SRC_URI="http://github.com/jruby/joni/tarball/${PV} -> ${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE=""
+
+CDEPEND="dev-java/asm:3
+ dev-java/jcodings:0"
+
+RDEPEND="${CDEPEND}
+ >=virtual/jre-1.5"
+
+DEPEND="${CDEPEND}
+ >=virtual/jdk-1.5"
+
+src_unpack() {
+ unpack ${A}
+ mv j* "${S}"
+}
+
+JAVA_ANT_REWRITE_CLASSPATH="true"
+EANT_BUILD_TARGET="build"
+EANT_GENTOO_CLASSPATH="asm-3 jcodings"
+
+src_install() {
+ java-pkg_dojar target/${PN}.jar
+ use source && java-pkg_dosrc src/*
+}
diff --git a/dev-java/joni/joni-2.1.0.ebuild b/dev-java/joni/joni-2.1.0.ebuild
new file mode 100644
index 000000000000..cfc2b47b83c0
--- /dev/null
+++ b/dev-java/joni/joni-2.1.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+JAVA_PKG_IUSE="source"
+
+inherit base java-pkg-2 java-ant-2
+
+DESCRIPTION="Java port of the Oniguruma regular expression engine"
+HOMEPAGE="http://jruby.codehaus.org/"
+SRC_URI="https://github.com/jruby/${PN}/archive/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="2.1"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+
+CDEPEND="dev-java/asm:3
+ dev-java/jcodings:1"
+
+RDEPEND="${CDEPEND}
+ >=virtual/jre-1.5"
+
+DEPEND="${CDEPEND}
+ >=virtual/jdk-1.5"
+
+S="${WORKDIR}/${PN}-${PN}-${PV}"
+
+JAVA_ANT_REWRITE_CLASSPATH="true"
+EANT_BUILD_TARGET="build"
+EANT_GENTOO_CLASSPATH="asm-3 jcodings-1"
+
+src_install() {
+ java-pkg_dojar target/${PN}.jar
+
+ use source && java-pkg_dosrc src/*
+}
diff --git a/dev-java/joni/metadata.xml b/dev-java/joni/metadata.xml
new file mode 100644
index 000000000000..0a200766983d
--- /dev/null
+++ b/dev-java/joni/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <upstream>
+ <remote-id type="github">jruby/joni</remote-id>
+ </upstream>
+</pkgmetadata>