summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/emma
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/emma')
-rw-r--r--dev-java/emma/Manifest1
-rw-r--r--dev-java/emma/emma-2.0.5312-r2.ebuild42
-rw-r--r--dev-java/emma/files/emma-2.0.5312-java15api.patch13
-rw-r--r--dev-java/emma/metadata.xml19
4 files changed, 75 insertions, 0 deletions
diff --git a/dev-java/emma/Manifest b/dev-java/emma/Manifest
new file mode 100644
index 000000000000..30c7e24e776c
--- /dev/null
+++ b/dev-java/emma/Manifest
@@ -0,0 +1 @@
+DIST emma-2.0.5312-src.zip 421109 SHA256 2c6cd6177f2cf4b011ac23c3d301be3655ef1fb276b523d5a5155064917a9833 SHA512 d99b7ff1c4682a97f714f74cc6142bb766cde47bcb33932dc466f1e505e836883f01faa0a959dad77c0837fca3ae744754e0fcdc34d7a8d14720b0b7ce90ee4b WHIRLPOOL bc91a3e681c4926058600382387c775cdf615abd5ad0e50e245aab28a82855519ff4ee0a3b3e74cfce909dfce405e64ab1d8e90177526b6a6247eeaf27630c57
diff --git a/dev-java/emma/emma-2.0.5312-r2.ebuild b/dev-java/emma/emma-2.0.5312-r2.ebuild
new file mode 100644
index 000000000000..aa5d87cc9a0a
--- /dev/null
+++ b/dev-java/emma/emma-2.0.5312-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# No support for javadocs in build.xml
+EAPI=2
+JAVA_PKG_IUSE="source"
+
+inherit base java-pkg-2 java-ant-2
+
+DESCRIPTION="a free Java code coverage tool"
+HOMEPAGE="http://emma.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-src.zip"
+
+LICENSE="CPL-1.0"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86 ~x86-fbsd"
+
+IUSE="+launcher"
+
+RDEPEND=">=virtual/jre-1.4
+ >=dev-java/ant-core-1.7.0
+ launcher? ( !sci-biology/emboss )"
+DEPEND=">=virtual/jdk-1.4
+ app-arch/unzip"
+
+EANT_BUILD_TARGET="build"
+
+java_prepare() {
+ epatch "${FILESDIR}/${P}-java15api.patch"
+ # bcp mangling unneccessary for 1.4+ and breaks with IBM 1.6 - bug #220463
+ sed -e '/bootclasspathref/d' -e '/extdirs/d' -i build.xml
+}
+
+src_install() {
+ java-pkg_dojar dist/${PN}.jar
+ java-pkg_dojar dist/${PN}_ant.jar
+ java-pkg_register-ant-task
+ use launcher && java-pkg_dolauncher ${PN} --main emmarun
+ # One of these does not have java sources
+ use source && java-pkg_dosrc */*/com 2> /dev/null
+}
diff --git a/dev-java/emma/files/emma-2.0.5312-java15api.patch b/dev-java/emma/files/emma-2.0.5312-java15api.patch
new file mode 100644
index 000000000000..e7a28ba2883f
--- /dev/null
+++ b/dev-java/emma/files/emma-2.0.5312-java15api.patch
@@ -0,0 +1,13 @@
+diff --git a/core/java12/com/vladium/emma/rt/InstrClassLoader.java b/core/java12/com/vladium/emma/rt/InstrClassLoader.java
+index 4ea4f80..2c14287 100644
+--- a/core/java12/com/vladium/emma/rt/InstrClassLoader.java
++++ b/core/java12/com/vladium/emma/rt/InstrClassLoader.java
+@@ -343,7 +343,7 @@ final class InstrClassLoader extends URLClassLoader
+ // support ProtectionDomains with non-null class source URLs:
+ // [however, disable anything related to sealing or signing]
+
+- final CodeSource csrc = new CodeSource (srcURL, null);
++ final CodeSource csrc = new CodeSource (srcURL, (java.security.cert.Certificate[]) null);
+
+ // allow getPackage() to return non-null on the class we are about to
+ // define (however, don't bother emulating the original manifest info since
diff --git a/dev-java/emma/metadata.xml b/dev-java/emma/metadata.xml
new file mode 100644
index 000000000000..45e018e0f406
--- /dev/null
+++ b/dev-java/emma/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <longdescription lang="en">
+ EMMA is an open-source toolkit for measuring and reporting Java code
+ coverage. EMMA distinguishes itself from other tools by going after
+ a unique feature combination: support for large-scale enterprise
+ software development while keeping individual developer's work fast
+ and iterative. Every developer on your team can now get code coverage
+ for free and they can get it fast
+ </longdescription>
+ <use>
+ <flag name="launcher">Install /usr/bin/emma. Collides with <pkg>sci-biology/emboss</pkg>.</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">emma</remote-id>
+ </upstream>
+</pkgmetadata>