summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2022-02-05 19:35:07 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2022-02-06 09:51:27 +0100
commit7a5df8a5a744c2da4261923a098bebd13ba6b61e (patch)
tree0b07ace79f6d68501c3b812976b4fc08b07b2228 /dev-java/commons-collections
parentwww-apps/radicale: minor ebuild enhancements for 3.1.4 (diff)
downloadgentoo-7a5df8a5a744c2da4261923a098bebd13ba6b61e.tar.gz
gentoo-7a5df8a5a744c2da4261923a098bebd13ba6b61e.tar.bz2
gentoo-7a5df8a5a744c2da4261923a098bebd13ba6b61e.zip
dev-java/commons-collections: Drop 4.1-r1
Closes: https://bugs.gentoo.org/830639 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Closes: https://github.com/gentoo/gentoo/pull/24090 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'dev-java/commons-collections')
-rw-r--r--dev-java/commons-collections/Manifest1
-rw-r--r--dev-java/commons-collections/commons-collections-4.1-r1.ebuild53
2 files changed, 0 insertions, 54 deletions
diff --git a/dev-java/commons-collections/Manifest b/dev-java/commons-collections/Manifest
index 466c5b01284b..a70cf6348c0f 100644
--- a/dev-java/commons-collections/Manifest
+++ b/dev-java/commons-collections/Manifest
@@ -1,3 +1,2 @@
DIST commons-collections-3.2.2-src.tar.gz 630693 BLAKE2B a70cebe9526291d5207db7edd7c9b50060413880d41dcb28c01cf05f7e00a9f5e1560012c3c3c763162412282db9512bc2b64a5788f210c5c8866943d912dafb SHA512 2e8ef638f07515b028a3e7e97851fcf1d9023a2c188e211bd1e936f35d3d91c2885adf3b1103ad17dfb7aeea6e7a67ce7826ee346a8a29c1aa7c6b0cf14e9230
DIST commons-collections-4.4-src.tar.gz 703008 BLAKE2B f4a0e858eb7412bdd431894f923a4731685ceb2463bee002401d8048cc40534f002ec0291aa67297e061a50b624d3de8f64e227f513ab1f3620e38d1d6858255 SHA512 2110e73eda97ca52a886cb708f21d8609a83655861594f3b6eb7a15b777d42eeeefc5d3b28ffc6ecc5e4f0b3fd5407f80019c2ce006f970f55455ef33eee47ee
-DIST commons-collections4-4.1-src.tar.gz 704671 BLAKE2B dea1b630168373013ca937c9b02414b92845fdd9ddf7a22a05c4d7f8d30ff26d73f3a2d399d7a4c026f8ec43a282120fdf3d3cb1042a311c3b490ffed1774e30 SHA512 c5666f41b68c9fdba3731730595616b16f98579c077cf047f421a46729b5a65476a8707125a2c0b0c6c024ca94df8c2633123bd99e705149fcb1afadcd3bf68b
diff --git a/dev-java/commons-collections/commons-collections-4.1-r1.ebuild b/dev-java/commons-collections/commons-collections-4.1-r1.ebuild
deleted file mode 100644
index 228b947a439d..000000000000
--- a/dev-java/commons-collections/commons-collections-4.1-r1.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-JAVA_PKG_IUSE="doc source"
-MAVEN_ID="org.apache.commons:commons-collections4:4.1"
-
-inherit java-pkg-2 java-pkg-simple
-
-SLOT="4"
-MY_P="${PN}${SLOT}-${PV}"
-
-DESCRIPTION="Extends the JCF classes with new interfaces, implementations and utilities"
-HOMEPAGE="https://commons.apache.org/collections/"
-SRC_URI="mirror://apache/${PN/-//}/source/${MY_P}-src.tar.gz"
-LICENSE="Apache-2.0"
-KEYWORDS="amd64 arm64 ppc64 x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
- >=virtual/jdk-1.8
- test? (
- dev-java/easymock:3.2
- dev-java/junit:4
- )"
-
-RDEPEND="
- >=virtual/jre-1.8"
-
-S="${WORKDIR}/${MY_P}-src"
-
-JAVA_SRC_DIR="src/main/java"
-
-src_install() {
- java-pkg-simple_src_install
- dodoc RELEASE-NOTES.txt
- docinto html
- dodoc {DEVELOPERS-GUIDE,PROPOSAL}.html
-}
-
-src_test() {
- local DIR=src/test/java
- local CP="${DIR}:${DIR}/../resources:${PN}.jar:$(java-pkg_getjars easymock-3.2,junit-4)"
- local TESTS=$(find ${DIR} -name "*Test.java" ! -name "Abstract*" ! -name "BulkTest.*")
- TESTS="${TESTS//src\/test\/java\/}"
- TESTS="${TESTS//.java}"
- TESTS="${TESTS//\//.}"
-
- ejavac -cp "${CP}" -d ${DIR} $(find ${DIR} -name "*.java")
- ejunit4 -classpath "${CP}" ${TESTS}
-}