summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormatoro <matoro@users.noreply.github.com>2022-09-16 10:34:25 -0400
committerJakov Smolić <jsmolic@gentoo.org>2022-10-06 08:08:46 +0200
commit8862ba4bc1ed0ef5f43a615af652d0d8f58348a4 (patch)
treebb1fc7b98cb95c83b732ec8ea2bb0f775a8a54e5 /dev-haskell/skylighting-core
parentdev-haskell/pretty-show: keyword 1.10 for ~riscv (diff)
downloadgentoo-8862ba4bc1ed0ef5f43a615af652d0d8f58348a4.tar.gz
gentoo-8862ba4bc1ed0ef5f43a615af652d0d8f58348a4.tar.bz2
gentoo-8862ba4bc1ed0ef5f43a615af652d0d8f58348a4.zip
dev-haskell/skylighting-core: keyword 0.12.3.1 for ~riscv
Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Diffstat (limited to 'dev-haskell/skylighting-core')
-rw-r--r--dev-haskell/skylighting-core/files/skylighting-increase-timeouts.patch39
-rw-r--r--dev-haskell/skylighting-core/skylighting-core-0.12.3.1.ebuild3
2 files changed, 41 insertions, 1 deletions
diff --git a/dev-haskell/skylighting-core/files/skylighting-increase-timeouts.patch b/dev-haskell/skylighting-core/files/skylighting-increase-timeouts.patch
new file mode 100644
index 000000000000..8dce65f4c855
--- /dev/null
+++ b/dev-haskell/skylighting-core/files/skylighting-increase-timeouts.patch
@@ -0,0 +1,39 @@
+https://github.com/jgm/skylighting/pull/154
+
+From 00af1d629c2f185fd3c8d3eee55857b1325f345b Mon Sep 17 00:00:00 2001
+From: matoro <matoro@users.noreply.github.com>
+Date: Fri, 16 Sep 2022 10:30:35 -0400
+Subject: [PATCH] Notch up core test timeout even further
+
+On very slow/embedded cpus, 25 seconds is not sufficient (even 50
+seconds is not); I had to notch the test timeout up to 75 seconds for
+everything to pass.
+
+This disables the test timeouts completely.
+---
+ test/test-skylighting.hs | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/test/test-skylighting.hs b/test/test-skylighting.hs
+index a3977e72..0f05e573 100644
+--- a/test/test-skylighting.hs
++++ b/test/test-skylighting.hs
+@@ -224,8 +224,7 @@ p_no_drop cfg syntax t =
+
+ noDropTest :: TokenizerConfig -> [Text] -> Syntax -> TestTree
+ noDropTest cfg inps syntax =
+- localOption (mkTimeout 25000000)
+- $ testCase (Text.unpack (sName syntax))
++ testCase (Text.unpack (sName syntax))
+ $ mapM_ go inps
+ where go inp =
+ case tokenize cfg syntax inp of
+@@ -238,7 +237,7 @@ noDropTest cfg inps syntax =
+ assertFailure ("Unexpected error: " ++ e ++ "\ninput = " ++ show inp)
+
+ tokenizerTest :: TokenizerConfig -> SyntaxMap -> Bool -> FilePath -> TestTree
+-tokenizerTest cfg sMap regen inpFile = localOption (mkTimeout 25000000) $
++tokenizerTest cfg sMap regen inpFile =
+ goldenTest testname getExpected getActual
+ (compareValues referenceFile) updateGolden
+ where testname = lang ++ " tokenizing of " ++ inpFile
diff --git a/dev-haskell/skylighting-core/skylighting-core-0.12.3.1.ebuild b/dev-haskell/skylighting-core/skylighting-core-0.12.3.1.ebuild
index e9f59184a966..9e849c9733d5 100644
--- a/dev-haskell/skylighting-core/skylighting-core-0.12.3.1.ebuild
+++ b/dev-haskell/skylighting-core/skylighting-core-0.12.3.1.ebuild
@@ -15,8 +15,9 @@ SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
-KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
IUSE="executable"
+PATCHES=( "${FILESDIR}/skylighting-increase-timeouts.patch" )
RDEPEND=">=dev-haskell/aeson-1.0:=[profile?]
>=dev-haskell/ansi-terminal-0.7:=[profile?]