summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:04:09 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:08:48 +0100
commit0e41810c2e06a8483201dd2f36de000754b4a19b (patch)
treed5369c6c6a887db7238df0f42c091cdaf7e0e4ea /dev-haskell/parsec
parentdev-haskell/stm: add 2.5.0.2-r1 (diff)
downloadgentoo-0e41810c2e06a8483201dd2f36de000754b4a19b.tar.gz
gentoo-0e41810c2e06a8483201dd2f36de000754b4a19b.tar.bz2
gentoo-0e41810c2e06a8483201dd2f36de000754b4a19b.zip
dev-haskell/parsec: add 3.1.15.0-r1
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/parsec')
-rw-r--r--dev-haskell/parsec/Manifest1
-rw-r--r--dev-haskell/parsec/metadata.xml8
-rw-r--r--dev-haskell/parsec/parsec-3.1.15.0-r1.ebuild34
3 files changed, 35 insertions, 8 deletions
diff --git a/dev-haskell/parsec/Manifest b/dev-haskell/parsec/Manifest
index 917d10325963..9b16df62bf2d 100644
--- a/dev-haskell/parsec/Manifest
+++ b/dev-haskell/parsec/Manifest
@@ -1,2 +1,3 @@
DIST parsec-3.1.14.0-rev4.cabal 4356 BLAKE2B 6c0d7b4ae6c2adad8e79eee1f90ce51b6451b5929bddbd553e9a58cf4f9c169d48910ed8a6254afec54c096caf473230ce3f5672da60c4c170dcadfe9e1d1120 SHA512 4f5cef855f39497f7c84cb9f033cde9b8326a38a81d6ed1dab310078a935a14f36aa3f660b0ff1ef73333841c603c4a28237e96df1737de70ba9f88df84780c1
DIST parsec-3.1.14.0.tar.gz 35688 BLAKE2B 474b14ff35d332339ce07f09ef22cbbdf971de9d9712848eb1c67b7ea4359e46079b67d39f978755c7560c55baf6d5f0d69a425291644a3ff638139a8bbec3ce SHA512 db14f77a2d36da5e540be35f0facb7fa61f2c46057b98039bdf16c06fe9865d5ee47e3523a312201665ca133f3f93855b42f0d0a920b8e233ffc8274075c56d3
+DIST parsec-3.1.15.0.tar.gz 36412 BLAKE2B b7d0b0eb022c0662a023d94e83106a528ed2fe280e3aa4cbd643479045d8afdee66a6dee938d5b7932e823fa39dddff18a407efb03a26d0029f1aea59b8738ef SHA512 fab7c48f43fae2708ee2d345897f827111408f82f4370442047d49d703de5d7a9666753926486764a3cfab15df98cf0f8e37d5b73811ffc80797ee498b4eb591
diff --git a/dev-haskell/parsec/metadata.xml b/dev-haskell/parsec/metadata.xml
index 443ee87b2842..5e5863ecfd97 100644
--- a/dev-haskell/parsec/metadata.xml
+++ b/dev-haskell/parsec/metadata.xml
@@ -5,14 +5,6 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
- <longdescription>
- Parsec is designed from scratch as an industrial-strength parser
- library. It is simple, safe, well documented (on the package
- homepage), has extensive libraries and good error messages,
- and is also fast. It is defined as a monad transformer that can be
- stacked on arbitrary monads, and it is also parametric in the
- input stream type.
- </longdescription>
<upstream>
<remote-id type="hackage">parsec</remote-id>
<remote-id type="github">haskell/parsec</remote-id>
diff --git a/dev-haskell/parsec/parsec-3.1.15.0-r1.ebuild b/dev-haskell/parsec/parsec-3.1.15.0-r1.ebuild
new file mode 100644
index 000000000000..e31e8cee36c8
--- /dev/null
+++ b/dev-haskell/parsec/parsec-3.1.15.0-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.0.0.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour" # test-suite circular depends
+# break circular dependencies:
+# https://github.com/gentoo-haskell/gentoo-haskell/issues/810
+CABAL_FEATURES+=" nocabaldep"
+inherit haskell-cabal
+
+DESCRIPTION="Monadic parser combinators"
+HOMEPAGE="https://github.com/haskell/parsec"
+
+LICENSE="BSD-2"
+SLOT="0/${PV}"
+# Keep in sync with relevant ghc versions (CABAL_CORE_LIB_GHC_PV)
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+RESTRICT=test # circular dependencies: dev-haskell/base-orphans->cabal->parsec[test]->test-framework-hunit->test-framework->base-orphans
+
+RDEPEND="
+ >=dev-lang/ghc-9.2.4:=
+"
+DEPEND="${RDEPEND}
+"
+# test? (
+# >=dev-haskell/tasty-1.4 <dev-haskell/tasty-1.5
+# >=dev-haskell/tasty-hunit-0.10 <dev-haskell/tasty-hunit-0.11
+# )
+
+CABAL_CORE_LIB_GHC_PV="9.2.4 9.2.5 9.2.6 9.2.7 9.2.8 9.4.4 9.4.5"