summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:08:58 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:09:56 +0100
commit5bb934c8e9e2dd0832ba6a35d285ebcb0e029685 (patch)
tree9c20550b56cec46ce494a3ad4a1bd9135a093890 /dev-haskell/network-uri
parentdev-haskell/network-info: add 0.2.1 (diff)
downloadgentoo-5bb934c8e9e2dd0832ba6a35d285ebcb0e029685.tar.gz
gentoo-5bb934c8e9e2dd0832ba6a35d285ebcb0e029685.tar.bz2
gentoo-5bb934c8e9e2dd0832ba6a35d285ebcb0e029685.zip
dev-haskell/network-uri: add 2.6.4.2 Signed-off-by: hololeap <hololeap@protonmail.com>
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/network-uri')
-rw-r--r--dev-haskell/network-uri/Manifest1
-rw-r--r--dev-haskell/network-uri/metadata.xml24
-rw-r--r--dev-haskell/network-uri/network-uri-2.6.4.2.ebuild39
3 files changed, 41 insertions, 23 deletions
diff --git a/dev-haskell/network-uri/Manifest b/dev-haskell/network-uri/Manifest
index 0ec6b3bc58f0..e6efe7b1d15e 100644
--- a/dev-haskell/network-uri/Manifest
+++ b/dev-haskell/network-uri/Manifest
@@ -1 +1,2 @@
DIST network-uri-2.6.4.1.tar.gz 32373 BLAKE2B cceeb533cae70b4b3e2a4caa2a2f3722949698bcc6c2c454787195ec33050c0a3f6ff9f2d60d5d965eb13043b22759525298a1840ac7046e765bc40b3ae960c7 SHA512 8e5b01fd11197ac36de9b804d37256662f904f2b94a997a2e262439bb1706d1c460db368e935bf3971fd1581162abbc07439a0bae391e1e616264bd00fe7104e
+DIST network-uri-2.6.4.2.tar.gz 31309 BLAKE2B 4ff7d3211ac89ef06ecc6f769c0a0a6933f23bd191dbfdae90697eb31c898d05d42094dec67161ff7cff648b2a6115b7a49d40218037cd838d2160a45cb0b445 SHA512 999e94a3053a101d1dc737a26ff93f832040365e949805b1ff5327ade9ab63d20f686c9f1bb3544d6d22c7c6d0b10bfcb64b30aa226d74ed6ad8bbb28fce6c0f
diff --git a/dev-haskell/network-uri/metadata.xml b/dev-haskell/network-uri/metadata.xml
index a4f8ab16450e..9e1b07f449dd 100644
--- a/dev-haskell/network-uri/metadata.xml
+++ b/dev-haskell/network-uri/metadata.xml
@@ -5,30 +5,8 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
- <longdescription>
- This package provides an URI manipulation inteface.
-
- In network-2.6 the @Network.URI@ module was split off from the
- network package into this package. If you're using the @Network.URI@
- module you can automatically get it from the right package by adding
- this to your .cabal file:
-
- &gt; flag network-uri
- &gt; description: Get Network.URI from the network-uri package
- &gt; default: True
- &gt;
- &gt; library
- &gt; -- ...
- &gt; if flag(network-uri)
- &gt; build-depends: network-uri &gt;= 2.6
- &gt; else
- &gt; build-depends: network &lt; 2.6
-
- If you want to use other modules from the network package while
- using the @Network.URI@ modules from this package, add a @network &gt;
- 2.6@ clause to the first @build-depends@ line.
- </longdescription>
<upstream>
+ <remote-id type="hackage">network-uri</remote-id>
<remote-id type="github">haskell/network-uri</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-haskell/network-uri/network-uri-2.6.4.2.ebuild b/dev-haskell/network-uri/network-uri-2.6.4.2.ebuild
new file mode 100644
index 000000000000..78efe4ef49f6
--- /dev/null
+++ b/dev-haskell/network-uri/network-uri-2.6.4.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.0.0.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="URI manipulation"
+HOMEPAGE="https://github.com/haskell/network-uri"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-haskell/th-compat-0.1.1:=[profile?] <dev-haskell/th-compat-1.0:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+ test? (
+ dev-haskell/hunit
+ dev-haskell/quickcheck
+ dev-haskell/tasty
+ dev-haskell/tasty-hunit
+ dev-haskell/tasty-quickcheck
+ )
+"
+
+pkg_pretend() {
+ if use test; then
+ ewarn "The \"test\" USE flag for this package creates cycles within the"
+ ewarn "dependency graph. This may give you problems during 'haskell-updater' runs."
+ ewarn "It is recommended to leave it disabled unless explicitly testing the package."
+ fi
+}