summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/fingertree
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/fingertree')
-rw-r--r--dev-haskell/fingertree/Manifest3
-rw-r--r--dev-haskell/fingertree/fingertree-0.1.0.0.ebuild29
-rw-r--r--dev-haskell/fingertree/fingertree-0.1.0.2.ebuild30
-rw-r--r--dev-haskell/fingertree/fingertree-0.1.1.0.ebuild30
-rw-r--r--dev-haskell/fingertree/metadata.xml20
5 files changed, 112 insertions, 0 deletions
diff --git a/dev-haskell/fingertree/Manifest b/dev-haskell/fingertree/Manifest
new file mode 100644
index 000000000000..1ccbab4c0174
--- /dev/null
+++ b/dev-haskell/fingertree/Manifest
@@ -0,0 +1,3 @@
+DIST fingertree-0.1.0.0.tar.gz 14216 SHA256 baa601587f8ed614886e02ca8b1eb915e6946e9937f4c4f7565c46fd7dd66530 SHA512 0189a75fccdb30fcfa29166152caea4836c959fb43ca115b9e3fb6848af7aaf517a733ad27e0676fb658b64d26b0306f1c1f0ced8953f680ea3d09973fe6ca99 WHIRLPOOL dd86370861cfa5996e40b063a8a83b2434177b8c9ee2b18aa21b970127fd8251dcdb13b01412327f73b502c8db076fd5e1af79f27ec254134666ff36aa503263
+DIST fingertree-0.1.0.2.tar.gz 14286 SHA256 e6232c5c77afbb8a70dcd898253fdb07f240f71144c8b12118df526376f53acf SHA512 ba948c6664b814be32c7360014a6ec0f30886204ce75d7e899457e3b16c57e4b7559b6c0de63d66433dab6e75aacb0d902ba079b3f224a577fb72a618c14282c WHIRLPOOL 93f6b3cf2ef73ca1156a53a4774d7d43589eed41fd2a22467ca1f83b2761b5ed4fc328d692ec5d8ed06a88c44a07a58e0cbcea2a2142b2eed8bb5ba62f2b9825
+DIST fingertree-0.1.1.0.tar.gz 14415 SHA256 160c5ba370d781dbf2920ddca870ce8596ab76729972535595bef835ee1cddf0 SHA512 47d7387e11cf05a2df323c6af76a12e6cf02a857f7131203400cbc6ba9ee4c3c9e2c721a8423e6456a385f5ea0c4aedd0e9a2600d2d33609c0457cd259337016 WHIRLPOOL 938296bb6a695774fa933231361d5a3879e0dc45a8227093875bc1a6c8fc1200faaba55a869d13635ea673bf822aa58ac669d27740ee261d410156052817fd2b
diff --git a/dev-haskell/fingertree/fingertree-0.1.0.0.ebuild b/dev-haskell/fingertree/fingertree-0.1.0.0.ebuild
new file mode 100644
index 000000000000..341a33831ed8
--- /dev/null
+++ b/dev-haskell/fingertree/fingertree-0.1.0.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Generic finger-tree structure, with example instances"
+HOMEPAGE="http://hackage.haskell.org/package/fingertree"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/hunit
+ dev-haskell/quickcheck
+ dev-haskell/test-framework
+ dev-haskell/test-framework-hunit
+ dev-haskell/test-framework-quickcheck2
+ )"
diff --git a/dev-haskell/fingertree/fingertree-0.1.0.2.ebuild b/dev-haskell/fingertree/fingertree-0.1.0.2.ebuild
new file mode 100644
index 000000000000..8a2c977fd9d3
--- /dev/null
+++ b/dev-haskell/fingertree/fingertree-0.1.0.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Generic finger-tree structure, with example instances"
+HOMEPAGE="http://hackage.haskell.org/package/fingertree"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/hunit
+ dev-haskell/quickcheck
+ dev-haskell/test-framework
+ dev-haskell/test-framework-hunit
+ dev-haskell/test-framework-quickcheck2 )
+"
diff --git a/dev-haskell/fingertree/fingertree-0.1.1.0.ebuild b/dev-haskell/fingertree/fingertree-0.1.1.0.ebuild
new file mode 100644
index 000000000000..8a2c977fd9d3
--- /dev/null
+++ b/dev-haskell/fingertree/fingertree-0.1.1.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Generic finger-tree structure, with example instances"
+HOMEPAGE="http://hackage.haskell.org/package/fingertree"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/hunit
+ dev-haskell/quickcheck
+ dev-haskell/test-framework
+ dev-haskell/test-framework-hunit
+ dev-haskell/test-framework-quickcheck2 )
+"
diff --git a/dev-haskell/fingertree/metadata.xml b/dev-haskell/fingertree/metadata.xml
new file mode 100644
index 000000000000..bca943599678
--- /dev/null
+++ b/dev-haskell/fingertree/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ A general sequence representation with arbitrary
+ annotations, for use as a base for implementations of
+ various collection types, with examples, as described
+ in section 4 of
+
+ * Ralf Hinze and Ross Paterson,
+ \&quot;Finger trees: a simple general-purpose data structure\&quot;,
+ /Journal of Functional Programming/ 16:2 (2006) pp 197-217.
+ &lt;http://www.soi.city.ac.uk/~ross/papers/FingerTree.html&gt;
+
+ For a tuned sequence type, see @Data.Sequence@ in the
+ @containers@ package, which is a specialization of
+ this structure.
+ </longdescription>
+</pkgmetadata>