summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:04:34 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:08:54 +0100
commit9fdfc87b4d1623615db6db1495bd83d4c2b00d4b (patch)
tree69393ab6a0c4d04aa9850a1165a25c9fb9314b48 /dev-haskell/citeproc
parentdev-haskell/base64: new package, add 0.4.2.4 (diff)
downloadgentoo-9fdfc87b4d1623615db6db1495bd83d4c2b00d4b.tar.gz
gentoo-9fdfc87b4d1623615db6db1495bd83d4c2b00d4b.tar.bz2
gentoo-9fdfc87b4d1623615db6db1495bd83d4c2b00d4b.zip
dev-haskell/citeproc: add 0.8.1
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/citeproc')
-rw-r--r--dev-haskell/citeproc/Manifest1
-rw-r--r--dev-haskell/citeproc/citeproc-0.8.1.ebuild53
-rw-r--r--dev-haskell/citeproc/metadata.xml10
3 files changed, 58 insertions, 6 deletions
diff --git a/dev-haskell/citeproc/Manifest b/dev-haskell/citeproc/Manifest
index 9a07a5b42658..557496d77e0d 100644
--- a/dev-haskell/citeproc/Manifest
+++ b/dev-haskell/citeproc/Manifest
@@ -1 +1,2 @@
DIST citeproc-0.7.tar.gz 528208 BLAKE2B 9ad395c2c3ba7bc957554b37af1a514c3deb3247a55a41b35c88b25f25db474043d18de5909e67ac5723fbfb0a5ed8161a16eb851f59c5648cfa3b30149c46fe SHA512 e24675c0d9227bd6ff5f13788c251647df1e61a65a1b0fe94d80c0bf064bd3018285ace6397d0c5f2b5d6e4ee9b91de8b90e6e4251e9914fb8fcbf58ed3c4539
+DIST citeproc-0.8.1.tar.gz 549947 BLAKE2B 055ec6466ec96cd44bf64d3cb9a9f92c5f9e825aaab93147905d3a69c5040807c1bf048196cede7d341608c96b39d9054545987b9de11be622aad6176895805e SHA512 7bce91a19e8db475b7c0c7f1f324e356dfb895fddc575b59d3fcdb8955b1ee17a82d3943edc383669a7bb5cc9fb14b3ff1cea766a2d322157017a97acddeee32
diff --git a/dev-haskell/citeproc/citeproc-0.8.1.ebuild b/dev-haskell/citeproc/citeproc-0.8.1.ebuild
new file mode 100644
index 000000000000..2aa2e572cfc2
--- /dev/null
+++ b/dev-haskell/citeproc/citeproc-0.8.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.2.0.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Generates citations and bibliography from CSL styles"
+HOMEPAGE="https://hackage.haskell.org/package/citeproc"
+
+LICENSE="BSD-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="executable icu"
+
+# Many tests for this package are known to fail and this is acceptable for
+# upstream:
+# <https://github.com/jgm/citeproc#known-bugs-and-limitations>
+# The author seems to know which tests are expected to fail, but I
+# can't find documentation for exactly which ones.
+RESTRICT="test"
+
+RDEPEND="dev-haskell/aeson:=[profile?]
+ dev-haskell/attoparsec:=[profile?]
+ >=dev-haskell/case-insensitive-1.2:=[profile?] <dev-haskell/case-insensitive-1.3:=[profile?]
+ >=dev-haskell/data-default-0.5.2:=[profile?]
+ dev-haskell/file-embed:=[profile?]
+ >=dev-haskell/pandoc-types-1.22:=[profile?] <dev-haskell/pandoc-types-1.24:=[profile?]
+ dev-haskell/safe:=[profile?]
+ dev-haskell/scientific:=[profile?]
+ dev-haskell/text:=[profile?]
+ >=dev-haskell/unicode-collation-0.1.3:=[profile?] <dev-haskell/unicode-collation-0.2:=[profile?]
+ dev-haskell/uniplate:=[profile?]
+ dev-haskell/vector:=[profile?]
+ dev-haskell/xml-conduit:=[profile?]
+ >=dev-lang/ghc-8.8.1:=
+ executable? ( dev-haskell/aeson-pretty:=[profile?] )
+ icu? ( >=dev-haskell/text-icu-0.7.1.0:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.0.0.0
+ test? ( >=dev-haskell/diff-0.4
+ dev-haskell/timeit )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag executable executable) \
+ $(cabal_flag icu icu)
+}
diff --git a/dev-haskell/citeproc/metadata.xml b/dev-haskell/citeproc/metadata.xml
index 68e37597bcd1..0066044cfb40 100644
--- a/dev-haskell/citeproc/metadata.xml
+++ b/dev-haskell/citeproc/metadata.xml
@@ -9,10 +9,8 @@
<flag name="executable">Build citeproc executable</flag>
<flag name="icu">Use Haskell bindings to the ICU library</flag>
</use>
- <longdescription>
- citeproc parses CSL style files and uses them to
- generate a list of formatted citations and bibliography
- entries. For more information about CSL, see
- &lt;https://citationstyles.org/&gt;.
- </longdescription>
+ <upstream>
+ <remote-id type="hackage">citeproc</remote-id>
+ <remote-id type="github">jgm/citeproc</remote-id>
+ </upstream>
</pkgmetadata>