summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/bits-atomic
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/bits-atomic')
-rw-r--r--dev-haskell/bits-atomic/Manifest1
-rw-r--r--dev-haskell/bits-atomic/bits-atomic-0.1.3.ebuild24
-rw-r--r--dev-haskell/bits-atomic/metadata.xml38
3 files changed, 63 insertions, 0 deletions
diff --git a/dev-haskell/bits-atomic/Manifest b/dev-haskell/bits-atomic/Manifest
new file mode 100644
index 000000000000..9c9e96e1f9f1
--- /dev/null
+++ b/dev-haskell/bits-atomic/Manifest
@@ -0,0 +1 @@
+DIST bits-atomic-0.1.3.tar.gz 7982 SHA256 e0ac3456cf0338e1d5ed33f4c3c6b932d652add2ac827c6a1b6636c6e754cb8d SHA512 e13c21c81ebc6cce2f85a184a572eb1647439f605985a8344ff219cc685c7d0adcf5d2433ea75fa1560a807e329cab23b548435adc0087e6294417eb7a65fbf1 WHIRLPOOL 3c15101610d87f202b910c60f9b875623661872bc91c8ae084e720f94633392b1338df3ee9d8eb3bd104e3c9c0d7dd949ead3a8f28be65e6a9f6458fda620a08
diff --git a/dev-haskell/bits-atomic/bits-atomic-0.1.3.ebuild b/dev-haskell/bits-atomic/bits-atomic-0.1.3.ebuild
new file mode 100644
index 000000000000..5ef53398b9c0
--- /dev/null
+++ b/dev-haskell/bits-atomic/bits-atomic-0.1.3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Atomic bit operations on memory locations
+for low-level synchronization"
+HOMEPAGE="http://hackage.haskell.org/package/bits-atomic"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
diff --git a/dev-haskell/bits-atomic/metadata.xml b/dev-haskell/bits-atomic/metadata.xml
new file mode 100644
index 000000000000..0e02475e5f09
--- /dev/null
+++ b/dev-haskell/bits-atomic/metadata.xml
@@ -0,0 +1,38 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ Atomic operations including CAS (compare-and-swap), fetch &amp; add and variants
+ suitable for low-level shared-memory synchronization.
+
+ The implementation is using GCC&#39;s builtin atomic operations (available in GCC &gt;=
+ 4) in C wrappers called through the FFI. See these links for background:
+
+ * GCC manual: &lt;http://gcc.gnu.org/onlinedocs/gcc/Atomic-Builtins.html&gt;
+
+ * GCC wiki: &lt;http://gcc.gnu.org/wiki/Atomic&gt;
+
+ /Portability/: This package is primarily developed on a Linux system, but
+ should work wherever GCC &gt;= 4 is available. It has been confirmed as working
+ on OSX. On Windows, it should work with Cygwin but currently fails for
+ vanilla Haskell-Platform 2010.1.0.0 as it still packages GCC 3.x. An
+ installer for updated versions of GCC is available at
+ &lt;http://www.mingw.org/&gt; and should make this package work in connection with
+ Haskell-Platform. Feedback on compatibility would be appreciated.
+
+ /Testing:/ The following commands can be used to compile and run the test suite:
+
+ &gt; cabal unpack bits-atomic &amp;&amp; cd bits-atomic-* # if not yet locally available
+ &gt; cabal configure -ftest
+ &gt; cabal build
+ &gt; cabal test
+
+ /Recent changes/:
+
+ * 0.1.3: Documentation updates, especially on portability. No functional
+ changes.
+
+ * 0.1.2: Avoid using System.FilePath in Setup.hs to fix build failure on hackage
+ </longdescription>
+</pkgmetadata>