summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/aws
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/aws')
-rw-r--r--dev-haskell/aws/Manifest3
-rw-r--r--dev-haskell/aws/aws-0.11.2.ebuild75
-rw-r--r--dev-haskell/aws/aws-0.11.3-r1.ebuild84
-rw-r--r--dev-haskell/aws/aws-0.12.1.ebuild76
-rw-r--r--dev-haskell/aws/files/aws-0.11.3-ghc-7.10.patch20
-rw-r--r--dev-haskell/aws/metadata.xml11
6 files changed, 269 insertions, 0 deletions
diff --git a/dev-haskell/aws/Manifest b/dev-haskell/aws/Manifest
new file mode 100644
index 000000000000..11de021e4619
--- /dev/null
+++ b/dev-haskell/aws/Manifest
@@ -0,0 +1,3 @@
+DIST aws-0.11.2.tar.gz 89149 SHA256 f1e3df0c141823f384f3410c9eef92eb410b716b0caa6534aec67dacb82b1697 SHA512 5e69f0bdb7459f6da7e123c2bf3435805b724d4c2ff3178728b241ae2d7e772e742d669c55fc0f51e42bfdee14fa940cba323e8473af3a16c286000f7b8c2733 WHIRLPOOL 03326691ee667c09153b7c89af150dd11816905b04d691f395f59bd3d5fc48bdae625dde08af7bb35d12275cb3daf0eb3c32cde66eb7608c93a8cf4746a69ff2
+DIST aws-0.11.3.tar.gz 90102 SHA256 14a9a9f4435f92b9a0364de66469e293f3ad09c7fe54aacce3486280866de30a SHA512 0343d8ef17ad06525c7c131eb97408d3298c46f4dd472604bd4b3a20c2bb1e880e12f9a0e345ee2fe9bfe56b684fd653e9a99b7919e8d97fce4ca0cdd720afb5 WHIRLPOOL 49e49b802c0c996d3b94d68dafcc3eed82f0b104f1a339e1ff3f9c8e12638543021394c79d24bbba3cf51c3f2a6c8638f71b8be8f8ca7e7c656924c52700ebc3
+DIST aws-0.12.1.tar.gz 90763 SHA256 6c85bac359ea94d78f287b45c6e7e981dc260a1c029a7888ed752a1c0e64d32b SHA512 8c89a982196b654ad4f001d30cb415a9272aacb582c8879173babc4183ca4eb21c025399f1bb5e2624a77a1c38da9b4637bf1dfa0a5bbccb888808a5e654bbf9 WHIRLPOOL 2a82e24cac4011b02408e76122fbbb3d7b871c907503da8a167b5d81752b4c4ecc766fd6095345694f1283ff28c4766f1c8c7254d3ff8e37a2dd1d6268d2731f
diff --git a/dev-haskell/aws/aws-0.11.2.ebuild b/dev-haskell/aws/aws-0.11.2.ebuild
new file mode 100644
index 000000000000..2ec4ce908a5f
--- /dev/null
+++ b/dev-haskell/aws/aws-0.11.2.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.3
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Amazon Web Services (AWS) for Haskell"
+HOMEPAGE="http://github.com/aristidb/aws"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RESTRICT=test # needs aws accound
+
+RDEPEND=">=dev-haskell/aeson-0.6:=[profile?]
+ >=dev-haskell/attoparsec-0.11:=[profile?] <dev-haskell/attoparsec-0.13:=[profile?]
+ >=dev-haskell/base16-bytestring-0.1:=[profile?] <dev-haskell/base16-bytestring-0.2:=[profile?]
+ >=dev-haskell/base64-bytestring-1.0:=[profile?] <dev-haskell/base64-bytestring-1.1:=[profile?]
+ >=dev-haskell/blaze-builder-0.2.1.4:=[profile?] <dev-haskell/blaze-builder-0.4:=[profile?]
+ >=dev-haskell/byteable-0.1:=[profile?] <dev-haskell/byteable-0.2:=[profile?]
+ >=dev-haskell/case-insensitive-0.2:=[profile?] <dev-haskell/case-insensitive-1.3:=[profile?]
+ >=dev-haskell/cereal-0.3:=[profile?] <dev-haskell/cereal-0.5:=[profile?]
+ >=dev-haskell/conduit-1.1:=[profile?] <dev-haskell/conduit-1.3:=[profile?]
+ >=dev-haskell/conduit-extra-1.1:=[profile?] <dev-haskell/conduit-extra-1.2:=[profile?]
+ >=dev-haskell/cryptohash-0.11:=[profile?] <dev-haskell/cryptohash-0.12:=[profile?]
+ >=dev-haskell/data-default-0.5.3:=[profile?] <dev-haskell/data-default-0.6:=[profile?]
+ >=dev-haskell/http-conduit-2.1:=[profile?] <dev-haskell/http-conduit-2.2:=[profile?]
+ >=dev-haskell/http-types-0.7:=[profile?] <dev-haskell/http-types-0.9:=[profile?]
+ >=dev-haskell/lifted-base-0.1:=[profile?] <dev-haskell/lifted-base-0.3:=[profile?]
+ >=dev-haskell/monad-control-0.3:=[profile?]
+ >=dev-haskell/mtl-2:=[profile?] <dev-haskell/mtl-3:=[profile?]
+ >=dev-haskell/network-2:=[profile?] <dev-haskell/network-3:=[profile?]
+ >=dev-haskell/resourcet-1.1:=[profile?] <dev-haskell/resourcet-1.2:=[profile?]
+ >=dev-haskell/safe-0.3:=[profile?] <dev-haskell/safe-0.4:=[profile?]
+ >=dev-haskell/scientific-0.3:=[profile?]
+ >=dev-haskell/tagged-0.7:=[profile?] <dev-haskell/tagged-0.8:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?]
+ >=dev-haskell/unordered-containers-0.2:=[profile?]
+ >=dev-haskell/utf8-string-0.3:=[profile?] <dev-haskell/utf8-string-0.4:=[profile?]
+ >=dev-haskell/vector-0.10:=[profile?]
+ >=dev-haskell/xml-conduit-1.2:=[profile?] <dev-haskell/xml-conduit-1.3:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ examples? ( >=dev-haskell/errors-1.4:=[profile?]
+ dev-haskell/exceptions:=[profile?]
+ >=dev-haskell/transformers-0.3:=[profile?] <dev-haskell/transformers-0.5:=[profile?] )
+ !examples? ( >=dev-haskell/transformers-0.2.2:=[profile?] <dev-haskell/transformers-0.5:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+ test? ( >=dev-haskell/aeson-0.7
+ >=dev-haskell/errors-1.4.7
+ >=dev-haskell/http-client-0.3
+ >=dev-haskell/lifted-base-0.2
+ >=dev-haskell/mtl-2.1
+ >=dev-haskell/quickcheck-2.7
+ >=dev-haskell/quickcheck-instances-0.3
+ >=dev-haskell/tasty-0.8
+ >=dev-haskell/tasty-quickcheck-0.8
+ >=dev-haskell/text-1.1
+ >=dev-haskell/transformers-base-0.4
+ !examples? ( >=dev-haskell/transformers-0.3 ) )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag examples examples)
+}
diff --git a/dev-haskell/aws/aws-0.11.3-r1.ebuild b/dev-haskell/aws/aws-0.11.3-r1.ebuild
new file mode 100644
index 000000000000..672df485fc0f
--- /dev/null
+++ b/dev-haskell/aws/aws-0.11.3-r1.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour test-suite"
+inherit base haskell-cabal
+
+DESCRIPTION="Amazon Web Services (AWS) for Haskell"
+HOMEPAGE="http://github.com/aristidb/aws"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RESTRICT=test # needs aws accound
+
+RDEPEND=">=dev-haskell/aeson-0.6:=[profile?]
+ >=dev-haskell/attoparsec-0.11:=[profile?] <dev-haskell/attoparsec-0.13:=[profile?]
+ >=dev-haskell/base16-bytestring-0.1:=[profile?] <dev-haskell/base16-bytestring-0.2:=[profile?]
+ >=dev-haskell/base64-bytestring-1.0:=[profile?] <dev-haskell/base64-bytestring-1.1:=[profile?]
+ >=dev-haskell/blaze-builder-0.2.1.4:=[profile?] <dev-haskell/blaze-builder-0.5:=[profile?]
+ >=dev-haskell/byteable-0.1:=[profile?] <dev-haskell/byteable-0.2:=[profile?]
+ >=dev-haskell/case-insensitive-0.2:=[profile?] <dev-haskell/case-insensitive-1.3:=[profile?]
+ >=dev-haskell/cereal-0.3:=[profile?] <dev-haskell/cereal-0.5:=[profile?]
+ >=dev-haskell/conduit-1.1:=[profile?] <dev-haskell/conduit-1.3:=[profile?]
+ >=dev-haskell/conduit-extra-1.1:=[profile?] <dev-haskell/conduit-extra-1.2:=[profile?]
+ >=dev-haskell/cryptohash-0.11:=[profile?] <dev-haskell/cryptohash-0.12:=[profile?]
+ >=dev-haskell/data-default-0.5.3:=[profile?] <dev-haskell/data-default-0.6:=[profile?]
+ >=dev-haskell/http-conduit-2.1:=[profile?] <dev-haskell/http-conduit-2.2:=[profile?]
+ >=dev-haskell/http-types-0.7:=[profile?] <dev-haskell/http-types-0.9:=[profile?]
+ >=dev-haskell/lifted-base-0.1:=[profile?] <dev-haskell/lifted-base-0.3:=[profile?]
+ >=dev-haskell/monad-control-0.3:=[profile?]
+ >=dev-haskell/mtl-2:=[profile?] <dev-haskell/mtl-3:=[profile?]
+ >=dev-haskell/network-2:=[profile?] <dev-haskell/network-3:=[profile?]
+ >=dev-haskell/old-locale-1:=[profile?] <dev-haskell/old-locale-2:=[profile?]
+ >=dev-haskell/resourcet-1.1:=[profile?] <dev-haskell/resourcet-1.2:=[profile?]
+ >=dev-haskell/safe-0.3:=[profile?] <dev-haskell/safe-0.4:=[profile?]
+ >=dev-haskell/scientific-0.3:=[profile?]
+ >=dev-haskell/tagged-0.7:=[profile?] <dev-haskell/tagged-0.9:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?]
+ >=dev-haskell/unordered-containers-0.2:=[profile?]
+ >=dev-haskell/utf8-string-0.3:=[profile?] <dev-haskell/utf8-string-1.1:=[profile?]
+ >=dev-haskell/vector-0.10:=[profile?]
+ >=dev-haskell/xml-conduit-1.2:=[profile?] <dev-haskell/xml-conduit-1.3:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ examples? ( >=dev-haskell/errors-1.4:=[profile?]
+ dev-haskell/exceptions:=[profile?]
+ >=dev-haskell/transformers-0.3:=[profile?] <dev-haskell/transformers-0.5:=[profile?] )
+ !examples? ( >=dev-haskell/transformers-0.2.2:=[profile?] <dev-haskell/transformers-0.5:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+ test? ( >=dev-haskell/aeson-0.7
+ >=dev-haskell/errors-1.4.7
+ >=dev-haskell/http-client-0.3
+ >=dev-haskell/lifted-base-0.2
+ >=dev-haskell/mtl-2.1
+ >=dev-haskell/quickcheck-2.7
+ >=dev-haskell/quickcheck-instances-0.3
+ >=dev-haskell/tasty-0.8
+ >=dev-haskell/tasty-quickcheck-0.8
+ >=dev-haskell/text-1.1
+ >=dev-haskell/transformers-base-0.4
+ !examples? ( >=dev-haskell/transformers-0.3 ) )
+"
+
+PATCHES=("${FILESDIR}/${P}-ghc-7.10.patch")
+
+src_prepare() {
+ base_src_prepare
+ cabal_chdeps \
+ 'tagged >= 0.7 && < 0.8' 'tagged >= 0.7 && < 0.9'
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag examples examples)
+}
diff --git a/dev-haskell/aws/aws-0.12.1.ebuild b/dev-haskell/aws/aws-0.12.1.ebuild
new file mode 100644
index 000000000000..4c88e476c76c
--- /dev/null
+++ b/dev-haskell/aws/aws-0.12.1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Amazon Web Services (AWS) for Haskell"
+HOMEPAGE="http://github.com/aristidb/aws"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RESTRICT=test # needs aws accound
+
+RDEPEND=">=dev-haskell/aeson-0.6:=[profile?]
+ >=dev-haskell/attoparsec-0.11:=[profile?] <dev-haskell/attoparsec-0.14:=[profile?]
+ >=dev-haskell/base16-bytestring-0.1:=[profile?] <dev-haskell/base16-bytestring-0.2:=[profile?]
+ >=dev-haskell/base64-bytestring-1.0:=[profile?] <dev-haskell/base64-bytestring-1.1:=[profile?]
+ >=dev-haskell/blaze-builder-0.2.1.4:=[profile?] <dev-haskell/blaze-builder-0.5:=[profile?]
+ >=dev-haskell/byteable-0.1:=[profile?] <dev-haskell/byteable-0.2:=[profile?]
+ >=dev-haskell/case-insensitive-0.2:=[profile?] <dev-haskell/case-insensitive-1.3:=[profile?]
+ >=dev-haskell/cereal-0.3:=[profile?] <dev-haskell/cereal-0.5:=[profile?]
+ >=dev-haskell/conduit-1.1:=[profile?] <dev-haskell/conduit-1.3:=[profile?]
+ >=dev-haskell/conduit-extra-1.1:=[profile?] <dev-haskell/conduit-extra-1.2:=[profile?]
+ >=dev-haskell/cryptohash-0.11:=[profile?] <dev-haskell/cryptohash-0.12:=[profile?]
+ >=dev-haskell/data-default-0.5.3:=[profile?] <dev-haskell/data-default-0.6:=[profile?]
+ >=dev-haskell/http-conduit-2.1:=[profile?] <dev-haskell/http-conduit-2.2:=[profile?]
+ >=dev-haskell/http-types-0.7:=[profile?] <dev-haskell/http-types-0.9:=[profile?]
+ >=dev-haskell/lifted-base-0.1:=[profile?] <dev-haskell/lifted-base-0.3:=[profile?]
+ >=dev-haskell/monad-control-0.3:=[profile?]
+ >=dev-haskell/mtl-2:=[profile?] <dev-haskell/mtl-3:=[profile?]
+ >=dev-haskell/network-2:=[profile?] <dev-haskell/network-3:=[profile?]
+ >=dev-haskell/old-locale-1:=[profile?] <dev-haskell/old-locale-2:=[profile?]
+ >=dev-haskell/resourcet-1.1:=[profile?] <dev-haskell/resourcet-1.2:=[profile?]
+ >=dev-haskell/safe-0.3:=[profile?] <dev-haskell/safe-0.4:=[profile?]
+ >=dev-haskell/scientific-0.3:=[profile?]
+ >=dev-haskell/tagged-0.7:=[profile?] <dev-haskell/tagged-0.9:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?]
+ >=dev-haskell/unordered-containers-0.2:=[profile?]
+ >=dev-haskell/utf8-string-0.3:=[profile?] <dev-haskell/utf8-string-1.1:=[profile?]
+ >=dev-haskell/vector-0.10:=[profile?]
+ >=dev-haskell/xml-conduit-1.2:=[profile?] <dev-haskell/xml-conduit-1.4:=[profile?]
+ >=dev-lang/ghc-7.6.1:=
+ examples? ( >=dev-haskell/errors-1.4:=[profile?] <dev-haskell/errors-2.0:=[profile?]
+ dev-haskell/exceptions:=[profile?]
+ >=dev-haskell/transformers-0.3:=[profile?] <dev-haskell/transformers-0.5:=[profile?] )
+ !examples? ( >=dev-haskell/transformers-0.2.2:=[profile?] <dev-haskell/transformers-0.5:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.16.0
+ test? ( >=dev-haskell/aeson-0.7
+ >=dev-haskell/errors-1.4.7 <dev-haskell/errors-2.0
+ >=dev-haskell/http-client-0.3
+ >=dev-haskell/lifted-base-0.2
+ >=dev-haskell/mtl-2.1
+ >=dev-haskell/quickcheck-2.7
+ >=dev-haskell/quickcheck-instances-0.3
+ >=dev-haskell/tasty-0.8
+ >=dev-haskell/tasty-quickcheck-0.8
+ >=dev-haskell/text-1.1
+ >=dev-haskell/transformers-base-0.4
+ !examples? ( >=dev-haskell/transformers-0.3 ) )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag examples examples)
+}
diff --git a/dev-haskell/aws/files/aws-0.11.3-ghc-7.10.patch b/dev-haskell/aws/files/aws-0.11.3-ghc-7.10.patch
new file mode 100644
index 000000000000..4d2db5d35a5f
--- /dev/null
+++ b/dev-haskell/aws/files/aws-0.11.3-ghc-7.10.patch
@@ -0,0 +1,20 @@
+--- aws-0.11.3-orig/aws.cabal 2015-03-24 05:26:53.000000000 +1100
++++ aws-0.11.3/aws.cabal 2015-04-04 10:18:21.057164803 +1100
+@@ -126,7 +126,7 @@
+ cryptohash >= 0.11 && < 0.12,
+ data-default >= 0.5.3 && < 0.6,
+ directory >= 1.0 && < 1.3,
+- filepath >= 1.1 && < 1.4,
++ filepath >= 1.1 && < 1.5,
+ http-conduit >= 2.1 && < 2.2,
+ http-types >= 0.7 && < 0.9,
+ lifted-base >= 0.1 && < 0.3,
+--- aws-0.11.3-orig/Examples/DynamoDb.hs 2015-03-24 05:26:53.000000000 +1100
++++ aws-0.11.3/Examples/DynamoDb.hs 2015-04-04 10:18:43.712140567 +1100
+@@ -1,5 +1,6 @@
+ {-# LANGUAGE OverloadedStrings #-}
+ {-# LANGUAGE ScopedTypeVariables #-}
++{-# LANGUAGE FlexibleContexts #-}
+
+ module Main where
+
diff --git a/dev-haskell/aws/metadata.xml b/dev-haskell/aws/metadata.xml
new file mode 100644
index 000000000000..53aa761ab0c6
--- /dev/null
+++ b/dev-haskell/aws/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ Bindings for Amazon Web Services (AWS), with the aim of supporting all AWS services. To see a high level overview of the library, see the README at &lt;https://github.com/aristidb/aws/blob/master/README.org&gt;.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">aristidb/aws</remote-id>
+ </upstream>
+</pkgmetadata>