summaryrefslogtreecommitdiff
path: root/dev-go
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2024-07-16 15:04:19 -0500
committerWilliam Hubbs <williamh@gentoo.org>2024-07-16 15:04:19 -0500
commit4a2a50d1a4e4ef8d537dd2fba73b8ffc9f96a370 (patch)
treec2e69c25435f6fb6638fe24d202f419bf20cba3c /dev-go
parentdev-go/go-dep-tarball: mark ALLARCHES (diff)
downloadgentoo-4a2a50d1a4e4ef8d537dd2fba73b8ffc9f96a370.tar.gz
gentoo-4a2a50d1a4e4ef8d537dd2fba73b8ffc9f96a370.tar.bz2
gentoo-4a2a50d1a4e4ef8d537dd2fba73b8ffc9f96a370.zip
dev-go/go-dep-tarball: drop 0
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-go')
-rw-r--r--dev-go/go-dep-tarball/files/go-dep-tarball-059
-rw-r--r--dev-go/go-dep-tarball/go-dep-tarball-0.ebuild17
2 files changed, 0 insertions, 76 deletions
diff --git a/dev-go/go-dep-tarball/files/go-dep-tarball-0 b/dev-go/go-dep-tarball/files/go-dep-tarball-0
deleted file mode 100644
index d630445fa770..000000000000
--- a/dev-go/go-dep-tarball/files/go-dep-tarball-0
+++ /dev/null
@@ -1,59 +0,0 @@
-#!/bin/bash
-# Copyright (c) 2024, William Hubbs
-# All rights reserved.
-#
-# Redistribution and use in source and binary forms, with or without
-# modification, are permitted provided that the following conditions are met:
-#
-# 1. Redistributions of source code must retain the above copyright notice,
-# this list of conditions and the following disclaimer.
-# 2. Redistributions in binary form must reproduce the above copyright
-# notice, this list of conditions and the following disclaimer in the
-# documentation and/or other materials provided with the distribution.
-# 3. Neither the name of the copyright holder nor the names of its
-# contributors may be used to endorse or promote products derived from
-# this software without specific prior written permission.
-#
-# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDER AND CONTRIBUTORS "AS IS"
-# AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
-# IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
-# ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE
-# LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
-# CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
-# SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
-# INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
-# CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
-# ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
-# POSSIBILITY OF SUCH DAMAGE.
-
-set -e
-shopt -s lastpipe
-
-if [[ -z $1 ]]; then
-printf "%s\n" "no tarball name specified" >&2
-exit 1
-fi
-
-if [[ ! -f go.mod ]]; then
-printf "%s %s\n" "${PWD}" "does not contain a go project" >&2
-exit 1
-fi
-
-work=$(mktemp -d -p '' dep-tarball-XXXXXX)
-export GOMODCACHE="${work}"/go-mod
-go mod download -modcacherw
-mapfile -t mod_paths < <(find . -mindepth 2 -name go.mod -print)
-for p in "${mod_paths[@]}"; do
- printf "entering %s\n" "${p%/go.mod}"
- pushd "${p%/go.mod}" > /dev/null
- go mod download -modcacherw
- popd > /dev/null
-done
-find "${GOMODCACHE}/cache/download" -type f -name '*.zip' -delete
-(
-cd "${work}"
-XZ_OPT='-T0 -9' \
-tar --owner 0 --group 0 --posix -acf "${1}"-deps.tar.xz go-mod
-rm -fr go-mod
-)
-mv "${work}"/*xz .
diff --git a/dev-go/go-dep-tarball/go-dep-tarball-0.ebuild b/dev-go/go-dep-tarball/go-dep-tarball-0.ebuild
deleted file mode 100644
index 33119de78872..000000000000
--- a/dev-go/go-dep-tarball/go-dep-tarball-0.ebuild
+++ /dev/null
@@ -1,17 +0,0 @@
-# Copyright 2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DESCRIPTION="script to package go dependencies"
-HOMEPAGE=""
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~loong ~mips ~ppc64 ~riscv ~s390 ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
-
-S="${WORKDIR}"
-
-src_install() {
- newbin "${FILESDIR}/go-dep-tarball-0" go-dep-tarball
-}