summaryrefslogtreecommitdiff
path: root/dev-go
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2016-01-22 15:44:09 -0800
committerZac Medico <zmedico@gentoo.org>2016-01-22 15:44:09 -0800
commit2ead2b6100c93033dbd0f634371d04fbf782bace (patch)
treecfa55e719a19194de1c5033049de44ebbbede345 /dev-go
parentsys-kernel/gentoo-sources: amd64 stable wrt bug 572384 (diff)
downloadgentoo-2ead2b6100c93033dbd0f634371d04fbf782bace.tar.gz
gentoo-2ead2b6100c93033dbd0f634371d04fbf782bace.tar.bz2
gentoo-2ead2b6100c93033dbd0f634371d04fbf782bace.zip
dev-go/go-tools: fix "tipgodoc does not exist" error (bug 572650)
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-go')
-rw-r--r--dev-go/go-tools/go-tools-0_pre20160121.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/dev-go/go-tools/go-tools-0_pre20160121.ebuild b/dev-go/go-tools/go-tools-0_pre20160121.ebuild
index a2030fb98d45..381504ad6f86 100644
--- a/dev-go/go-tools/go-tools-0_pre20160121.ebuild
+++ b/dev-go/go-tools/go-tools-0_pre20160121.ebuild
@@ -98,7 +98,16 @@ src_install() {
# bug 558818: install binaries in $GOROOT/bin to avoid file collisions
exeinto "$(go env GOROOT)/bin"
- doexe bin/* "${T}/goroot/bin/godoc" "${T}/gopath/bin/tipgodoc"
+ doexe bin/* "${T}/goroot/bin/godoc"
+ # Since tipgodoc has been known to be installed in either
+ # GOROOT or GOPATH, handle either case (bug 572650). It likely
+ # depends on what is currently installed, as is often the case
+ # for weird issues like this with go.
+ if [[ -e ${T}/gopath/bin/tipgodoc ]]; then
+ doexe "${T}/gopath/bin/tipgodoc"
+ else
+ doexe "${T}/goroot/bin/tipgodoc"
+ fi
dodir /usr/bin
ln "${ED}$(go env GOROOT)/bin/godoc" "${ED}usr/bin/godoc" || die