summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2023-01-14 13:51:19 +0100
committerDavid Seifert <soap@gentoo.org>2023-01-14 13:51:19 +0100
commited468028e725c9580a7b2ee02d6b7b9375f7a0b2 (patch)
tree3a39616d9a763db526cec9d2562da20ec1c456a8 /dev-embedded
parentsci-mathematics/form: bump to 4.3.0 (diff)
downloadgentoo-ed468028e725c9580a7b2ee02d6b7b9375f7a0b2.tar.gz
gentoo-ed468028e725c9580a7b2ee02d6b7b9375f7a0b2.tar.bz2
gentoo-ed468028e725c9580a7b2ee02d6b7b9375f7a0b2.zip
*/*: remove py3.8 from PYTHON_COMPAT
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-embedded')
-rw-r--r--dev-embedded/esptool/esptool-3.3.1.ebuild4
-rw-r--r--dev-embedded/esptool/esptool-3.3.2.ebuild4
-rw-r--r--dev-embedded/esptool/esptool-4.2.1.ebuild4
-rw-r--r--dev-embedded/esptool/esptool-4.3.ebuild4
-rw-r--r--dev-embedded/esptool/esptool-4.4.ebuild4
-rw-r--r--dev-embedded/libftdi/libftdi-0.20-r1.ebuild4
-rw-r--r--dev-embedded/libftdi/libftdi-1.5-r4.ebuild4
-rw-r--r--dev-embedded/libftdi/libftdi-9999.ebuild4
-rw-r--r--dev-embedded/nodemcu-uploader/nodemcu-uploader-1.0.0.ebuild4
-rw-r--r--dev-embedded/platformio/platformio-6.1.5.ebuild4
-rw-r--r--dev-embedded/rpi-eeprom/rpi-eeprom-13.19_p1.ebuild4
-rw-r--r--dev-embedded/rpi-eeprom/rpi-eeprom-13.3_p1-r1.ebuild4
-rw-r--r--dev-embedded/rpi-eeprom/rpi-eeprom-15.0_p1.ebuild4
13 files changed, 26 insertions, 26 deletions
diff --git a/dev-embedded/esptool/esptool-3.3.1.ebuild b/dev-embedded/esptool/esptool-3.3.1.ebuild
index fb5d371d3bb7..0cda006a3dcf 100644
--- a/dev-embedded/esptool/esptool-3.3.1.ebuild
+++ b/dev-embedded/esptool/esptool-3.3.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 2021-2022 Gentoo Authors
+# Copyright 2021-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{9..10} )
DISTUTILS_SINGLE_IMPL=1
inherit distutils-r1
diff --git a/dev-embedded/esptool/esptool-3.3.2.ebuild b/dev-embedded/esptool/esptool-3.3.2.ebuild
index 80fed540a0c6..4c1b59d3dce1 100644
--- a/dev-embedded/esptool/esptool-3.3.2.ebuild
+++ b/dev-embedded/esptool/esptool-3.3.2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 2021-2022 Gentoo Authors
+# Copyright 2021-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_COMPAT=( python3_{9..11} )
DISTUTILS_USE_PEP517=setuptools
DISTUTILS_SINGLE_IMPL=1
diff --git a/dev-embedded/esptool/esptool-4.2.1.ebuild b/dev-embedded/esptool/esptool-4.2.1.ebuild
index 16c7d1459d52..cdfa690dbb34 100644
--- a/dev-embedded/esptool/esptool-4.2.1.ebuild
+++ b/dev-embedded/esptool/esptool-4.2.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 2021-2022 Gentoo Authors
+# Copyright 2021-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{9..10} )
DISTUTILS_SINGLE_IMPL=1
inherit distutils-r1
diff --git a/dev-embedded/esptool/esptool-4.3.ebuild b/dev-embedded/esptool/esptool-4.3.ebuild
index f10c855044bc..98189323de60 100644
--- a/dev-embedded/esptool/esptool-4.3.ebuild
+++ b/dev-embedded/esptool/esptool-4.3.ebuild
@@ -1,9 +1,9 @@
-# Copyright 2021-2022 Gentoo Authors
+# Copyright 2021-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_COMPAT=( python3_{9..11} )
DISTUTILS_USE_PEP517=setuptools
DISTUTILS_SINGLE_IMPL=1
diff --git a/dev-embedded/esptool/esptool-4.4.ebuild b/dev-embedded/esptool/esptool-4.4.ebuild
index 07050b96b1bc..073e18b731fd 100644
--- a/dev-embedded/esptool/esptool-4.4.ebuild
+++ b/dev-embedded/esptool/esptool-4.4.ebuild
@@ -1,9 +1,9 @@
-# Copyright 2021-2022 Gentoo Authors
+# Copyright 2021-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_COMPAT=( python3_{9..11} )
DISTUTILS_USE_PEP517=setuptools
DISTUTILS_SINGLE_IMPL=1
diff --git a/dev-embedded/libftdi/libftdi-0.20-r1.ebuild b/dev-embedded/libftdi/libftdi-0.20-r1.ebuild
index f0468fddf592..726eafcea6cb 100644
--- a/dev-embedded/libftdi/libftdi-0.20-r1.ebuild
+++ b/dev-embedded/libftdi/libftdi-0.20-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{9..10} )
inherit cmake python-single-r1
if [[ ${PV} == 9999* ]] ; then
diff --git a/dev-embedded/libftdi/libftdi-1.5-r4.ebuild b/dev-embedded/libftdi/libftdi-1.5-r4.ebuild
index 903865676551..ef8da75061c4 100644
--- a/dev-embedded/libftdi/libftdi-1.5-r4.ebuild
+++ b/dev-embedded/libftdi/libftdi-1.5-r4.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{9..10} )
inherit cmake python-single-r1
MY_P="${PN}1-${PV}"
diff --git a/dev-embedded/libftdi/libftdi-9999.ebuild b/dev-embedded/libftdi/libftdi-9999.ebuild
index e59e64110b94..52d409b5cacd 100644
--- a/dev-embedded/libftdi/libftdi-9999.ebuild
+++ b/dev-embedded/libftdi/libftdi-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{9..10} )
inherit cmake python-single-r1
MY_P="${PN}1-${PV}"
diff --git a/dev-embedded/nodemcu-uploader/nodemcu-uploader-1.0.0.ebuild b/dev-embedded/nodemcu-uploader/nodemcu-uploader-1.0.0.ebuild
index f8f4861793bb..d6a6dde13414 100644
--- a/dev-embedded/nodemcu-uploader/nodemcu-uploader-1.0.0.ebuild
+++ b/dev-embedded/nodemcu-uploader/nodemcu-uploader-1.0.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7..10} )
+PYTHON_COMPAT=( python3_{9..10} )
inherit distutils-r1
DESCRIPTION="Simple tool for uploading files to the filesystem of an ESP8266 running NodeMCU"
diff --git a/dev-embedded/platformio/platformio-6.1.5.ebuild b/dev-embedded/platformio/platformio-6.1.5.ebuild
index d19bf8c9d53a..ca5e00e204c5 100644
--- a/dev-embedded/platformio/platformio-6.1.5.ebuild
+++ b/dev-embedded/platformio/platformio-6.1.5.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_SINGLE_IMPL=1
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{9..10} )
inherit distutils-r1 udev
diff --git a/dev-embedded/rpi-eeprom/rpi-eeprom-13.19_p1.ebuild b/dev-embedded/rpi-eeprom/rpi-eeprom-13.19_p1.ebuild
index b16bae43e922..aa705d4d9dbc 100644
--- a/dev-embedded/rpi-eeprom/rpi-eeprom-13.19_p1.ebuild
+++ b/dev-embedded/rpi-eeprom/rpi-eeprom-13.19_p1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_COMPAT=( python3_{9..11} )
inherit python-r1 systemd
diff --git a/dev-embedded/rpi-eeprom/rpi-eeprom-13.3_p1-r1.ebuild b/dev-embedded/rpi-eeprom/rpi-eeprom-13.3_p1-r1.ebuild
index de2223baedb2..492ca6b9da32 100644
--- a/dev-embedded/rpi-eeprom/rpi-eeprom-13.3_p1-r1.ebuild
+++ b/dev-embedded/rpi-eeprom/rpi-eeprom-13.3_p1-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{9..10} )
inherit python-r1 systemd
diff --git a/dev-embedded/rpi-eeprom/rpi-eeprom-15.0_p1.ebuild b/dev-embedded/rpi-eeprom/rpi-eeprom-15.0_p1.ebuild
index b16bae43e922..aa705d4d9dbc 100644
--- a/dev-embedded/rpi-eeprom/rpi-eeprom-15.0_p1.ebuild
+++ b/dev-embedded/rpi-eeprom/rpi-eeprom-15.0_p1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_COMPAT=( python3_{9..11} )
inherit python-r1 systemd