summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2021-10-07 20:21:06 +0200
committerJakov Smolić <jsmolic@gentoo.org>2021-10-07 20:54:02 +0200
commit443eda5bdbf9ecbd8b056a9800361028c582ec39 (patch)
tree6657eed4293cd4a6036c151f5684930d3c86f7a7 /dev-embedded/parapin/parapin-1.5.0-r1.ebuild
parentsys-fs/genext2fs: add 1.5.0 (diff)
downloadgentoo-443eda5bdbf9ecbd8b056a9800361028c582ec39.tar.gz
gentoo-443eda5bdbf9ecbd8b056a9800361028c582ec39.tar.bz2
gentoo-443eda5bdbf9ecbd8b056a9800361028c582ec39.zip
dev-embedded/parapin: Fix tc-directly
- Port to EAPI-8 - Remove broken docs compilation Closes: https://bugs.gentoo.org/722632 Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Diffstat (limited to 'dev-embedded/parapin/parapin-1.5.0-r1.ebuild')
-rw-r--r--dev-embedded/parapin/parapin-1.5.0-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-embedded/parapin/parapin-1.5.0-r1.ebuild b/dev-embedded/parapin/parapin-1.5.0-r1.ebuild
new file mode 100644
index 000000000000..eb1ca039789c
--- /dev/null
+++ b/dev-embedded/parapin/parapin-1.5.0-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="A parallel port pin programming library"
+HOMEPAGE="http://parapin.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+
+LICENSE="LGPL-2.1"
+IUSE="doc"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-tc-directly.patch
+)
+
+src_compile() {
+ tc-export AR CC
+ # Note 2.4 and 2.6 makefiles are identical for the targets used
+ emake -f Makefile-2.4
+}
+
+src_install() {
+ einstalldocs
+ dolib.a libparapin.a
+ insopts -m0444; insinto /usr/include; doins parapin.h
+
+ if use doc; then
+ cd examples || die
+ docinto examples
+ dodoc *.c
+ fi
+}