summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-embedded/libftd2xx
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-embedded/libftd2xx')
-rw-r--r--dev-embedded/libftd2xx/Manifest3
-rw-r--r--dev-embedded/libftd2xx/libftd2xx-0.4.16-r1.ebuild48
-rw-r--r--dev-embedded/libftd2xx/libftd2xx-1.1.12-r1.ebuild44
-rw-r--r--dev-embedded/libftd2xx/metadata.xml10
4 files changed, 105 insertions, 0 deletions
diff --git a/dev-embedded/libftd2xx/Manifest b/dev-embedded/libftd2xx/Manifest
new file mode 100644
index 000000000000..0adb118c06ac
--- /dev/null
+++ b/dev-embedded/libftd2xx/Manifest
@@ -0,0 +1,3 @@
+DIST libftd2xx0.4.16.tar.gz 2124501 SHA256 84e2b90c2d553837d30d435fa5e4e353a4c051a51b50a07251cdd59ada7a4a96 SHA512 3a945bd31750dafd08cb86e875263e4fdb7a641676e91caf12420769ff12b505e34ec3a88d80dd43590d039c2ace280f166d1ebda2dcc399fb696d9f6c298f20 WHIRLPOOL 3377cf086fa62d8e363f4e5456fd180361fd47c1b0074059e5a55a2f765c936af91c15ff84c26a05df734c365771d50e68387adaf8cd083fa63dc0ae8929e641
+DIST libftd2xx0.4.16_x86_64.tar.gz 2099109 SHA256 b80233143de6b8077ade3e7d9c9819a2c0a4dbf4fd9fbff756b72d656dc611ec SHA512 e11ffa917560b6fb974092bcd89ef95f21651a3ce84d0bc7cc7647c4fe031368209db3b4ab52f8d6240ee89c2e6335e89135d4f358c4271284f8a830655608a9 WHIRLPOOL ad8bfe48e30ea20dd422cc2047bc8c06b4c9f225044fdc1fd96d3fa3876f894cea9094dfaffb1ec94c4decf2b89ebb802d7a60fd62ce3f5919b921877b7a039a
+DIST libftd2xx1.1.12.tar.gz 950540 SHA256 644951c1d7eeac05b0a648a105fd84ba14b0b20250f6b70f1a63e69d2f6b2579 SHA512 afe0a8a7ccc47eb8888346dabdbfb41e182f7dadee7a57a1c4ffce544aebe5cab45c3e64de4ebeebdc0f31961617a79cbcf11dadfebde65ee79ca38e6234995a WHIRLPOOL e56228f9c42aebeb0c425ea20a89466ac07615a943e9ddb7585762315a581026a1e59df60ed0813c78b8a28842728545276dc3c697a6c9624b66ef8fc3e08a7a
diff --git a/dev-embedded/libftd2xx/libftd2xx-0.4.16-r1.ebuild b/dev-embedded/libftd2xx/libftd2xx-0.4.16-r1.ebuild
new file mode 100644
index 000000000000..4f01cc7ef527
--- /dev/null
+++ b/dev-embedded/libftd2xx/libftd2xx-0.4.16-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit multilib
+
+MY_P="${PN}${PV}"
+
+DESCRIPTION="Library that allows a direct access to a USB device"
+HOMEPAGE="http://www.ftdichip.com/Drivers/D2XX.htm"
+SRC_URI="amd64? ( http://www.ftdichip.com/Drivers/D2XX/Linux/${MY_P}_x86_64.tar.gz )
+ x86? ( http://www.ftdichip.com/Drivers/D2XX/Linux/${MY_P}.tar.gz )"
+
+LICENSE="FTDI LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+QA_PREBUILT="*"
+
+S=${WORKDIR}
+
+src_install() {
+ use x86 && cd ${MY_P}
+ use amd64 && cd ${MY_P}_x86_64
+
+ into /opt
+ dolib.so ${PN}.so.${PV}
+ dosym ${PN}.so.${PV} /opt/$(get_libdir)/${PN}.so.${PV:0:1}
+ dosym ${PN}.so.${PV:0:1} /opt/$(get_libdir)/${PN}.so
+ insinto /usr/include
+ doins ftd2xx.h WinTypes.h
+
+ dodir /etc/env.d
+ echo "LDPATH=\"/opt/$(get_libdir)\"" > ${D}/etc/env.d/50libftd2xx || die
+ if use examples ; then
+ find sample lib_table '(' -name '*.so' -o -name '*.[oa]' ')' -exec rm -f {} +
+ insinto /usr/share/doc/${PF}
+ doins -r sample
+ insinto /usr/share/doc/${PF}/sample
+ doins -r lib_table
+ fi
+
+ dodoc Config.txt
+ use x86 && dodoc faq.txt readme.dat
+ use amd64 && dodoc FAQ.txt README.dat
+}
diff --git a/dev-embedded/libftd2xx/libftd2xx-1.1.12-r1.ebuild b/dev-embedded/libftd2xx/libftd2xx-1.1.12-r1.ebuild
new file mode 100644
index 000000000000..3bb2bfe3cf6a
--- /dev/null
+++ b/dev-embedded/libftd2xx/libftd2xx-1.1.12-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit multilib
+
+MY_P="${PN}${PV}"
+
+DESCRIPTION="Library that allows a direct access to a USB device"
+HOMEPAGE="http://www.ftdichip.com/Drivers/D2XX.htm"
+SRC_URI="http://www.ftdichip.com/Drivers/D2XX/Linux/${MY_P}.tar.gz"
+
+LICENSE="FTDI LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="examples"
+
+QA_PREBUILT="*"
+
+S=${WORKDIR}
+
+src_install() {
+
+ use arm && cd "${S}"/release/build/arm926
+ use amd64 && cd "${S}"/release/build/x86_64
+ use x86 && cd "${S}"/release/build/i386
+
+ into /opt
+ dolib.so ${PN}.so.${PV}
+ dosym ${PN}.so.${PV} /opt/$(get_libdir)/${PN}.so.${PV:0:1}
+ dosym ${PN}.so.${PV:0:1} /opt/$(get_libdir)/${PN}.so
+ insinto /usr/include
+ doins "${S}"/release/ftd2xx.h "${S}"/release/WinTypes.h
+
+ dodir /etc/env.d
+ echo "LDPATH=\"/opt/$(get_libdir)\"" > ${D}/etc/env.d/50libftd2xx || die
+ if use examples ; then
+ insinto /usr/share/doc/${PF}/sample
+ doins -r "${S}"/release/examples
+ fi
+
+ dodoc "${S}"/release/ReadMe.txt
+}
diff --git a/dev-embedded/libftd2xx/metadata.xml b/dev-embedded/libftd2xx/metadata.xml
new file mode 100644
index 000000000000..11dd73f4383c
--- /dev/null
+++ b/dev-embedded/libftd2xx/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>proxy-maintainers</herd>
+<maintainer>
+ <email>brendan@horan.hk</email>
+ <name>Brendan Horan</name>
+ <description>Proxy maintainer. Assign bugs to him</description>
+</maintainer>
+</pkgmetadata>