summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHolger Hoffstätte <holger@applied-asynchrony.com>2024-04-13 15:58:37 +0200
committerMike Gilbert <floppym@gentoo.org>2024-05-20 11:52:38 -0400
commit844fbd1e96beda0fb94ea06aba8f2618bfdad1f7 (patch)
treea4aa0f9e765204372f49307260ba063f061acf99 /dev-debug
parentdev-debug/sysdig: add a missed <cstdint> include on musl (diff)
downloadgentoo-844fbd1e96beda0fb94ea06aba8f2618bfdad1f7.tar.gz
gentoo-844fbd1e96beda0fb94ea06aba8f2618bfdad1f7.tar.bz2
gentoo-844fbd1e96beda0fb94ea06aba8f2618bfdad1f7.zip
dev-debug/sysdig: don't try to link against libanl on musl
libanl is an empty stub library since glibc-2.34 and does not exist on musl. Since sysdig uses c-ares and therefore does not even need glibc's async name lookups, we can safely remove it when building on musl. Bug: https://bugs.gentoo.org/929227 Bug: https://bugs.gentoo.org/929907 Signed-off-by: Holger Hoffstätte <holger@applied-asynchrony.com> Closes: https://github.com/gentoo/gentoo/pull/36237 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'dev-debug')
-rw-r--r--dev-debug/sysdig/files/0.29.3-libs-no-libanl.patch16
-rw-r--r--dev-debug/sysdig/sysdig-0.29.3-r2.ebuild12
2 files changed, 25 insertions, 3 deletions
diff --git a/dev-debug/sysdig/files/0.29.3-libs-no-libanl.patch b/dev-debug/sysdig/files/0.29.3-libs-no-libanl.patch
new file mode 100644
index 000000000000..16563aee8ca0
--- /dev/null
+++ b/dev-debug/sysdig/files/0.29.3-libs-no-libanl.patch
@@ -0,0 +1,16 @@
+
+Remove libanl from list of linked libraries as it is not needed at all
+and does not exist on musl.
+
+--- libs-e5c53d648f3c4694385bbe488e7d47eaa36c229a/userspace/libsinsp/CMakeLists.txt~ 2022-03-25 09:50:03.000000000 +0000
++++ libs-e5c53d648f3c4694385bbe488e7d47eaa36c229a/userspace/libsinsp/CMakeLists.txt 2024-04-13 13:40:53.222240196 +0000
+@@ -230,8 +230,7 @@ if(NOT WIN32)
+
+ if(NOT MUSL_OPTIMIZED_BUILD)
+ list(APPEND SINSP_LIBRARIES
+- rt
+- anl)
++ rt)
+ endif()
+
+ else()
diff --git a/dev-debug/sysdig/sysdig-0.29.3-r2.ebuild b/dev-debug/sysdig/sysdig-0.29.3-r2.ebuild
index 7262049544d9..64902719ed6b 100644
--- a/dev-debug/sysdig/sysdig-0.29.3-r2.ebuild
+++ b/dev-debug/sysdig/sysdig-0.29.3-r2.ebuild
@@ -46,9 +46,15 @@ DEPEND="${RDEPEND}
PDEPEND="modules? ( =dev-debug/scap-driver-${PV}* )"
src_prepare() {
- # manually apply patch to falcosecurity-libs dependency
- pushd "${WORKDIR}" && \
- eapply -p0 "${FILESDIR}/${PV}-libs-gcc13.patch" && \
+ # manually apply patches to falcosecurity-libs dependency
+ pushd "${WORKDIR}"
+ # gcc13 needs explicit <cstdint>
+ eapply -p0 "${FILESDIR}/${PV}-libs-gcc13.patch" || die
+
+ # musl has no libanl (#929227)
+ if [ ${ELIBC} == "musl" ] ; then
+ eapply -p0 "${FILESDIR}/${PV}-libs-no-libanl.patch" || die
+ fi
popd
# force C++14 standard for libs & main