summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-05-26 18:17:49 -0400
committerSam James <sam@gentoo.org>2024-05-27 00:11:05 +0100
commit7dacecf376120d114419b41885bcfa01ed1d981e (patch)
tree83004ef0919519562b3ad31a952f6a91311f4063 /dev-debug
parentsys-apps/portage: backport more tweaks to implicit func. decl QA check (diff)
downloadgentoo-7dacecf376120d114419b41885bcfa01ed1d981e.tar.gz
gentoo-7dacecf376120d114419b41885bcfa01ed1d981e.tar.bz2
gentoo-7dacecf376120d114419b41885bcfa01ed1d981e.zip
dev-debug/valgrind: add whitelist for false positive configure implicit decls
The issue here is, yet again, that clang is a trash compiler and cannot handle sensible diagnostic output. It warns you for implicit function decls because it doesn't permit nested function definitions, *after* it tells you that it doesn't permit the nested function. Instead of just telling you that the former is forbidden. Closes: https://bugs.gentoo.org/900396 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-debug')
-rw-r--r--dev-debug/valgrind/valgrind-3.22.0-r2.ebuild7
-rw-r--r--dev-debug/valgrind/valgrind-3.23.0.ebuild7
-rw-r--r--dev-debug/valgrind/valgrind-9999.ebuild7
3 files changed, 21 insertions, 0 deletions
diff --git a/dev-debug/valgrind/valgrind-3.22.0-r2.ebuild b/dev-debug/valgrind/valgrind-3.22.0-r2.ebuild
index b9204af91b7b..86ec190689c8 100644
--- a/dev-debug/valgrind/valgrind-3.22.0-r2.ebuild
+++ b/dev-debug/valgrind/valgrind-3.22.0-r2.ebuild
@@ -53,6 +53,13 @@ PATCHES=(
"${FILESDIR}"/0004-Bug-478624-Valgrind-incompatibility-with-binutils-2..patch
)
+QA_CONFIG_IMPL_DECL_SKIP+=(
+ # "checking if gcc accepts nested functions" but clang cannot handle good
+ # errors and reports both "function definition is not allowed here" and
+ # -Wimplicit-function-declaration. bug #900396
+ foo
+)
+
src_prepare() {
# Correct hard coded doc location
sed -i -e "s:doc/valgrind:doc/${PF}:" docs/Makefile.am || die
diff --git a/dev-debug/valgrind/valgrind-3.23.0.ebuild b/dev-debug/valgrind/valgrind-3.23.0.ebuild
index efcec418f726..48014039f07e 100644
--- a/dev-debug/valgrind/valgrind-3.23.0.ebuild
+++ b/dev-debug/valgrind/valgrind-3.23.0.ebuild
@@ -55,6 +55,13 @@ PATCHES=(
# From stable branch
)
+QA_CONFIG_IMPL_DECL_SKIP+=(
+ # "checking if gcc accepts nested functions" but clang cannot handle good
+ # errors and reports both "function definition is not allowed here" and
+ # -Wimplicit-function-declaration. bug #900396
+ foo
+)
+
src_prepare() {
# Correct hard coded doc location
sed -i -e "s:doc/valgrind:doc/${PF}:" docs/Makefile.am || die
diff --git a/dev-debug/valgrind/valgrind-9999.ebuild b/dev-debug/valgrind/valgrind-9999.ebuild
index efcec418f726..48014039f07e 100644
--- a/dev-debug/valgrind/valgrind-9999.ebuild
+++ b/dev-debug/valgrind/valgrind-9999.ebuild
@@ -55,6 +55,13 @@ PATCHES=(
# From stable branch
)
+QA_CONFIG_IMPL_DECL_SKIP+=(
+ # "checking if gcc accepts nested functions" but clang cannot handle good
+ # errors and reports both "function definition is not allowed here" and
+ # -Wimplicit-function-declaration. bug #900396
+ foo
+)
+
src_prepare() {
# Correct hard coded doc location
sed -i -e "s:doc/valgrind:doc/${PF}:" docs/Makefile.am || die