summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz@gentoo.org>2024-08-08 00:15:15 -0400
committerEli Schwartz <eschwartz@gentoo.org>2024-08-08 12:06:27 -0400
commitcccb407280eee0285757834c1cd0769a9a30e8f6 (patch)
tree955bdeeab2e29045af11f2efd54eef2b92203e2e /dev-db
parentdev-db/percona-xtrabackup: mark as LTO-unsafe (diff)
downloadgentoo-cccb407280eee0285757834c1cd0769a9a30e8f6.tar.gz
gentoo-cccb407280eee0285757834c1cd0769a9a30e8f6.tar.bz2
gentoo-cccb407280eee0285757834c1cd0769a9a30e8f6.zip
dev-db/percona-xtrabackup: fix automagic dependencies
There were some dependencies which we tried to link to, which are usually bundled but we ask for system copies. However, we didn't properly depend on it -- and in the case of procps, even though it is in @system we do want to enforce a subslot dependency on it, so it really shouldn't be left out. rapidjson doesn't actually work. You can try to unbundle it but it will simply error out because rapidjson hasn't been released since 2016 (despite active development, they simply ghost anyone requesting a release) and percona states they are using newer features... there is an error check if you try to force system rapidjson and whatever they need isn't present. Signed-off-by: Eli Schwartz <eschwartz@gentoo.org>
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/percona-xtrabackup/percona-xtrabackup-8.0.30.23-r1.ebuild (renamed from dev-db/percona-xtrabackup/percona-xtrabackup-8.0.30.23.ebuild)15
1 files changed, 13 insertions, 2 deletions
diff --git a/dev-db/percona-xtrabackup/percona-xtrabackup-8.0.30.23.ebuild b/dev-db/percona-xtrabackup/percona-xtrabackup-8.0.30.23-r1.ebuild
index fd790e55724c..3ec110a05eb1 100644
--- a/dev-db/percona-xtrabackup/percona-xtrabackup-8.0.30.23.ebuild
+++ b/dev-db/percona-xtrabackup/percona-xtrabackup-8.0.30.23-r1.ebuild
@@ -26,6 +26,7 @@ KEYWORDS="amd64 x86"
DEPEND="
app-arch/lz4:0=
+ app-arch/zstd:=
app-editors/vim-core
dev-libs/icu:=
dev-libs/libaio
@@ -37,11 +38,12 @@ DEPEND="
dev-libs/libgpg-error
dev-libs/openssl:0=
dev-libs/protobuf:=
- dev-libs/rapidjson
dev-libs/re2:=
dev-python/sphinx
net-misc/curl
- sys-libs/zlib:="
+ sys-libs/zlib:=
+ sys-process/procps:=
+"
RDEPEND="
${DEPEND}
@@ -66,6 +68,13 @@ src_prepare() {
eerror "Ebuild Boost version: ${MY_BOOST_VERSION}"
die "Ebuild needs to fix MY_BOOST_VERSION!"
fi
+
+ local extra
+ # rapidjson: last released in 2016 and totally unviable to devendor
+ # lz4: in storage/innobase/xtrabackup/src/CMakeLists.txt it is used even when =system
+ for extra in curl icu libcbor libedit libevent libfido2 zlib zstd; do
+ rm -r "extra/${extra}/" || die "failed to remove bundled libs"
+ done
}
src_configure() {
@@ -85,6 +94,8 @@ src_configure() {
-DWITH_BOOST="${WORKDIR}/boost_$(ver_rs 1- _ ${MY_BOOST_VERSION})"
-DWITH_MAN_PAGES=ON
-DWITH_SYSTEM_LIBS=ON
+ # not handled via SYSTEM_LIBS
+ -DWITH_ZLIB=system
)
cmake_src_configure