summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2024-08-05 06:44:15 +0000
committerPatrick Lauer <patrick@gentoo.org>2024-08-05 06:44:15 +0000
commit91424214b802f5118a599a98d416a41ed792df06 (patch)
treeea0925c52ed1f7d2b6615c36f8d261b6a5d7624e /dev-db
parentwww-apps/grafana-bin: add 10.2.9, 10.3.7 (diff)
downloadgentoo-91424214b802f5118a599a98d416a41ed792df06.tar.gz
gentoo-91424214b802f5118a599a98d416a41ed792df06.tar.bz2
gentoo-91424214b802f5118a599a98d416a41ed792df06.zip
dev-db/barman: add 3.10.1
Signed-off-by: Patrick Lauer <patrick@gentoo.org>
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/barman/Manifest1
-rw-r--r--dev-db/barman/barman-3.10.1.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-db/barman/Manifest b/dev-db/barman/Manifest
index 888a8fdff7a4..db91b4265796 100644
--- a/dev-db/barman/Manifest
+++ b/dev-db/barman/Manifest
@@ -1,2 +1,3 @@
DIST barman-3.10.0.tar.gz 1851778 BLAKE2B 8e481676ae8a41e5a38a206966e26523237ee13f7201d219c405f355795e9755778d5495be3274bb67a931820b069d96be21adbcefc471380f98cd5f41fc1a08 SHA512 d01f4e940a46964aa8359614195c2bdc423c5a57e18331ccd798e0d52a2bd8f6adf299d42c5e1ac47ece5100cb1a828093badd8e1b181b20e4480cf368c8d1d0
+DIST barman-3.10.1.tar.gz 1852417 BLAKE2B d678ab90608684cbbc5c5196810bf4a4aa1a356f3f0b1157c112219d40151cbfc7d5b79857fa97147958eec34cfc2f7d2a2c4047417978d6f97b0f503fd5e08f SHA512 6fdecd83d8bc58d3712e825cdd2c691f5749c3e7fd0b7ec0807020f1a1ebc06b7c2a4640f8638264afa0250f0c2ccd86373ad7418ba6f25cdd8f2768788635ed
DIST barman-3.9.0.tar.gz 1819096 BLAKE2B 712ec047f9409014495afd868a9bbe889b6b2d54a511770a95e9c62513d7042673b7c1ebec31d45729211a1da0e55dfdc5cdc0ef62d84e7efa26b2b9fbff5feb SHA512 e5b4796a470f43e4ea79383defabd31cd4d33d8dfc06495bc4485bd1bc5cfab701c3719567bcc302de3f157e9ef08a6848776daa2cf9c537fb2829b7931111fd
diff --git a/dev-db/barman/barman-3.10.1.ebuild b/dev-db/barman/barman-3.10.1.ebuild
new file mode 100644
index 000000000000..7fbafde8ce5e
--- /dev/null
+++ b/dev-db/barman/barman-3.10.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517="setuptools"
+PYTHON_COMPAT=( python3_{10..13} )
+
+RESTRICT="test" # missing azure sdk
+
+inherit distutils-r1
+
+DESCRIPTION="Administration tool for disaster recovery of PostgreSQL servers"
+HOMEPAGE="https://www.pgbarman.org https://sourceforge.net/projects/pgbarman/"
+SRC_URI="https://github.com/2ndquadrant-it/barman/archive/release/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-release-${PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/boto3[${PYTHON_USEDEP}]
+ dev-python/argh[${PYTHON_USEDEP}]
+ dev-python/psycopg:2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/argcomplete[${PYTHON_USEDEP}]
+ net-misc/rsync
+ dev-db/postgresql[server]
+"
+
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/python-snappy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ default
+
+ sed -i -e \
+ "s/^ def test_xlog_segment_mask(.*:/ @pytest.mark.xfail(reason='Test fails on Gentoo')\n\0/" \
+ tests/test_xlog.py || die
+}