summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-04-27 02:09:59 +0100
committerSam James <sam@gentoo.org>2024-04-27 02:09:59 +0100
commit87c7b4704b5a0e5dd7f02b0d21f59fdf3ef1999b (patch)
tree81877cadda718926198b92cf896f477a848cfce4 /dev-db
parentnet-vpn/pptpd: fix Modern C issue (diff)
downloadgentoo-87c7b4704b5a0e5dd7f02b0d21f59fdf3ef1999b.tar.gz
gentoo-87c7b4704b5a0e5dd7f02b0d21f59fdf3ef1999b.tar.bz2
gentoo-87c7b4704b5a0e5dd7f02b0d21f59fdf3ef1999b.zip
dev-db/firebird: filter LTO, no SA, no lifetime DSE
Bug: https://gcc.gnu.org/PR107078 Bug: https://github.com/FirebirdSQL/firebird/issues/5384 Bug: https://github.com/FirebirdSQL/firebird/issues/7308 Closes: https://bugs.gentoo.org/917662 Closes: https://bugs.gentoo.org/924659 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/firebird/firebird-3.0.10.33601.0-r1.ebuild8
-rw-r--r--dev-db/firebird/firebird-3.0.4.33054.0-r2.ebuild6
2 files changed, 11 insertions, 3 deletions
diff --git a/dev-db/firebird/firebird-3.0.10.33601.0-r1.ebuild b/dev-db/firebird/firebird-3.0.10.33601.0-r1.ebuild
index cf1793d314a8..5fd90979b8e5 100644
--- a/dev-db/firebird/firebird-3.0.10.33601.0-r1.ebuild
+++ b/dev-db/firebird/firebird-3.0.10.33601.0-r1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
MY_P=${PN/f/F}-$(ver_rs 4 '-')
-inherit autotools flag-o-matic
+inherit autotools flag-o-matic toolchain-funcs
DESCRIPTION="Relational database offering many ANSI SQL:2003 and some SQL:2008 features"
HOMEPAGE="https://www.firebirdsql.org/"
@@ -91,6 +91,10 @@ src_prepare() {
-e 's:ISQL :FBSQL :w /dev/stdout' \
src/msgs/messages2.sql | wc -l)" "6" "src/msgs/messages2.sql" # 6 lines
+ # bug #917662, bug #924659
+ filter-lto
+ append-flags -fno-strict-aliasing $(test-flags-CXX -fno-lifetime-dse)
+
# use gentoo's CXXFLAGS instead of whatever firebird decided on
# doesn't replace all firebird's CXXFLAGS, but at least this is last,
# so it can do some overrides
diff --git a/dev-db/firebird/firebird-3.0.4.33054.0-r2.ebuild b/dev-db/firebird/firebird-3.0.4.33054.0-r2.ebuild
index 171554c2aebe..6f2ba7ca3b89 100644
--- a/dev-db/firebird/firebird-3.0.4.33054.0-r2.ebuild
+++ b/dev-db/firebird/firebird-3.0.4.33054.0-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -93,6 +93,10 @@ src_configure() {
filter-flags -fprefetch-loop-arrays
filter-mfpmath sse
+ # bug #917662, bug #924659
+ filter-lto
+ append-flags -fno-strict-aliasing $(test-flags-CXX -fno-lifetime-dse)
+
# otherwise this doesnt build with gcc-6
# http://tracker.firebirdsql.org/browse/CORE-5099
append-cflags -fno-sized-deallocation -fno-delete-null-pointer-checks