summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2023-03-13 16:42:17 +0100
committerAgostino Sarubbo <ago@gentoo.org>2023-03-13 16:42:17 +0100
commit76fd5bb6f159da7c95da454bd41d339f6814d235 (patch)
tree5fa3d2ef2ff99df53413ed9e15c3661f0b8c4f38 /dev-db
parentwww-apps/moodle: version bumps to 3.11.13, 4.0.7, 4.1.2 (diff)
downloadgentoo-76fd5bb6f159da7c95da454bd41d339f6814d235.tar.gz
gentoo-76fd5bb6f159da7c95da454bd41d339f6814d235.tar.bz2
gentoo-76fd5bb6f159da7c95da454bd41d339f6814d235.zip
dev-db/pg_activity: version bump to 3.1.1
Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/pg_activity/Manifest1
-rw-r--r--dev-db/pg_activity/pg_activity-3.1.1.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-db/pg_activity/Manifest b/dev-db/pg_activity/Manifest
index 07c5628d9961..2b62cedf973a 100644
--- a/dev-db/pg_activity/Manifest
+++ b/dev-db/pg_activity/Manifest
@@ -1 +1,2 @@
DIST pg_activity-3.0.1.tar.gz 421148 BLAKE2B cd6c97878671ca3881363b5ee7a67f3c6ed8f50ce36b57e087f818609e557f2d12e0405268b3c297939c31b254b0a6bce98d270954a8743645a04b86587ec778 SHA512 2a57d26090d862731b62494231005fdb13c7a132f7425a74f57c57dc004e4da61e39342d86386df4a08e5780c1f0fc170ccf962faa0872799586129e96743e30
+DIST pg_activity-3.1.1.tar.gz 427382 BLAKE2B a46090bca01f5b2bc73770df82acddeff17acab36b416f21b2a761cd1dc1631211bbac35a78ce94572824a6c269ad542c513f6a260f569adc21ae64150c767d3 SHA512 c8cd7812109d8237e4183e410723d978f219e5adf6e3fa6e3cc0dddf4bf6065df64b72a036004a1c59b96ff8eadfe96b06833b699177b29defccd47ddb55c8ff
diff --git a/dev-db/pg_activity/pg_activity-3.1.1.ebuild b/dev-db/pg_activity/pg_activity-3.1.1.ebuild
new file mode 100644
index 000000000000..987d27b7f245
--- /dev/null
+++ b/dev-db/pg_activity/pg_activity-3.1.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Realtime PostgreSQL database server monitoring tool"
+HOMEPAGE="https://github.com/dalibo/pg_activity"
+SRC_URI="https://github.com/dalibo/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+SLOT="0"
+LICENSE="POSTGRESQL"
+
+RDEPEND="
+ dev-python/attrs[${PYTHON_USEDEP}]
+ dev-python/blessed[${PYTHON_USEDEP}]
+ dev-python/humanize[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ dev-python/attrs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/psycopg:0[${PYTHON_USEDEP}]
+ dev-python/psycopg:2[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # https://github.com/dalibo/pg_activity/issues/201
+ export COLUMNS="80"
+ epytest -k 'not test_ui.txt and not test_data.py'
+}
+
+src_install() {
+ distutils-r1_src_install
+ doman docs/man/${PN}.1
+}