summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-db/oracle-instantclient-basic/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-db/oracle-instantclient-basic/files')
-rw-r--r--dev-db/oracle-instantclient-basic/files/11.2.0.3-makefile.patch57
-rw-r--r--dev-db/oracle-instantclient-basic/files/oracle-instantclient-basic-10.2.0.3-makefile.patch11
-rw-r--r--dev-db/oracle-instantclient-basic/files/tnsnames.ora.sample93
3 files changed, 161 insertions, 0 deletions
diff --git a/dev-db/oracle-instantclient-basic/files/11.2.0.3-makefile.patch b/dev-db/oracle-instantclient-basic/files/11.2.0.3-makefile.patch
new file mode 100644
index 000000000000..efcc2c6fac7c
--- /dev/null
+++ b/dev-db/oracle-instantclient-basic/files/11.2.0.3-makefile.patch
@@ -0,0 +1,57 @@
+Fake demo_xe.mk found in Oracle eXpress Edition,
+known by CPAN DBD::Oracle (bug#165834).
+This provides absolute paths for headers and libraries.
+
+Paranoia drops those REMOVE lines.
+--- sdk/demo/demo.mk.orig 2012-03-06 17:11:57.636990449 +0100
++++ sdk/demo/demo.mk 2012-03-06 17:19:37.985324293 +0100
+@@ -28,8 +28,9 @@
+ CC=/opt/SunProd/SUNWspro6.1/bin/CC
+ cc=/opt/SunProd/SUNWspro6.1/bin/cc
+
+-ICINCHOME=../
+-ICLIBHOME=../../
++LIBDIR=lib
++ICINCHOME=$(ORACLE_HOME)/
++ICLIBHOME=$(ORACLE_HOME)/$(LIBDIR)
+ ICLIBPATH=-L$(ICLIBHOME)
+ THREADLIBS=-lthread
+ CCLIB=$(ICLIBPATH) -locci -lclntsh $(THREADLIBS)
+@@ -64,18 +64,18 @@
+ all: clean buildoci $(OCCIDEMO) $(OCCIOBJDEMO)
+
+ buildoci: $(CLNCACHE) $(LIBCLNT) $(CDEMOOBJS)
+- $(MKLINK) $(ICLIBHOME)libclntsh$(SO_EXT).11.1 $(ICLIBHOME)libclntsh$(SO_EXT)
+- $(MKLINK) $(ICLIBHOME)libocci$(SO_EXT).11.1 $(ICLIBHOME)libocci$(SO_EXT)
++# $(MKLINK) $(ICLIBHOME)libclntsh$(SO_EXT).11.1 $(ICLIBHOME)libclntsh$(SO_EXT)
++# $(MKLINK) $(ICLIBHOME)libocci$(SO_EXT).11.1 $(ICLIBHOME)libocci$(SO_EXT)
+ $(CC) -o $(CDEMOEXE) $(LDFLAGS) $(CDEMOOBJS) $(CCLIB)
+- $(REMOVE) $(ICLIBHOME)libclntsh$(SO_EXT)
+- $(REMOVE) $(ICLIBHOME)libocci$(SO_EXT)
++# $(REMOVE) $(ICLIBHOME)libclntsh$(SO_EXT)
++# $(REMOVE) $(ICLIBHOME)libocci$(SO_EXT)
+
+ buildocci: $(CLNCACHE) $(LIBCLNT) $(OBJS)
+- $(MKLINK) $(ICLIBHOME)libclntsh$(SO_EXT).11.1 $(ICLIBHOME)libclntsh$(SO_EXT)
+- $(MKLINK) $(ICLIBHOME)libocci$(SO_EXT).11.1 $(ICLIBHOME)libocci$(SO_EXT)
++# $(MKLINK) $(ICLIBHOME)libclntsh$(SO_EXT).11.1 $(ICLIBHOME)libclntsh$(SO_EXT)
++# $(MKLINK) $(ICLIBHOME)libocci$(SO_EXT).11.1 $(ICLIBHOME)libocci$(SO_EXT)
+ $(CC) -o $(EXE) $(LDFLAGS) $(OBJS) $(CCLIB)
+- $(REMOVE) $(ICLIBHOME)libclntsh$(SO_EXT)
+- $(REMOVE) $(ICLIBHOME)libocci$(SO_EXT)
++# $(REMOVE) $(ICLIBHOME)libclntsh$(SO_EXT)
++# $(REMOVE) $(ICLIBHOME)libocci$(SO_EXT)
+
+ $(OCCIDEMO):
+ $(MAKE) -f $(MAKEFILE) buildocci OBJS=$@.o EXE=$@
+@@ -93,8 +93,8 @@
+
+ cleancache:
+ $(REMOVE) $(CACHEDIR)
+- $(REMOVE) $(ICLIBHOME)libclntsh$(SO_EXT)
+- $(REMOVE) $(ICLIBHOME)libocci$(SO_EXT)
++# $(REMOVE) $(ICLIBHOME)libclntsh$(SO_EXT)
++# $(REMOVE) $(ICLIBHOME)libocci$(SO_EXT)
+
+ clean: $(CLNCACHE)
+ $(REMOVE) cdemo81 cdemo81.o occidml occidml.o occiobj occiobj.o occiobjo* occiobjm* occiobj.h occiobjout.type
diff --git a/dev-db/oracle-instantclient-basic/files/oracle-instantclient-basic-10.2.0.3-makefile.patch b/dev-db/oracle-instantclient-basic/files/oracle-instantclient-basic-10.2.0.3-makefile.patch
new file mode 100644
index 000000000000..80df560a1014
--- /dev/null
+++ b/dev-db/oracle-instantclient-basic/files/oracle-instantclient-basic-10.2.0.3-makefile.patch
@@ -0,0 +1,11 @@
+--- instantclient_10_2/sdk/demo/demo.mk.orig 2007-02-06 17:51:47.018247041 -0800
++++ instantclient_10_2/sdk/demo/demo.mk 2007-02-06 17:52:35.374869934 -0800
+@@ -30,7 +30,7 @@
+
+ ICINCHOME=../
+ ICLIBHOME=../../
+-ICLIBPATH=-L$(ICLIBHOME)
++ICLIBPATH=-L$(ICLIBHOME) -L$(ORACLE_HOME)/lib
+ THREADLIBS=-lthread
+ CCLIB=$(ICLIBPATH) -locci -lclntsh $(THREADLIBS)
+
diff --git a/dev-db/oracle-instantclient-basic/files/tnsnames.ora.sample b/dev-db/oracle-instantclient-basic/files/tnsnames.ora.sample
new file mode 100644
index 000000000000..f0524f5993cd
--- /dev/null
+++ b/dev-db/oracle-instantclient-basic/files/tnsnames.ora.sample
@@ -0,0 +1,93 @@
+# This file contains the syntax information for
+# the entries to be put in any tnsnames.ora file
+# The entries in this file are need based.
+# There are no defaults for entries in this file
+# that Sqlnet/Net3 use that need to be overridden
+#
+# Typically you could have two tnsnames.ora files
+# in the system, one that is set for the entire system
+# and is called the system tnsnames.ora file, and a
+# second file that is used by each user locally so that
+# he can override the definitions dictated by the system
+# tnsnames.ora file.
+
+# The entries in tnsnames.ora are an alternative to using
+# the names server with the onames adapter.
+# They are a collection of aliases for the addresses that
+# the listener(s) is(are) listening for a database or
+# several databases.
+
+# The following is the general syntax for any entry in
+# a tnsnames.ora file. There could be several such entries
+# tailored to the user's needs.
+
+<alias>= [ (DESCRIPTION_LIST = # Optional depending on whether u have
+ # one or more descriptions
+ # If there is just one description, unnecessary ]
+ (DESCRIPTION=
+ [ (SDU=2048) ] # Optional, defaults to 2048
+ # Can take values between 512 and 32K
+ [ (ADDRESS_LIST= # Optional depending on whether u have
+ # one or more addresses
+ # If there is just one address, unnecessary ]
+ (ADDRESS=
+ [ (COMMUNITY=<community_name>) ]
+ (PROTOCOL=tcp)
+ (HOST=<hostname>)
+ (PORT=<portnumber (1521 is a standard port used)>)
+ )
+ [ (ADDRESS=
+ (PROTOCOL=ipc)
+ (KEY=<ipckey (PNPKEY is a standard key used)>)
+ )
+ ]
+ [ (ADDRESS=
+ [ (COMMUNITY=<community_name>) ]
+ (PROTOCOL=decnet)
+ (NODE=<nodename>)
+ (OBJECT=<objectname>)
+ )
+ ]
+ ... # More addresses
+ [ ) ] # Optional depending on whether ADDRESS_LIST is used or not
+ [ (CONNECT_DATA=
+ (SID=<oracle_sid>)
+ [ (GLOBAL_NAME=<global_database_name>) ]
+ )
+ ]
+ [ (SOURCE_ROUTE=yes) ]
+ )
+ (DESCRIPTION=
+ [ (SDU=2048) ] # Optional, defaults to 2048
+ # Can take values between 512 and 32K
+ [ (ADDRESS_LIST= ] # Optional depending on whether u have more
+ # than one address or not
+ # If there is just one address, unnecessary
+ (ADDRESS
+ [ (COMMUNITY=<community_name>) ]
+ (PROTOCOL=tcp)
+ (HOST=<hostname>)
+ (PORT=<portnumber (1521 is a standard port used)>)
+ )
+ [ (ADDRESS=
+ (PROTOCOL=ipc)
+ (KEY=<ipckey (PNPKEY is a standard key used)>)
+ )
+ ]
+ ... # More addresses
+ [ ) ] # Optional depending on whether ADDRESS_LIST
+ # is being used
+ [ (CONNECT_DATA=
+ (SID=<oracle_sid>)
+ [ (GLOBAL_NAME=<global_database_name>) ]
+ )
+ ]
+ [ (SOURCE_ROUTE=yes) ]
+ )
+ [ (CONNECT_DATA=
+ (SID=<oracle_sid>)
+ [ (GLOBAL_NAME=<global_database_name>) ]
+ )
+ ]
+ ... # More descriptions
+ [ ) ] # Optional depending on whether DESCRIPTION_LIST is used or not