summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-08-21 18:23:52 +0100
committerSam James <sam@gentoo.org>2023-08-21 18:27:22 +0100
commite2225439e3338f92b391e7c33d69b12b833c71cb (patch)
tree068877746157f3f6635b9dabddd7c5635b55b7ae /dev-cpp
parentdev-cpp/abseil-cpp: use -std=c++14 instead (diff)
downloadgentoo-e2225439e3338f92b391e7c33d69b12b833c71cb.tar.gz
gentoo-e2225439e3338f92b391e7c33d69b12b833c71cb.tar.bz2
gentoo-e2225439e3338f92b391e7c33d69b12b833c71cb.zip
dev-cpp/abseil-cpp: unmultilibify, at least for now
We're not bumping re2 to the new version which needs abseil as ideally we'll use bundled copies instead. Although as with grpc + protobuf, unclear if we can actually do that given it then tries to install its own abseil. Bug: https://bugs.gentoo.org/912281 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/abseil-cpp/abseil-cpp-20230802.0.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/dev-cpp/abseil-cpp/abseil-cpp-20230802.0.ebuild b/dev-cpp/abseil-cpp/abseil-cpp-20230802.0.ebuild
index b5d25058e213..10dd19ada8e9 100644
--- a/dev-cpp/abseil-cpp/abseil-cpp-20230802.0.ebuild
+++ b/dev-cpp/abseil-cpp/abseil-cpp-20230802.0.ebuild
@@ -5,7 +5,7 @@ EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
-inherit cmake-multilib python-any-r1
+inherit cmake python-any-r1
DESCRIPTION="Abseil Common Libraries (C++), LTS Branch"
HOMEPAGE="https://abseil.io/"
@@ -45,7 +45,7 @@ src_prepare() {
absl/copts/generate_copts.py || die
}
-multilib_src_configure() {
+src_configure() {
local mycmakeargs=(
# We use -std=c++14 here so that abseil-cpp's string_view is used
# See the discussion in https://github.com/gentoo/gentoo/pull/32281.