summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-12 18:36:12 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-12 18:58:13 +0100
commitdf359c8eb436ead66affc6c8e205a8c16555e404 (patch)
tree611b67388a323c19bc7a4e133a620a49ec103d58 /dev-cpp
parentgames-action/prismlauncher: drop 5.1 (diff)
downloadgentoo-df359c8eb436ead66affc6c8e205a8c16555e404.tar.gz
gentoo-df359c8eb436ead66affc6c8e205a8c16555e404.tar.bz2
gentoo-df359c8eb436ead66affc6c8e205a8c16555e404.zip
dev-cpp/libjson-rpc-cpp: Disable coverage-related flags
Closes: https://bugs.gentoo.org/885613 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/libjson-rpc-cpp/libjson-rpc-cpp-1.4.0.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/dev-cpp/libjson-rpc-cpp/libjson-rpc-cpp-1.4.0.ebuild b/dev-cpp/libjson-rpc-cpp/libjson-rpc-cpp-1.4.0.ebuild
index f1b78fc655fc..3d9e42dd0fce 100644
--- a/dev-cpp/libjson-rpc-cpp/libjson-rpc-cpp-1.4.0.ebuild
+++ b/dev-cpp/libjson-rpc-cpp/libjson-rpc-cpp-1.4.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -44,6 +44,8 @@ src_configure() {
-DCOMPILE_STUBGEN=$(usex stubgen)
-DCOMPILE_TESTS=$(usex test)
-DCATCH_INCLUDE_DIR="${EPREFIX}/usr/include/catch2"
+ # disable coverage-related flags
+ -DWITH_COVERAGE=OFF
)
cmake_src_configure