summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-09-03 05:48:44 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-09-03 07:51:17 -0400
commit37681577b557e0c57f7b1e17d4f9bae8de286414 (patch)
treee45b326568cf9dc64e8724db95d8f4f3fee16762 /dev-cpp/rapidyaml
parentgames-engines/devilutionx: add 1.5.3 (diff)
downloadgentoo-37681577b557e0c57f7b1e17d4f9bae8de286414.tar.gz
gentoo-37681577b557e0c57f7b1e17d4f9bae8de286414.tar.bz2
gentoo-37681577b557e0c57f7b1e17d4f9bae8de286414.zip
dev-cpp/rapidyaml: add 0.7.2 (unkeyworded)
See ebuild comment. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-cpp/rapidyaml')
-rw-r--r--dev-cpp/rapidyaml/Manifest3
-rw-r--r--dev-cpp/rapidyaml/rapidyaml-0.7.2.ebuild97
2 files changed, 100 insertions, 0 deletions
diff --git a/dev-cpp/rapidyaml/Manifest b/dev-cpp/rapidyaml/Manifest
index 0e0a6986813e..2197240b2ad2 100644
--- a/dev-cpp/rapidyaml/Manifest
+++ b/dev-cpp/rapidyaml/Manifest
@@ -1,4 +1,7 @@
DIST c4fs-0ee9c03d0ef3a7f12db6cb03570aa7606f12ba1b.tar.gz 25156 BLAKE2B 864a6a75c5ebe15d73fb6ffa5a83cd6448f37a0f465bf3992fc5bc1000f06d6e945c99b9a4f8f3625499c47ea719a49dd340d11e37c11ed759d1adcb1ea585be SHA512 58149c055b1f87abb12a01b042600a2927bfe7afeb878ca4523b658b0736aff6f752cd579c748cf9d4c85b4229ea50a1e70d633f85f9041fe157765286fa5233
+DIST c4fs-59cfbae26b821f4d4c50ff0775219cb739fa7f46.tar.gz 25149 BLAKE2B 8c8fbc59112e5a2e5d2a9aa8a0dc6665466ca309b78bbd5fe0203489bd8823097c79ff09f0dd1d33595f5b052fc95bde911580b8b083ee63f349a7fd0d0dde86 SHA512 3a76522f230c26bbe3b893421b1785259a79a4e7e01f83a2530f35af5d2a10195e4b85cfad6e8a6942715120f3c3b7f3eec3e95ac043ac5b47029dcd0ee8c3cf
DIST c4log-457a2997e8ea26ea2a659b8152621f7fead1eb48.tar.gz 12056 BLAKE2B f0dc357c8beb28b2fa73e77f85918c3285be08a6e6c750317b7babddfc2372532d56b29a01adbc2284b7e850aeb2a45f1b24599acca0d0feccf5d60c00432627 SHA512 f728b34c000bbd58ad02d003697de1185feffc1a349600153a7d851f8dac28b88433e97c81dcb14769a74faa9e3d86b297536e8764d6e00b886f11bb2343518f
+DIST c4log-f4cf64caedd622a739aaa3ecb67a5aac105c2919.tar.gz 12076 BLAKE2B a5d09011d65aabad37f6821430a48e2ab0808863c34c750c7685f3de4b112251a6c7679b5d8962e83f3fe0847cbc9d80b791ec58907a4ee613dda950c947b553 SHA512 097c4566ad4f2906299e544ee067b01369433b654590cf4cf87cb56017caa5757ba037fef5ed1fd00c143a59e8d66013b07a28ad014903d761919a5ddda7c9d1
DIST rapidyaml-0.6.0-src.tgz 7384217 BLAKE2B b81f797dcdac10368231256765bff08fa9d911550b620c286a657b41e74e589701a41d4f6e33317a7149fd1a2aabbad6bac6c66c1e494db053251e20bc5e505c SHA512 6637aa970919d76339ca7d3d131032ca97720650e275f7e285c0fa46671daf8638695c4db6ccb06f93671171110c445781a7f2c8e37f6d9a4951d6e649f60cde
+DIST rapidyaml-0.7.2-src.tgz 10139792 BLAKE2B f50005a313414073281258ed66d973adb9cf22995bf8742727b5f1910f05065bb14baac7273e437c450f72e984b713680a83951706f0cc0564113c406a07748c SHA512 076420688d9e230627ec48013928ede74a65980c1bf5335a187270f90958eb15af11e7958379e4915dbd35723f2eadfb425531a460fb0a0467559f9d1ba34b6e
DIST yaml-test-suite-6e6c296ae9c9d2d5c4134b4b64d01b29ac19ff6f.tar.gz 99765 BLAKE2B d55a605623c988a4c58daa6dd155980129ffefe86570d55b1ce2514dfa77c352e0467b12e95d6e2bd38cc0454f0b30c3109c088841ddbe423b8bbb7d9e41bc9b SHA512 4ab0e52369d085e696196ef1aab8ecb4f0218e48e8ce33c4ecc863942639141601cb1c83b41027eceddc20a6a4cebfc51abcb83779007e890b87d79c76394946
diff --git a/dev-cpp/rapidyaml/rapidyaml-0.7.2.ebuild b/dev-cpp/rapidyaml/rapidyaml-0.7.2.ebuild
new file mode 100644
index 000000000000..107332c03e0e
--- /dev/null
+++ b/dev-cpp/rapidyaml/rapidyaml-0.7.2.ebuild
@@ -0,0 +1,97 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake flag-o-matic
+
+# see no-download.patch, match with release date if "master"
+HASH_C4FS=59cfbae26b821f4d4c50ff0775219cb739fa7f46
+HASH_C4LOG=f4cf64caedd622a739aaa3ecb67a5aac105c2919
+HASH_YAMLTS=6e6c296ae9c9d2d5c4134b4b64d01b29ac19ff6f
+
+DESCRIPTION="Library to parse and emit YAML, and do it fast"
+HOMEPAGE="https://github.com/biojppm/rapidyaml/"
+SRC_URI="
+ https://github.com/biojppm/rapidyaml/releases/download/v${PV}/${P}-src.tgz
+ test? (
+ https://github.com/biojppm/c4fs/archive/${HASH_C4FS}.tar.gz
+ -> c4fs-${HASH_C4FS}.tar.gz
+ https://github.com/biojppm/c4log/archive/${HASH_C4LOG}.tar.gz
+ -> c4log-${HASH_C4LOG}.tar.gz
+ https://github.com/yaml/yaml-test-suite/archive/${HASH_YAMLTS}.tar.gz
+ -> yaml-test-suite-${HASH_YAMLTS}.tar.gz
+ )
+"
+S=${WORKDIR}/${P}-src
+
+LICENSE="MIT Boost-1.0 BSD"
+SLOT="0/${PV}"
+# Bumped fwiw, but believe the future of this package is to be last-rited --
+# its build system is a maintenance headache and the only remaining revdep
+# (jsonnet) is not only incompatible with this version but upstream has
+# switched to single-header version and will not be able to easily use
+# system's anymore: https://github.com/google/jsonnet/commit/4003c4df8ee
+#
+# Leaving unkeyworded rather than do extra work until likely last-rites.
+# If kept, will be dropped to m-n given I no longer need this. Feel free
+# to take over and drop this comment if needed.
+#KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="debug test"
+RESTRICT="!test? ( test )"
+
+DEPEND="test? ( dev-cpp/gtest )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.6.0-no-download.patch
+)
+
+DOCS=( README.md ROADMAP.md changelog )
+
+src_prepare() {
+ if use test; then
+ # also need c4core, symlink the one included in src.tgz
+ mv ../c4fs-${HASH_C4FS} ext/c4fs &&
+ rmdir ext/c4fs/ext/c4core &&
+ ln -s ../../c4core ext/c4fs/ext || die
+
+ mv ../c4log-${HASH_C4LOG} ext/c4log &&
+ rmdir ext/c4log/ext/c4core &&
+ ln -s ../../c4core ext/c4log/ext || die
+
+ mv ../yaml-test-suite-${HASH_YAMLTS} ext/yaml-test-suite || die
+
+ eapply "${FILESDIR}"/${PN}-0.3.0-tests-no-install.patch
+ fi
+
+ cmake_src_prepare
+
+ sed -E "/set\(_(ARCHIVE|LIBRARY)_INSTALL/s:lib/:$(get_libdir)/:" \
+ -i ext/c4core/cmake/c4Project.cmake || die
+}
+
+src_configure() {
+ # not looked into, but tests fail with lto and USE=debug fails to build
+ filter-lto
+
+ local mycmakeargs=(
+ -DGIT=false
+ -DRYML_BUILD_TESTS=$(usex test)
+ -DRYML_DBG=$(usex debug)
+ -DRYML_TEST_FUZZ=no
+
+ # TODO?: enable this+tests, should(?) be easier to do with >=0.5.0 but
+ # still need looking into (please file a bug if actually need this now)
+ -DRYML_BUILD_API=no
+
+ # rapidyaml sets c++11, but (system) >=gtest-1.13 wants >=c++14, also
+ # see: https://github.com/biojppm/cmake/commit/e344bf0681 (bug #893272)
+ -DC4_CXX_STANDARD=17
+ )
+
+ cmake_src_configure
+}
+
+src_test() {
+ cmake_build test
+}