summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-08-18 01:10:56 -0400
committerTim Harder <radhermit@gentoo.org>2016-08-18 01:10:56 -0400
commitb2a80b0e1f5841d7870296deaff1c55ffbfdcacb (patch)
treefab2e662151761472ff7e7b1759873dfa3d6c397 /app-vim/gnupg/gnupg-2.6.ebuild
parentapp-vim/gentoo-syntax: remove old (diff)
downloadgentoo-b2a80b0e1f5841d7870296deaff1c55ffbfdcacb.tar.gz
gentoo-b2a80b0e1f5841d7870296deaff1c55ffbfdcacb.tar.bz2
gentoo-b2a80b0e1f5841d7870296deaff1c55ffbfdcacb.zip
app-vim/gnupg: version bump to 2.6
Diffstat (limited to 'app-vim/gnupg/gnupg-2.6.ebuild')
-rw-r--r--app-vim/gnupg/gnupg-2.6.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-vim/gnupg/gnupg-2.6.ebuild b/app-vim/gnupg/gnupg-2.6.ebuild
new file mode 100644
index 000000000000..583108037acf
--- /dev/null
+++ b/app-vim/gnupg/gnupg-2.6.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit vim-plugin
+
+DESCRIPTION="transparent editing of gpg encrypted files"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=3645"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~arm ~x86"
+
+RDEPEND="app-crypt/gnupg"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+src_prepare() {
+ default
+
+ # There's good documentation included with the script, but it's not
+ # in a helpfile. Since there's rather too much information to include
+ # in a VIM_PLUGIN_HELPTEXT, we'll sed ourselves a help doc.
+ mkdir doc
+ sed -e '/" Section: Plugin header.\+$/,9999d' -e 's/^" \?//' \
+ -e 's/\(Name:\s\+\)\([^.]\+\)\.vim/\1*\2.txt*/' \
+ plugin/${PN}.vim \
+ > doc/${PN}.txt
+}